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Introduction to NeuroScript® MovAlyzeR® 
Handwriting Movement Software 

(Draft 14 August 2015) 
 
 
Our mission: Facilitate discoveries and applications with handwriting movement software at 
universities, hospitals, therapy clinics, forensic and private labs.  
 
NeuroScript’s MovAlyzeR has become the leading handwriting movement software: “Measure Motor 
Skill TODAY!” 
 
A. Why Handwriting?  
 
Handwriting is the most taught motor skill worldwide. Yet, few measurement methods exist to 
compare teaching methods.  
 
Handwriting requires the highest speed of the neuromuscular system. Neuromuscular disorder, 
medication, and mental distraction will affect movements and handwriting movements in particular.  
 
Handwritten signatures are the gold standard for signing with pen and paper. The digital equivalent is 
handwritten signatures on electronic pads. This provides also dynamic information. This richer 
information must be included in court disputes. The proper way is to use independent electronic 
signature analysis software like MovAlyzeR. Exemplars recorded on an electronic signature pad 
reveals added information crucial in examining wet signatures.  
 
B. Why MovAlyzeR?  
 
MovAlyzeR is the result of US$4M+ funding by the National Institutes of Health to develop general 
purpose handwriting movement analysis software.  
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The pen tablets available in computer stores enable us to record pen movements at greater 
accuracies than 3D movement tracking equipment that is about 100 times more expensive.  
 
MovAlyzeR helps professionals and students in education, therapy, forensics, neurology, psychiatry, 
and kinesiology can now design, run, process, and analyze handwriting and drawing movement tests 
without special computer skills. Movements are segmented and per segment duration, size, fluency, 
accuracy, … are estimated. The design will be according to scientific standards. It can be replicated 
by others. Each participant tested with MovAlyzeR represents a value of typically US$500 for 
organizations who wish to outsource human movement testing.  
 
 
C. Implement a MovAlyzeR test from scratch 
 
Let us create a handwriting test from scratch, run it, analyze it, and document a result in 30 minutes. 
For example: What differences exist between movements with the left and right hands. 
 
If no pen tablet is available: Use the computer mouse as movement recording device 
 

If you have a pen tablet 
Download the tablet’s Wintab driver from the manufacturer’s website and install it.  
o Select  instead of Mouse: Tablet (in tool bar) 
o If the Tablet option is not available, the proper Wintab driver is not installed properly.  
o Verify the functioning of the tablet via the Tablet Properties in the Control Panel.   
o When changing tablets, the driver may emulate the first tablet. To erase the first tablet: 
Start >All Programs >Tablets >Tablet Preference File Utility >Remove all. 

 
(1) Download MovAlyzeR 
Search the internet for: Handwriting Movement Software. You will find www.neuroscriptsoftware.com 
where you can download MovAlyzeR onto your MS Windows computer. When installing MovAlyzeR it 
will generate a Request Code that needs emailed to Sales@neuroscriptsoftware.com. A Trial 
Activation Code will be emailed. 
 
  

http://www.neuroscriptsoftware.com/
mailto:Sales@neuroscriptsoftware.com
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(2) Start MovAlyzeR 
 
Start >Type: movalyzer, then hit Enter. 
MovAlyzeR will open the first time with Example User UU1. It contains several handwriting tests. You 
can look at those later. 
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Quick Test of Recording Device 
 
Click: Hide Start Page 
Move mouse or pen inside recording window.  
With mouse, keep mouse button pressed or press the pen lightly on the tablet while moving. 

 
 
To Erase: Rightclick in start window >Clear 
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(3) Define yourself as user 
 
Click: File >Users >Create New (Shown as + sign) 
 
Enter User ID  
Enter your name 
 
Additional information is optional 
 
For example: 

 
 
>OK.  
 
You will be prompted to specify the default locations where all your data and the data backup will be.  
 
You can password protect participant’s data with a password. Say No. 
 
>OK 
 
Confirm that new directories will be made (as there were no data yet) 
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(3a) Input Device 
 
The first time the input device needs setup. Say Yes. it will walk you through all steps. Click Next after 
each step. 
 
In general, use the default settings unless you have reasons to alter these. 

 
 
  



Introduction to NeuroScript MovAlyzeR                                       Page 7 of 20 
 
(4) Setup a new experiment 
 
When done you should see a clean user with no items created. 
 
Nearly all instructions are Rightclick actions inside the left window. This window describes the 
hierarchical data structure. 
 

 
 
We will use the basic method which will give you the most control. 
There are other ways, e.g., using the Experiment Setup Wizard (Hold mouse over each of the tools). 
 
Later you could try to import an experiment from User UU1: 
1. Switch to User UU1    File >Users 
2. Export      Rightclick an experiment  >Export.  
3. Switch back to your own user ID 
4. Import      File >Import >Import Experiment 
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 (4a) Create Experiment 
 
An Experiment is a test or a case. The jargon used is from Experimental Psychology. 
 
Rightclick Experiments >Create New 
Enter Experiment ID 
Enter Description  
For example: 

 
 
Device setup for each new and (if you want to called data) each imported experiment 
Each experiment can be produced with another device. 
Click: Input Device >Run Device Setup Wizard 
 
>OK 
 
Experiment properties are the same for all Conditions 
 
Later you can walk through all Experiment Properties and fine tune. These are properties that 
MUST be the same for all conditions (We will introduce different conditions in 4d).  
 
Help 
To obtain help on each Experiment Properties screen (and similarly on every other screen), just hit 
F1. This is a little known standard feature in all MS Windows programs. 
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(4b) Add or Create Group 
 
Under the Groups of participants, define a particular group, for example, Young Adults.  
 
Rightclick on Groups >Add Groups 
Enter: Group ID 
Enter: Description  
For example: 
 

 
>OK 
 
Add the selected Group. 
 
Why Add Each Time?  
 
 “Add” is needed after “OK” because all items you define within a user will be reusable in all future 
experiments.  Under the headings  
Groups,  
Subjects,  
Conditions,  
you will now find all items defined earlier.  
To find where else an item is use, rightclick on it >Relationships  
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(4c) Add or Create Subject 
 
Under Subjects (or Writer, or Participants – A better term but it is longer), define a particular subject, 
for example Test Subject. 
 
Rightclick on Subjects >Add Subjects 
 
Subject ID is filled automatically (This can be disabled in the Settings >User properties). This is handy 
because each Subject ID needs to be unique. In multi-site studies, the ranges of Subject IDs can be 
set differently per site. 
 
Enter a subject code. Note this code needs to be public to protect the identity of research subjects. In 
forensic case work it may be allowed to enter personal information.  
 
For example: 
 

 
>OK 
 
Add the selected Subject.   
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(4d) Add or Create Condition 
 
A condition is a task or situation under which something is written. For example, writing with the right 
and the left hands are 2 different conditions. 
 
Rightclick on Conditions >Add Conditions 
 
Enter Condition ID 
Enter your description 
Enter a 1-line recording window instruction (You can create a multi-line condition instruction window 
later) 
 
For example: 

 
>OK 
 
Add selected condtion. 
 
Condition Properties  Differ Per Condition 
 
Later you can walk through all Condition Properties and fine tune. These are properties that you 
often wish to COMPARE in one experiment, for example, the instruction to write with left or right 
hands.  The sequence of trials can be set in the Experiment Conditions >Running Experiment 
>Procedure. 
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We want to add a SECOND condition to this experiment. 
 
A second condition is a good idea as you now can compare participants when a particular effect 
should and should not occur, respectively.  
 
You can create a second condition like the first one but better is to migrate a second condition from 
the first condition by: 
Rightclick on the particular condition >Duplicate 
 
Alter Condition ID 
Alter your description 
Alter a 1-line recording window instruction (You can create a multi-line condition instruction window 
later) 
 
For example: 

 
>OK 
 
Add selected condtion. 
 
Number of Trials 
 
Each condition as still a few replications (Called Trials) of exactly the same task. By default the 
number of trials is 3. This is the absolute minimum to do comparisons between conditions. The 
number can be set differently for each experiment and condition: Rightclick your condition WITHIN 
and experiment >Number opf trials.  
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(5) Test MovAlyzeR and pen tablet or pen tablet PC 
 
To verify the sampling you could do the following 5 tests in one experiment. Repeat each test at least 
2 times. You can check the processed results immediately after the recording of each trial or you can 
record first all trials and then check the processed results. 
 
TEST1: Draw an capital L shape of 5 cm x 5 cm by threading the lines and stand briefly still at the 
corner. The shape should be aligned with the sides of the tablet. Double-click on the trial and verify in 
the processed XY chart that the measured sizes are 5 cm x 5 cm. 
 
TEST2: Record a slow circle of 2 cm diameter and lasting 5 seconds from pen down to pen up. Circle 
does not need complete. Use a stop watch in your smart phone to time the 5 seconds. What sampling 
rate is measured and shown top left?  
 
TEST3: Record rapid, repetitive circles of 2 cm diameter and lasting 5 seconds from pen down to pen 
up. The sampling rate should be the same as in TEST 2. Double-click on the recording and select as 
Chart: Velocity Spectrum. The part above 10 Hz should be like low-amplitude white noise without 
structure. 
 
TEST4: Draw a rapid, fluent, diagonal line of 5 cm length along a good ruler with the pen upright. 
Rightclick on the recording >Linearity test.  
Ensure:  
View >Detailed Ouput 
is checked.  
Then the output details will be in the lowest window. Move the separators to see more. The test will 
verify whether the sampling rate is constant (Ideally there should be no missing samples or doubls 
samples) and what the RMS error per sample is in cm. This needs reported.  
 
TEST5: Draw a rapid, fluent, diagonal line of 5 cm length along a good ruler with the pen held 
constnatly upright plus reverse the movement with an equally fast line so that you are back at the 
starting point. The lines should cover each other on the screen. If you see an eye shape, the 
sampling rate  
 
 
(6) Run experiment 
 
Running an experiment means testing a subject, one at a time. We could also have called it Run 
Subject  or Test Subject. 
 
Rightclick your subject (e.g., Test Subject) >Run experiment. 
 
Alternative ways to run an experiment are:  
o Select your subject >Click Green arrow 
o Select your subject >Hit F9 
o Run Experiment Wizard (in tool bar) 
o Tree Action (in menu bar) >Subjects >Subject  >Run Experiment 
  
Know how to stop before you begin. 
Normally, experiments end when all trials are done. To stop prematurely, locate and use the tools in 
the toolbar that are grouped with the Run tool (Green arrow). 
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o Stop everything  
o Stop condition  
o Stop recording  
 
What does the subject do during the experiment? 
o Normally there is a subject (research participant) sitting in front of the computer (or pen tablet) 
o Ideally, the experiment needs to be self-explanatory for the subject 
o Reads the 1-line instructions shown in the top window. The instruction disappears by default when 
the movement starts 
o Performs the instruction 
 To “write” with the mouse, keep the mouse button pressed (equivalent with placing pen on 

paper) 
 Starts to produce the instructed task (e.g., circles). 
 When done stop the movement and release the mouse button. The pen-lift time out will end 

the trial. If the subject does not seem to stop, the trial time out will end the trial. These time 
outs are settable in the Experiment Properties >Running Experiment >Trial. 

 Waits for the next task to appear. 
 
What does the experimenter do during the experiment? 
o Normally the experimenter (investigator, supervisor) is sitting next to the tablet and monitors the 
screen.   
o The experimenter see in the left window green check marks for each successfully completed trial. 
o The top left of the recording window lists  
 X and Y coordinates 
 P for “pen pressure”. If there is just a mouse P will be 0 or 99. 
 Sampling rate. This is the true sampling rate. In many cases MovAlyzeR does not obtain the 

correct sampling rate via Acquire. The correct sampling rate is thus only relevant for 
processing, not recording. When the sampling rate is changed, all trials need reprocessed. 
When recording the mouse the sampling rate fails to be constant.  Where the mouse is moving 
fast the rate is maximal. Where the mouse moves very slowly the sampling rate drops, and 
when the mouse does not move te rate will drop to 0. Therefore, the mouse is not reliable for 
duration measurements. For accurate duration measurements a pen tablet with Wintab driver 
is required. 

 Stroke: This is a stroke counter added for your convenience. A stroke is an upward or a 
downward movement. A circle counts for 2 strokes. 

o The red dots are the individual samples collected. The blue line is the connection between 
successive points. Dot and line color and size can be set in the experiment properties. 
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(7) Processing 
 
Immediately after each trial is completed the raw data are stored and also backed up and the data are 
processed. Double click on each trial will yield an analysis chart. The circles mark the up and down 
strokes (Other segmentation methods can be set in the Experiment Properties). 

 
 
Click on the Vertical arrow bottom to walk through all time curves and frequency spectra. 
 
Click in the chart. Use the left and right keyboard arrows to navigate through the signals. 
 
You can have many charts (and numerical views – introduced next) open at the same time. You can 
also have many MovAlyzeRs running at the same time. 
 
All charts (and views) (of the same trial) are synchronized.     



Introduction to NeuroScript MovAlyzeR                                       Page 17 of 20 
 
Numerical Data per Trial 
 
Action >View >Yields various numerical view options. 
The extracted data show per Condition (for example RIG), all trials (for example, 03), all strokes or 
segments, Start Time, Duration, etc (many data). 
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(8) Summarize across groups and subjects and analysis of summary results 
 
When the experiment is completed MovAlyzeR summarizes the subjects and groups collected and 
shows a summary analysis chart. For example 
 

  
 
This is a generic chart which is mostly not appropriate for the present experiment. 
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Customizing Analysis Chart 
 
In the present experiment we wanted to compare the speed (or the stroke duration) between left and 
right hands. Therefore we want to select: 
o X Axis = Condition (Right vs. Left hands) 
o Y Axis = Duration (Duration per up and down stroke) 
o Grouping = Trial (showing results for trials 1, 2, and 3 in one chart). 
o Chart = Averages +- Standard Deviations 
o Refresh 
 

 
 
The chart shows that Condition 1 (Right hand) has stroke durations of about 0.2 s while Condition 2 
(Left hand) has stroke durations of about 0.4 s. Considering the non-overlapping standard deviations 
this difference is likely significant.  
 
Export Chart into Your Document 
 
You can export a chart with: Rightclick in chart >Export Dialog >Export.  
Then paste (Control V) in your MS Word document. 
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(9) Statistics 
 
To obtain all data for your statistical analysis: 
Rightclick your experiment >Summarize >Summarized data 

 
 
 


