
Introduction
MovAlyzeR/ScriptAlyzeR
MovAlyzeR is a movement analysis system designed to measure, record, process and analyze handwriting movements.
The MovAlyzeR and ScriptAlyzeR programs enable professionals in the medical, gerontology, rehabilitation, ergonomics, psychology, psychiatry, physiotherapy, forensic, and educational fields, among others, to obtain immediate, accurate analysis of a person's handwriting, drawing, or other 2-dimensional movements, recorded via mouse or a Wintab-compliant pen tablet. In addition, scanned handwriting images can be processed and analysed.
MovAlyzeR/ScriptAlyzeR can be used with a flat-panel display-digitizer or a tablet PC.

Figure: Processed data chart. The loops written on a pen tablet are processed using a number of steps and displayed.

MovAlyzeR supports drag and drop processing of handwriting images.
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 Figure: (top) Scanned handwriting sample.
            (bottom) Processed output of above sample.

GripAlyzeR Package
o GripAlyzeR software allows recording and processing of 3 analog (differential) signals, using an analog-to-digital converter directly connected to the computer.
o NeuroScript's Gripper measures bimanual force coordination: Grip forces of the left and right hands and the load force while pulling two objects apart.

Gripper Description
The Gripper setup consists of the following:
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Grip Units
l Lower Grip Unit (Housing an Entran load cell: ELPM-T2E-04-25L) . 
l Upper Grip Unit (Entran load cell: ELPM-T2E-04-25L ). 
l Load Sensor (Entran load cell: ELPM-T2E-03-25L).

Device Interface Circuitry
The device interface contains two connector sockets, one to the upper grip (Channel 0) and other for the lower grip (Channel 2) and load (Channel 1). It also has the input for the power supply and a connector pin for a jump cable to connect the power supply to NIDaqpad power input.
Data Acquisition Pad
To record the analog signals, we use a NI-DAQPad-6020E for USB, 100 kS/s, 12-Bit, 16 Analog Input Multi-function DAQPad.
Power Supply
Both the interface circuitry and the NI DAQPad use a common 12V power supply. The power supply is connected to the gripper interface and a short jumper connects the supply to the NIDAQ pad power inlet.
Choose a DC adapter where the + is on the inside of the plug and the - on the outside of the plug, as follows:

Operation:

A typical Gripper task consists of pulling the upper and lower grip units apart while a magnet holds them together. To pull the units apart, apply pressure on the upper and lower grip sensors using the left and right thumbs, as shown in the diagrams above.
The Gripper consists of two units, each with a force sensor for the thumb. The upper and lower units are held together with a magnet of a programmable force.
The thumb force characterizes the grip force when holding the gripper units with all fingers on the opposite side as the thumb.
When instructed to pull the upper and lower units apart, a person with normal force coordination will gradually increase the pulling (or load) force on the upper gripper unit with the right hand while simultaneously increasing the grip force of the lower unit with the left hand.
A disturbance of the proportional increase of grip and load forces may signify a motor control disorder. Lower and Upper refer to the situation when the Gripper is placed vertically on the 
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table. The situation changes trivially when the Gripper is used horizontally (laterally or sagitally).
Measurements:

© NeuroScript LLC. All Rights Reserved.

Signal ID Description of Digitizer Data Description of Gripper data
X Horizontal coordinate Lower grip force (by left/non-dominant hand)
Y Vertical coordinate Upper grip force (by right/dominant hand)
Z Axial Pen pressure Upper load force
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Next>
Video Tutorial: Download and Install (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.

1. Setup
1.1. Visit www.neuroscript.net/download.php

● Register to receive login information 

● Download MovAlyzeR.msi 

● Run install file 

1.2. If using a tablet, install tablet driverORUse mouse as recording device
● Download and install from tablet manufacturer's website
● Connect Tablet
● TEST tablet driver:Start >Control Panel >Tablet

Disclaimer: This information is provided as a courtesy. The Driver Downloads image taken from wacom.com

MovAlyzeR Tutorial
NeuroScript MovAlyzeR Help Send comments on this topic.
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Extras

Next>
See Also

SetupNext: StartCreate New UserDevice SetupExperiment Setup

1.3. Start MovAlyzeR

Click Start > All Programs > NeuroScript> MovAlyzeR > MovAlyzeR

1.4. Activate MovAlyzeR 

Automatically at first launch of MovAlyzeR

Manual request online
OR
Email request code to sales@neuroscript.net

Context sensitive help
Hit the F1 key to read help on the current window within MovAlyzeR

Symbol legend
View > Symbol Legend to look up MovAlyzeR symbols
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Run ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force Coordination

© NeuroScript LLC. All Rights Reserved.

<Previous Next>
Video Tutorial: Start MovAlyzeR (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
2. Start

Extras

2.1. Click Start > All Programs > NeuroScript > MovAlyzeR > MovAlyzeR

TEST MovAlyzeR:
Write with mouse or tablet pen in recording window 

 Run Example Experiment in user UU1
Run Experiment
Click File >Run Experiment >Simulated Loops E01 > Next>Group G01 > Next>Subject SSS > Next>Finish
Record data
Write the sequence llll when the recording starts. Repeat for all trials.
Process data
After the recording is finished, the data is processed automatically. Processed trials have a green check mark compared to a grey check for unprocessed trials.
View processed data
Double click on the trial to chart processed data OR

Start
NeuroScript MovAlyzeR Help Send comments on this topic.
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<Previous Next>
See Also

Prev: SetupStartNext: Create New UserDevice SetupExperiment SetupRun ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments
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<Previous Next>
Video Tutorial: Create new user (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
3. Create New User

Right click trial to choose the data you want to view.
Example Experiments
E01 Simulated loopsEX1 Hick’s lawEX2 Stimulus-response compatibilityEX3 Fitts’ lawEX9 Signals with known featuresIMG Mirror – image tracingLAY Menu experimentLEA Learning experiment

 Test Tablet Accuracy
Click Settings >Test input device

3.1. File > Users

Each USER is a MovAlyzeR workspace with individual settings and experiments

Create New User
NeuroScript MovAlyzeR Help Send comments on this topic.
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3.2. Click  to create a new user 

3.3. Click Path and Settings to assign folder locations 
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Extras

<Previous Next>
See Also

SetupPrev: StartCreate New UserNext: Device SetupExperiment SetupRun ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments

Multi-site Team
Multiple users can share the same data path
Right click experiment name > Client server > Upload or Download on LAN server
File > Import > Remote Data Import Wizard to remote URL

Disaster Recovery
Automate backup of raw data when produced
File > Backup > History > Restore to restore any previous backup
User database backup offered after each change
Backup directory on a separate device for greater safety against data loss.
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<Previous Next>
Video Tutorial: Device setup (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
4. Device Setup

4.1. Automatic first time

Settings >Device Setup Wizard.
New experiments will inherit these settings.
Existing or imported experiments: Right click experiment name> Properties > Input Device 

4.2. Configure Display Settings

Device Setup
NeuroScript MovAlyzeR Help Send comments on this topic.
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4.3. Configure Input Device

Click Acquire to obtain tablet or estimated mouse properties.
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Extras

<Previous Next>
See Also

SetupStartPrev: Create New UserDevice SetupNext: Experiment SetupRun ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments
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<Previous Next>
Video Tutorial: Experiment setup (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
5. Experiment Setup

 Tooltips

Hold mouse over any object to see more details pop up.

5.1. File > Experiment Setup Wizard

Setup 1 group and 1 condition.
Adding more groups or conditions, see Extras. 

Experiment Setup
NeuroScript MovAlyzeR Help Send comments on this topic.
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5.2. New Experiment

Enter ID and description of experiment > Next
Add condition > Next
Add group > Finish 

5.3. Stimuli

MovAlyzeR can generate complex stimuli for experiments
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Right click Condition name > Properties > Stimuli
OR
File > Stimulus Editor

5.4. File > Stimulus Editor
Graphical interface to quickly and easily create and edit stimuli

5.5. Create or Edit Stimuli

Create New Stimulus
File > Stimulus Editor > File > New
OR
Right click Condition name > Properties > 
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Stimuli > Click 

Edit existing Stimulus
Stimulus (tree menu) > Right click Stimulus name > Stimulus Editor

5.6. Export from Stimulus Editor into MovAlyzeR user

Export the stimulus in the Stimulus Editor workspace to the current MovAlyzeR User.
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Extras

5.7. Include stimulus in experiment condition

Right click Condition name > Properties > Stimuli
Choose the stimuli that you want to use.
Click  or  to edit stimulus manually or in the Stimulus Editor

Additional condition's or groups
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Right click your condition or group.

Visual, Interactive, Animated Stimuli
File > Stimulus EditorORRight click Condition name > Properties > Stimuli

Questionnaire – Combining MovAlyzeR Data and Patient Data

1. Build your master list: Settings > Questionnaire
2. Right click Group name > Setup/Modify Questionnaire
3. Right click Subject name > Run/View QuestionnaireORRight click Experiment name > Running Experiment > Procedure > View/ Answer Questionnaire

Experiment properties – Settings you never want to compare between conditions

Right click Experiment name > Properties > Processing > Consistency
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<Previous Next>
See Also

SetupStartCreate New UserPrev: Device SetupExperiment SetupNext: Run ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments

Condition properties – Settings you may want to compare between conditions

Right click Condition name > Properties > Consistency

Password protection

Settings > Password > Change User Password
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<Previous Next>
Video Tutorial: Run experiment (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
6. Run Experiment

Extras

6.1. File > Run Experiment Wizard 

6.2. Select or create experiment, group and subject 

Run Experiment
NeuroScript MovAlyzeR Help Send comments on this topic.
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<Previous Next>
See Also

SetupStartCreate New UserDevice SetupPrev: Experiment SetupRun ExperimentNext: Chart and View TrialsAnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments
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<Previous Next>
Video Tutorial: Chart and view trials (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.
7. Chart and View Trials

Discontinuity Correction – When pen loses data
 Right click on Experiment name> Properties > Advanced > Discontinuity

Patient-centered data recording and analysis interface
 File > MovAlyzeRx

7.1. Double click on a trial to chart Processed Data

Chart and View Trials
NeuroScript MovAlyzeR Help Send comments on this topic.
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Extras

Data is ordered in a tree menu
Each item has a right click menu 

7.2. Click on graph and use Arrow Keys on the keyboard

Click Action or Right click on graph for more options

Visualizing additional curves and data simultaneously
Click Actions > View Extracted DataClick Actions > View Raw DataClick Actions > Chart Processed Data > Select other Chart (e.g. Vy)
Click in a chart and use the keyboard <> Arrow keys to walk through data in time simultaneously in all Data and Chart windows
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SetupStartCreate New UserDevice SetupExperiment SetupPrev: Run ExperimentChart and View TrialsNext: AnalysisScanned Handwriting ImagesBimanual Force CoordinationExample Experiments
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<Previous Next>
Video Tutorial: Summarize and analyze (requires internet connection)
Click on the above link to view a video tutorial of this topic. Depending on the speed of your internet connection, the page may take a while to load and display.

Real-time replay
Right click trial > Chart Data > Chart Processed Data (Real-Time)

3-Dimensional chart
Right click trial > Chart Data > Chart Processed Data (3D)

Analysis
NeuroScript MovAlyzeR Help Send comments on this topic.
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8. Summarize and Analyze

Extras

8.1. Right click your experiment > Summarize all trials

8.2. Right click your experiment > Analyze

 Add your own Attachments
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<Previous Next>
9. Scanned Handwriting Images

MovAlyzeR can be used to process scanned handwriting images. Instead of recording pen movements, scan handwriting images and store on your computer.

Include any file that you want to add as an attachment to the experiment.
Right click Attachments under your Experiment name in tree menu > View Attachments folder
OR
Right click Experiment name > Properties > Attachments

 Statistics export file
Right click Experiment name > Summarize > View Summarized DataOR
Right click Experiment name > Analyze > Actions/ Settings > View Raw Data 

 Statistics export file with questionnaire answers
Right click Experiment name > Summarize > View Summarized DataOR
Right click Experiment name > Analyze > Actions/ Settings > View Raw Data 

Scan 1 line of handwriting and store in PNG, BMP, GIF, JPG or PCX format with 300-600 DPI and 8-bit (256) gray-scale levels.

9.1. Right click your experiment >Properties > Experiment type > Handwriting Image

Scanned Handwriting Images
NeuroScript MovAlyzeR Help Send comments on this topic.
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Raw image files produce also raw handwriting files. To store both handwriting images and recorded handwriting, create 2 identical experiments, one for Handwriting Movements and one for Handwriting Images.

9.2. Drag and drop files into MovAlyzeRORFile > Import > Data Import Wizard
Drag image onto a subject ID in tree menu to import to that subject
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View the Attachments folder (Right click Attachments in the tree menu > Select View Attachments Folder) for more handwriting image samples

9.3. Select condition to add the image trial to that subject

● Drag image into subject ID > Add Condition window pops up automatically. Select existing or add new condition.
● Trial numbers will be assigned automatically. 

9.4. Double click on the trial to show the Processed Image trial
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Extras

The blue squares are the fork and crossing points.The color of the skeleton line indicates line thickness. Yellow=Thin, Green=ThickRed means the segment is smaller than Minimum Stroke Size () and will be neglected.

View numerical output: Right click a trial >View >Extracted data

Summarize all images and Analyze

Two writers have different line thicknesses, for example.

Right click the trial >Chart >Raw data to chart the raw data of the skeleton almost as if it was recorded.
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See Also

SetupStartCreate New UserDevice SetupExperiment SetupRun ExperimentChart and View TrialsPrev: AnalysisScanned Handwriting ImagesNext: Bimanual Force CoordinationExample Experiments
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<Previous Next>
10. Bimanual Force Coordination

10.1. Bimanual force coordination

Right click your experiment > Experiment Type > Grip Force
Requires analog interface and Gripper hardware

Bimanual Force Coordination
NeuroScript MovAlyzeR Help Send comments on this topic.
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<Previous
Example Experiments (from default user UU1)
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Experiment E01 (Simulated Loops in Left and Right Handers)
Experiment EX1 (Hicks' Law)
Experiment EX2 (Stimulus Response Compatibility)
Experiment EX3 (Fitts' Law -- Speed-Accuracy Trade-off)
Experiment EX9 (Simulated Signals)
Experiment IMG (Mirror Image Tracing)
Experiment LAY (Menu Layout)
Experiment PH2 (Caligiuri Handwriting Test for EPS)
Experiment WRD (Word Extraction)
Experiment ALC (Alcohol Test)

Experiment E01 (Simulated Loops)
The experiment consists of making four loops of equal size for every trial.
For Subjects S01 and S02, the data has been generated using the data generate wizard, rather than 

Example Experiments
NeuroScript MovAlyzeR Help Send comments on this topic.
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recording real data. For Subject SSS, data was recorded.
Input device settings:
MovAlyzeR > Settings > Select input device > tablet.
In Input device settings: Resolution = 0.001, Minimum pen pressure = 1, Sampling rate = 0.01.
Procedure used to generate data for E01:
The following procedure was used to generate data for Experiment E01:
For Subject S01
1) Select File > Data Generate wizard.. > Specify data generation settings > click settings
2) Choose Predefined = custom, the following window appears:

3) Set the following specifications and click ok.
Noise Settings

Noise amplitude (cm) = 0.05
General Settings

Start Time = 0.1Number of strokes = 8.4trail time = 0.1
X Movement componentposition start = 0.3size = 1start phase = 60velocity = 2
Y Movement componentposition start = 0.3size = 1start phase = 0

Stroke Settings
Stroke duration = 0.22 s, stroke size = 2 cm (i.e., X component = 1.414 cm, Y component = 1.414 cm)

4) Click Next > choose experiment = E01 > condition = C01 group = G01 > subject = S01 > By clicking 
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next, the first trial of the subject S01 for condition C01 is created.
5) Repeat steps 1-4 from the first screen, without changing any settings (clicking next instead of finish retains all the previous settings) 8 times. Thus, 8 trials are generated with the above specifications.
6) Repeat steps 1-5 by changing the condition each time (condition = C02 and condition = C03) and the stroke settings:
Cond C02 : Stroke duration = 0.22 s, stroke size = 2.1 cm (i.e., X component = 1.449 cm, Y component = 1.449 cm)
Cond C03 : Stroke duration = 0.2 s, stroke size = 2 cm (i.e., X component = 1.414 cm, Y component = 1.414 cm)
NOTE: The data for the 8 trials per condition are slightly different from each other, even though the parameters are the same. This is because of the added noise.
For Subject S02
Repeat the same procedure as for Subject S01, changing only noise amplitude to 0.1, for all the steps.
For Subject SSS
Run experiment with the three conditions. Stimuli LOP and LIN which contain two lines between which the loops are used.

Experiment EX1 (Hick's Law -- Reaction Time Increases with #Choices)
Reaction Time (RT) is the interval between the presentation of an unanticipated stimulus and the beginning of the response.
~ Nature of the stimulus
~ Type of movement 
Number of Stimulus-Response Alternatives:
~ One of the most important factors influencing RT is the number of possible stimuli (choices)
~ Choice RT: subject identifies the stimulus and then chooses a response that corresponds to the stimulus
~ Simple RT: RT when there is only one stimulus and one response (shortest possible RT)
Hick’s Law: Longer reaction times result from greater number of stimulus-response (S-R) alternatives. Hick’s Law (Hick, 1952) states that RT increases by a nearly equal amount each time the number of alternatives is doubled (1 to 2 to 4 to 8, etc.). More formally, Hick’s Law is expressed as:

RT = a + b * log2(N)
N = Number of alternatives
a = Simple RT (when there is one response choice – no event uncertainty)
b = Increase in RT each time the number of alternatives is doubled

Experiment EX2 (Stimulus Response Compatibility)
There is a “natural” connection between the stimulus and the response
RT is faster with more compatible S-R pairs
Implementation In MovAlyzeR. The pen is moved to a home position. Two circles appear (width 1 cm) at an equal distance (8 cm) from the home position. Between the home position and the two target circles the precue "Compatible" or "Incompatible" appears  for 0.5 s. After a fixed period the home position turns red or green. Simultaneously, one of the circles turns red and the the other one turns green. The subject has been instructed to move as quickly as possible to the target that has the same color if the precue was "Compatible" or to the target with a different color than the home position if the precue was "Incompatible".
The period between the time that the circle turns red or green and adn the movement start time is the reaction time. Reaction-time increase in the incompatible condition expresses the extra “cost” to process and program an incompatible target.
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Experiment EX3 (Fitts' Law -- Speed-Accuracy Trade-off)
The time to reach a target depends on how the accuracy. Therefore, there is a “trade-off” between speed and accuracy when performing a goal-directed movement.
Fitts’ Law: Fitts’ Law describes the relationship between the duration of the movement and the accuracy:

MT = a + b * log2(2A/W)
MT = Movement time 

A = Amplitude of the movement
W = Width of the target
Index of Difficulty (ID), defined as ID = log2(2A/W). Therefore, Fitts’ Law says that movement time increases linearly 
with ID: MT = a + b * ID

Experiment EX9 (Simulated Signals)
The Data Generate Wizard in MovAlyzeR is used to create a wide array of signals with known underlying features. Please refer to EX9 experiment-property attachment to get information on how to generate these signals.

Experiment IMG (Mirror Image Tracing)
The mirror-image tracing study requires that the participant use the mouse to trace the star shown when running this experiment, first with one hand, and then with the other hand. Because mirror image tracing is primarily a visual-spatial task, and each half of the brain controls the contralateral side of the body, it is expected that right-handed participants will take longer to complete the task with their right hand (controlled by the left hemisphere) compared to their left hand ( controlled by the right hemisphere). Please note that this prediction may not necessarily hold for left-handed participants, because their brains are more bilateral.

Experiment LAY (Menu Layout)
You can establish the efficiency of aiming at one item in a 16-option menu. The menu has 2 different layouts: 16 items under each other or 4 x 4 items in a square. It is a 16 choice-reaction time experiment. You can also establish whether pen movements are more efficient than mouse movements. Different menu aiming efficiencies can be expected by altering the mouse setting in the Control Panel.

Experiment PH2 (Caligiuri's Handwriting Test for EPS)
Extrapyramidal side effects due to schizophrenia medication measurements were collected in 3 major US mental hospitals using this test battery consisting of simple (overlaying circles and cursive l sequences) and more complex movement patterns (cursive llee patterns and a sentence "Today is a nice day") at sizes 1, 2, and 4 cm, with dominant and non-dominant hands, at normal and maximal speeds. The test was intentionally simple. Subjects wrote with a non-inking pen on a template underlaying the tablet cover. The template showed guidelines indicating the target sizes. The writing patterns were shown by the experimenter using paper cards. The subjects did not monitor their movements on the computer screen. The templates and examples are included in the experiment-property attachments.

Experiment WRD (Word Extraction)
Demonstrates the ability of MovAlyzeR to extract individual words from a long handwritten sample. There are two trials provided and a list of 500 conditions to run the experiment. Users may make their own lengthy recordings and tweak experiment parameters to get best results.

Experiment ALC (Alcohol Test)
Experiment to demonstrate the debilitating effects of alcohol on motor control. This experiment implements a number of tests that can be used to gauge the effect of alcohol on a given user.
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Menu Bar Road Map
User Management Menu Bar: File -> Users  ->

-> Select existing user -> OK
-> Create New -> Settings -> User -> User ID Blank
-> Create New -> Settings -> User -> Name/Description Blank

User Preferences Settings
Menu Bar: File -> Users -> Create New -> Settings -> Settings ->
-> Root data path [WRITE permissions required]
-> Backup path [WRITE permissions required] ..\\Data
-> Sort alphabetically Chronologically
-> ID/Descriptions delimiter [names of items cannot contain this character]

User Preferences Input Device
Menu Bar: File -> Users -> Create New -> Settings -> Input Device ->
Run Device Setup Wizard
-> Mapping -> Communications port for trigger pulses CommunicationsPort[COM1]

Run-Experiment Wizard
Menu Bar: File -> Run-Experiment Wizard ->
(See Detail)

Experiment Setup Wizard Menu Bar: File -> Experiment Setup Wizard ->
(See Detail)

Experiment Setup Wizard Menu Bar: File -> MovAlyzeRx->
(See Detail)

Stimulus Editor Menu Bar: File -> Stimulus Editor ->
(See Detail)

Log Menu Bar: File -> Logging ->
-> Log Actions to File FALSE
-> View Log File FALSE
-> Clean Log File     FALSE
-> Add Comment Issues to Log -> What is the issue? What were you trying to accomplish? Blank

-> Add Comment Issues to Log -> What actually happened? What went wrong? What is the problem? Blank

-> Content -> Log User Interface Action FALSE
-> Content -> Log Data Action FALSE
-> Content -> Log Data Action FALSE
-> Content -> Log Processing Action FALSE
-> Content -> Log Graphics Action FALSE
-> Content -> Log Input Action FALSE
-> Content -> Select All FALSE

ROADMAP(MenuBar)
NeuroScript MovAlyzeR Help Send comments on this topic.
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-> Content -> Select None FALSE
-> Send Log to Neuroscript

Backup Menu Bar: File -> Backup ->
-> Complete Backup
-> Backup Database
-> Restore Database
-> Backup History                                             

Import Menu Bar: File -> Import -> Import Experiment ->
-> Import Experiment
-> Data Import Wizard

Data Generate Wizard Menu Bar: File -> Data Generate Wizard ->
(See Detail)

Experiments Menu Bar: Tree Action ->Experiments ->
-> Create New
-> Create New -> Exp. ID Blank
-> Create New -> Description Blank
-> Create New -> Notes Blank
-> Create New -> Experiment Type Handwriting
-> Find -> ID of item to find Blank
-> Import Experiment -> Specify Import File [*.exp] Blank
-> Client-Sever -> Download All
-> Client-Sever -> Upload All
-> Experiment (See Left Panel Help)

Groups Menu Bar: Tree Action -> Groups ->
-> Create New
-> Create New -> Group ID Blank
-> Create New -> Description Blank
-> Create New -> Notes Blank
-> Find -> ID of item to find Blank
-> Add Group(s) to Experiment
-> Client-Sever -> Download All
-> Client-Sever -> Upload All
-> Group (See Left Panel Help)

Subjects Menu Bar: Tree Action -> Subjects ->
-> Create New
-> Create New -> Subject ID Blank
-> Create New -> First Name Blank
-> Create New -> Last Name Blank
-> Create New -> Date Added Current Date
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-> Create New -> Inactive FALSE
-> Create New -> Default Experiment Blank
-> Create New -> Number of experiments participated in 0
-> Create New -> Private Notes [Tel#, DOB, ect] Blank
-> Create New -> Public Notes [Gender, Race, Handedness, ect] Blank

-> Find -> ID of item to find Blank
-> Add Subject(s) to Group

Trials Menu Bar: Tree Action -> Trials ->
-> View Numerical Data -> View Raw Data
-> View Numerical Data -> View Processed Data
-> View Numerical Data -> View Segment Data
-> View Numerical Data -> View Extracted Data
-> View Numerical Data -> View Consistency Error Data
-> View Numerical Data -> View Consistency Data
-> Chart Data -> Chart Raw Data
-> Chart Data -> Chart Raw Data (3D)
-> Chart Data -> Chart Raw Data (Real-Time)
-> Chart Data -> Chart Processed Data
-> Chart Data -> Chart Processed Data (3D)
-> Chart Data -> Chart Processed Data (Real-Time)
-> Redo Trial
-> Reprocess Trial -> Append Results
-> Reprocess Trial -> Ignore Results
-> Test Linearity
-> Condition Properties
-> Condition Number of Trials
-> Delete

Stimuli Menu Bar: Tree Action -> Stimuli ->
-> Create New
-> Create New -> Stimulus ID Blank
-> Create New -> Description Blank
-> Create New -> Stimulus Elements Blank
-> Create New -> Available Targets Blank
-> Create New -> Target Use/Sequence Blank
-> Find -> ID of item to find Blank
-> Refresh
-> Client-Sever -> Download All
-> Client-Sever -> Upload All
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-> Stimulus (See Left Panel Help)
Elements General Menu Bar: Tree Action -> Elements -> Create New  -> General ->

-> Element ID Blank
-> Description Blank
-> Use a shape TRUE
-> Use a pattern [data file] FALSE
-> Use a Bitmap FALSE
-> Start Time [s] 0
-> Duration [s] 0
-> Indefinite TRUE
-> This element will be a Target FALSE
-> Category No Category

Elements Pattern Menu Bar: Tree Action -> Elements -> Create New  -> Pattern ->
-> Experiment Blank
-> Group Blank
-> Subject Blank
-> Trial Blank

Elements Dimensions Menu Bar: Tree Action -> Elements -> Create New  -> Dimensions ->
-> Shape Rectangle
-> Center Point X-coord [cm] 3
-> Center Point Y-coord [cm] 5
-> ½ Length of X [cm] 0.2
-> ½ Length of Y [cm] 0.2
-> Target Allowable Error -> X Allowable Error [cm] 0
-> Target Allowable Error -> Y Allowable Error [cm] 0

Elements Appearance Menu Bar: Tree Action -> Elements -> Create New  -> Appearance ->
-> Category Main/Initial
-> Line Appearance -> Line Size [cm] 2
-> Line Color -> Line Color Black
-> Line Color -> Fill Color White
-> Text Appearance -> Text Blank
-> Text Appearance -> Front Face Name Arial
-> Text Appearance -> Size 10
-> Text Appearance -> Color Black

Elements Results Menu Bar: Tree Action -> Elements -> Create New  -> Results ->
-> Hide when correctly reached target FALSE
-> Hide when incorrectly reached target FALSE
-> Display this element when correctly reached target FALSE
-> Display this element when incorrectly reached target FALSE
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Elements Animation Menu Bar: Tree Action -> Elements -> Create New  -> Animation->
-> Animate this element FALSE
-> Sampling Rate [Hz] 120
-> Existing pattern TRUE
-> Random pattern FALSE
-> Random pattern -> Randomly generated FALSE
-> Random pattern -> From a subject of an experiment TRUE
-> Random pattern -> From a subject of an experiment -> Experiment Blank

-> Random pattern -> From a subject of an experiment -> Group Blank

-> Random pattern -> From a subject of an experiment -> Subject Blank

Categories Menu Bar: Tree Action -> Categories ->
-> Create New -> Cat. ID Blank
-> Create New -> Description Blank
-> Create New -> Category Type None
-> Find -> ID of item to find Blank
-> Client-Sever -> Download All
-> Client-Sever -> Upload All
-> Category (See Left Panel Help)

Feedback Menu Bar: Tree Action -> Feedbacks ->
-> Create New -> ID Blank
-> Create New -> Description Blank
-> Create New -> Feature Blank
-> Create New -> Min. Value Color Blue
-> Create New -> Max. Value Color Red
-> Find -> ID of item to find Blank
-> Client-Sever -> Download All
-> Client-Sever -> Upload All
-> Feedback (See Left Panel Help)

Select Input Device Menu Bar: Settings -> Select Input Device ->
-> Input Device -> Select Input Device -> Mouse TRUE
-> Input Device -> Select Input Device -> Tablet FALSE
-> Input Device -> Mapping -> Entire Desktop [real-size recording unavailable] TRUE

-> Input Device -> Mapping -> Recording Window [needed for real-size feedback in exp. settings] FALSE

-> Input Device -> Mapping -> Display Width [cm] 40.64
-> Input Device -> Mapping -> Display Height [cm] 30.48
-> Input Device -> Mapping -> Tablet Width [cm] 20.32
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-> Input Device -> Mapping -> Tablet Height [cm] 15.24
-> Input Device -> Mapping -> Communications port for trigger pulses CommunicationsPort[COM1]

-> Input Device -> Mapping -> Communications port for trigger pulses -> Show only available ports FALSE

DAQPad Settings Menu Bar: Settings -> DAQPad Settings ->
(See Detail)

Test/Record Input Device Menu Bar: Settings -> Test/Record Input Device ->
-> Test device free-hand TRUE
-> Test digitizer device for linearity FALSE
-> Test digitizer device for linearity -> Manually draw a diagonal line TRUE

-> Test digitizer device for linearity -> Generate a diagonal line FALSE
Test/Record Input Device (Settings Dialog)

Menu Bar: Settings -> Test/Record Input Device ->
-> Test device free-hand/Test digitizer device for linearity -> Click “Go” -> Sampling Rate [Hz] – Obtain from testing the device

100

->Test device free-hand/Test digitizer device for linearity -> Click “Go” -> Minimum Pen Pressure/Load (N)/Z position [cm] 1

->Test device free-hand/Test digitizer device for linearity -> Click “Go” -> Device Resolution [cm or N] 0.0005

Reset Input Device Menu Bar: Settings -> Reset Input Device ->
(See Detail)

Root Data Path Menu Bar: Settings -> Root Data Path ->
-> Settings -> Settings -> Root data path [WRITE permissions required] …\\Data

-> Settings -> Settings -> Backup path [WRITE permissions required] …\\Data\BACKUP

-> Settings -> Settings -> Log all actions to “Actions.log” FALSE
-> Settings -> Settings -> Sort alphabetically [Default is chronologically] FALSE

-> Settings -> Settings -> ID/Name delimiter [names of items cannot contain this character] .

Questionnaire Template Menu Bar: Settings -> Questionnaire Template ->
-> Create New -> Question ID Blank
-> Create New -> Topic/Question Blank
-> Create New -> Topic/Question -> Header FALSE
-> Create New -> Topic/Question -> Private FALSE

Download Questionnaire Menu Bar: Settings -> Download Questionnaire ->
(See Detail)

Upload Questionnaire Menu Bar: Settings -> Upload Questionnaire ->
(See Detail)

View Menu Bar: View ->
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-> Subject Privacy Protection
-> Toolbar -> Info Bar
-> Toolbar -> Device Bar
-> Toolbar -> Action Bar
-> Toolbar -> Wizard Bar
-> Toolbar -> Text Labels
-> Status Bar
-> Rapaid Review
-> Relationships
-> Symbol Legend
-> Clear Recording Window
-> Clear Results Window
-> Refresh

View  Conversion Calculator
Menu Bar: View -> Conversion Calculator ->
-> Inches/Centimeters TRUE
-> Degrees/Radians FALSE
-> Inches 0
-> Centimeters 0

View  Application Look
Menu Bar: View -> Application Look ->
-> Visual Manager Microsoft Office 2007
-> Style [Office 2007 only] Luna-blue
-> OneNote-style MDI tabs TRUE
-> Docking Tab Colors TRUE
-> 3D Rounded Docking Tabs and Auto Hide Buttons [VS 2005 only] TRUE

-> Show Extended Tooltips TRUE
Support Menu Bar: Support ->

-> Support Website
-> Activate Features
-> Check for Updates
-> Deactivate License

Stimulus Editor Menu Bar- File
Menu Bar: Support ->Stimulus Editor -> Menu Bar: File ->
-> New
-> Open
-> Close
-> Save
-> Save AS
-> Save All
-> Import [*.EXP File]
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-> Export -> To a file [*.EXP File]
-> Export -> To a MovAlyzeR user
-> Print
-> Print Preview
-> Print Setup
-> Exit

Stimulus EditorMenu Bar-Action
Menu Bar: Support ->Stimulus Editor -> Menu Bar: Action ->
-> New Element
-> New Target
-> Copy Element
-> Delete Element

Stimulus Editor Menu Bar- View
Menu Bar: Support ->Stimulus Editor -> Menu Bar: View ->
-> Workspace
-> Properties View
-> Output
-> Refresh
-> Application Look
-> Application Look -> Visual Manager Microsoft Office 2007
-> Application Look -> Style [Office 2007 only] Luna-blue
-> Application Look -> OneNote Style MDI Tabs TRUE
-> Application Look -> Docking Tab Colors TRUE
-> Application Look -> 3D Rounded Docking Tabs and Auto Hide buttons [VS 2005 only] TRUE

-> Application Look -> Show Extended Tooltips TRUE
Stimulus Editor Menu Bar- Window

Menu Bar: Support ->Stimulus Editor -> Menu Bar: Window ->
-> New Window
-> Close All Documents

Stimulus Editor Menu Bar- Help
Menu Bar: Support ->Stimulus Editor -> Menu Bar: Help ->
-> Dynamic Help
-> Show Start Page
-> Neuroscript on Web
-> About Stimulus Editor

Stimulus Editor User Properties
Menu Bar: Support ->Stimulus Editor -> Left Window -> User ->
-> Path
-> ID
-> Description
-> Delimiter :

Stimulus Editor System Properties
Menu Bar: Support ->Stimulus Editor -> Left Window -> System ->
-> Display Width 40.64
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-> Display Height 30.48
-> Tablet Width 20.32
-> Tablet Height 15.24
-> Tablet Resolution 1000

Stimulus Editor Element/Target Properties

Menu Bar: Support ->Stimulus Editor -> Left Window -> Click an Element/Target ->
-> Element -> ID
-> Element -> Description Element
-> General -> Type Shape
-> General -> Image
-> General -> Start Time 0
-> General -> Duration 0
-> General -> Indefinite Yes
-> General -> Target No/Yes
-> Dimensions -> Shape Rectangle
-> Dimensions -> Center X
-> Dimensions -> Center Y
-> Dimensions -> X Radius 1.0
-> Dimensions -> Y Radius 1.0
-> Appearance -> State Main/Initial
-> Appearance -> Line Size 2
-> Appearance -> Border Color Black
-> Appearance -> File Color White
-> Appearance -> Text
-> Appearance -> Text Font Arial (10)
-> Results -> Hide Correct No
-> Results -> Hide Incorrect No
-> Results -> Correct Stimulus No
-> Results -> Incorrect Stimulus No
-> Animation No
-> Animation -> Rate 120
-> Animation -> Trial

Help Menu Bar: Help ->
-> Application Help
-> Quick Reference Card
-> Troubleshooting
-> Tutorial
-> NeuroScript Website
-> About MovAlyzeR
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© NeuroScript LLC. All Rights Reserved.

-> License Agreement

Left Window Road Map
Experiment General Properties

Left Window: Right click your Experiment -> Properties -> General -> Properties ->
-> Exp. ID
-> Description
-> Notes
-> Experiment Type Handwriting
-> Instructions

-> Extended Notes
Experiment Trial Settings Left Window: Right click your Experiment ->Properties ->Running Experiment -> Trials ->

-> Timeouts [secs] -> Start 10
-> Timeouts [secs] -> Recording 10
-> Timeouts [secs] -> Pen-Lift (s) 3
-> Timeouts [secs] -> Trial-to-Trial (s) 0
-> Process immediately after recording TRUE
-> Make recording window real size FALSE
-> Maximize recording window FALSE
-> Leave recording window as-is FALSE

Experiment Charting Settings
Left Window: Right click your Experiment -> Properties ->Running Experiment -> Charting ->
-> Display charts after each trial FALSE
-> Chart raw data TRUE
-> Chart data as a function of time FALSE
-> Include segmentation FALSE

Experiment Summarize and Analysis Settings

Left Window: Right click your Experiment -> Properties ->Running Experiment -> Summ/Analysis ->
-> Summarize data after running experiment TRUE
-> Summarize this subject only TRUE
-> Select which subjects to include/exclude FALSE
-> Analyze experiment TRUE

Experiment View Settings Left Window: Right click your Experiment -> Properties ->Running Experiment -> View Data ->
-> Run Experiment View Settings -> Subject -> Extracted FALSE

ROADMAP(LeftWindow)
NeuroScript MovAlyzeR Help Send comments on this topic.
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Data
-> Run Experiment View Settings -> Subject -> Consistency Errors FALSE

-> Run Experiment View Settings -> Experiment -> Extracted Data FALSE

-> Run Experiment View Settings -> Experiment -> Consistency Errors FALSE

Experiment Procedure Settings
Left Window: Right click your Experiment -> Properties ->Running Experiment ->Procedure ->
-> View/Answer Questionnaire FALSE
-> Instruction constantly visible during recording FALSE
-> Randomize condition order TRUE
-> Randomize replications TRUE
-> Apply rules False
-> Events at the Beginning of a Trial -> Show condition instruction TRUE

-> Events at the Beginning of a Trial -> Show condition instruction -> For the first trial per condition TRUE

-> Events at the Beginning of a Trial -> Show condition instruction -> Per trial FALSE

-> Events at the End of a Trial -> Delay next trial until ENTER key is pressed TRUE

-> Events at the End of a Trial -> Accept/Redo trial TRUE
-> Events at the End of a Trial -> Accept/Redo trial -> Ask for every trial FALSE

-> Events at the End of a Trial -> Accept/Redo trial -> Ask if consistency error TRUE

-> Events at the End of a Trial -> Accept/Redo trial -> Redo trial automatically if consistency error FALSE

Experiment Recording Input Device Settings

Left Window: Right click your Experiment -> Properties -> Input Device -> Settings ->
-> Acquire Device Settings
-> Sampling Rate [Hz]-Obtain From Testing The Device 100
-> Minimum Pen Pressure/Load[N]/Z position [cm] 1
-> Device Resolution [cm or N] 0.001

Experiment Processing Word Extraction Settings

Left Window: Right click your Experiment -> Properties -> Processing -> Word Extraction -> Settings ->
-> Min. word width [cm] 0.1
-> Min. leftward distance between words [cm] 0.25
-> Min. leftward penlift movement between words [cm] 0.5
-> Min. downward distance between word beginnings [s] 1
-> Min. duration of penlifts between words [s] 0.6
-> Max. duration of penlifts within a word [s] 0.01

Experiment Processing Left Window: Right click your Experiment -> Properties -> Processing -> Time Functions ->
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Time Function Settings -> Filter Method -> FFT Low Pass TRUE
-> Filter Method -> Butterworth Low Pass FALSE
-> Filter frequency 12
-> Sharpness (NOTE: Half filter width = Filter Frequency/Sharpness) 1.75

-> Lump decimates samples or 0 for optimal decimation 1
-> Spectrum of Position FALSE
-> Spectrum of Velocity TRUE
-> Spectrum of Acceleration FALSE
-> Unrotate automatically FALSE
-> Additional rotation [in radians] 0

Experiment Processing Segmentation Settings

Left Window: Right click your Experiment -> Properties -> Processing -> Segmentation ->
-> Add first segment at any rate FALSE
-> Add last segment at any rate FALSE
-> The entire trial is one stroke FALSE
-> Move segmentation point to nearest pendown if on a penlift FALSE

-> Move segmentation point to the nearest absolute velocity minima within stroke FALSE

-> Submovement analysis: Add before each stroke primary and secondary submovements FALSE

-> Segmentation Method -> At vertical velocity zero crossings TRUE
-> Segmentation Method -> At absolute velocity minima FALSE
-> Segmentation Method -> At pendown trajectories FALSE

Experiment Processing Extraction Settings

Left Window: Right click your Experiment -> Properties -> Processing -> Extraction ->
->Onestroke analysis combines all strokes as if it were one FALSE
-> Calculate loop area between every consecutive 2 strokes, instead of every consecutive stroke FALSE

Experiment Processing Consistency Settings

Left Window: Right click your Experiment -> Properties -> Processing -> Consistency ->
-> Use absolute measures instead of relative measures FALSE
-> Discard trial if out of range [# of strokes] FALSE
-> Remove initial downstroke FALSE
-> Discard trial if first stroke starts within the reaction time FALSE
-> Discard trial if reaction time < Min. reaction time FALSE
-> Discard trial if reaction time < Min. reaction time -> Min. reaction time [s] 0.1

-> Discard trial if reaction time > Min. reaction time FALSE
-> Discard trial if reaction time > Min. reaction time -> Max. reaction time [s] 3

Experiment Left Window: Right click your Experiment -> Properties ->Summarization -> 
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Summarization Settings Settings ->
-> Absolute values FALSE
-> Relative data = data / mean_across_strokes FALSE
-> Output missing strokes as zeroes FALSE
-> Output missing trials as zeroes [Use only with above] FALSE
-> Substitute missing trials FALSE
-> Substitute missing trials -> Discard substituted trials after # 0

-> Discard trials after # 0

-> Collapse across all strokes (HINT: use absolute values), -OR- FALSE

-> Collapse across odd and even strokes AND/OR FALSE

-> Collapse across trials FALSE

-> Averages TRUE

-> Medians FALSE

Experiment Norm DB Settings
Left Window: Right click your Experiment -> Properties ->Norm DB -> Settings ->
-> Calculate subject's Z score TRUE
-> Include comparison to all subjects within experiment? TRUE
-> Do not add subject to DB if personal X is above critical? FALSE
-> Critical Z score 1

Experiment Drawing Options Settings

Left Window: Right click your Experiment -> Properties ->Drawing Options -> Settings ->
-> Line Medium Thin
-> Background Color white
-> Line 1 Color blue
-> Line 2 Color green
-> Line 3 Color red
-> Ellipse Color red
-> Ellipse Radius [pixels] 2
-> Min. Pen Pressure Color white

Experiment Advanced Time Functions Settings

Left Window: Right click your Experiment -> Advanced -> Time Functions ->
-> Discard all samples after discontinuity TRUE
-> Insert constant velocity line FALSE
-> Move towards start of discontinuity FALSE
-> Accept discontinuity FALSE
-> Integration constant 0.2
-> Pressure of inserted or first moved sample[s] -1
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-> Relative error 20
-> Absolute error 100

Experiment Advanced Segmentation Settings

Left Window: Right click your Experiment -> Advanced -> Segmentation ->
-> Min. stroke size [cm] 0.05
-> Min. stroke size relative to max stroke 0.1
-> Min. stroke duration [s] 0.04
-> Min. velocity of 1st/last stroke [rel. to abs. peak] 0.05
-> Max. noise velocity of the 1st/last stroke [cm/s] 0.1

Experiment Advanced Extraction Settings

Left Window: Right click your Experiment -> Advanced -> Extraction ->
-> Initial part of stroke for departure of initial [s] 0.08
-> Max frequency of acceleration and decelration 10

Experiment Advanced Consistency Settings

Left Window: Right click your Experiment -> Advanced -> Consistency ->
-> Min. loop area [cm2] 0.001
-> Min. rel. stroke size increase in outward spiral 1.1
-> Max. slant error for strokes of a certain direction [radians] 0.39269908175
-> Max. straightness error for straight segments 0.1
-> Min. straightness departure for curved segments 0.01

Condition General Settings
Left Window: Right click your Condition -> Properties ->General ->
-> Condition ID
-> Description
-> Insturctions
-> Extended Notes

Blank
Blank

Condition Stimuli Settings
Left Window: Right click your Condition -> Properties ->Stimuli ->
-> Instruction Blank
-> Warning Stimulus NONE
-> Precue Stimulus NONE
-> Imperative Stimulus NONE
-> Delay recording until pen touches tablet TRUE

Condition Consistency Checking
Left Window: Right click your Condition -> Properties ->Consistency Checking ->
-> Stroke Pattern Blank
-> Minimum Strokes 0
-> Maximum Strokes 0
-> Strokes to skip 0
-> Stroke Length [cm] 0
-> +/- Length Error [cm] 0
-> Stroke Dir. [rad] 0
-> +/- Dir. Error [rad] 0
-> Check for target sequence as defined by the imperative FALSE
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stimulus
Condition Word Extraction

Left Window: Right click your Condition -> Properties -> Word Extraction ->
-> Trials will be Recorded [DEFALUT =TRUE] TRUE
-> Trials will be Extracted from condition, word Blank
-> Trials will be Processed TRUE

Condition Feedback Left Window:Right click your Condition -> Properties ->Feedback ->
-> End recording when max. strokes is reached FALSE
-> Hide the pen/mouse drawings [until end] FALSE
-> Transform the recording [gain and rotation] FALSE
-> Transform the recording [gain and rotation] -> X Gain 1
-> Transform the recording [gain and rotation] -> X Rotation [degree] 0

-> Transform the recording [gain and rotation] -> Y Gain 1
-> Transform the recording [gain and rotation] -> Y Rotation [degree] 0

-> Select feedback method for processed charts -> Y Rotation [degree] NONE

Condition Sound Left Window:Right click your Condition -> Properties -> Sound ->
-> Use sound TRUE
-> Use sound -> Use tones TRUE
-> Use sound -> Use tones -> Frequency [Hz] 800
-> Use sound -> Use tones -> Duration [ms] 20
-> Use sound -> Use wave file FALSE
-> Fire trigger pulse to communication port FALSE

Condition Right Click Left Window:Right click your Condition ->
-> Number of Trials -> Condition -> General -> Number of Trials 2

-> View Condition Relationship
-> Reprocess Trials
-> Show Instruction
-> Duplicate
-> Remove From Experiment

Experiment Properties Left Window:Right click your Experiment -> Experiment Properties ->
-> Exp. ID
-> Description
-> Notes
-> Type Handwriting

Experiment Instructions Left Window:Right click your Experiment -> Experiment Instructions ->
-> Font Times New Roman
-> Size 8
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-> Color Black
Experiment Summarize Left Window:Right click your Experiment -> Summarize -> Summarize -> Subject to exclude ->

-> Exclude All
-> Include All
-> OK

Experiment Summarize View Data
Left Window: Right click your Experiment -> Summarize ->
-> View Extracted Data
-> View Consistency Error Data
-> View Consistency Error Summary Data

Experiment Export Left Window: Right click your Experiment -> Export ->
-> Specify Export Location
-> Include experiment support files [instructions, notes, sorting, etc]? FALSE

-> Include experiment trials? TRUE
Experiment Analysis Left Window: Right click your Experiment -> Analysis -> Analysis Chart ->

-> X Axis Segment
-> Y Axis StartVerticalPosition
-> Grouping Segment
-> X-Axis Statistic Avgs
-> Y-Axis Statistic Avgs
-> Chart Trials
-> Averaging FALSE
-> per Subject FALSE
-> Actions/Settings Points
-> Strokes FALSE
-> X 1
-> Y 1

Experiment Process Left Window: Right click your Experiment -> Process ->
->Reprocess Trials
->Remove Process Files
->Remove Process Files -> Recorded Files -> Raw Data Files FALSE
->Remove Process Files -> Scratch Files -> TF Files [Time Function] TRUE

->Remove Process Files -> Scratch Files -> SEGFiles [Segmentation] TRUE

->Remove Process Files -> Trial Results Files -> EXT Files [Extraction] TRUE

->Remove Process Files -> Trial Results Files -> CON Files [Consistency Scratch] TRUE

->Remove Process Files -> Trial Results Files -> ERR Files TRUE
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[Error]
->Remove Process Files ->  Experiment Results Files -> INC Files FALSE

Experiment Add Groups Left Window: Right click your Experiment -> Add Groups ->
(See Detail)

Experiment Add Conditions Left Window: Right click your Experiment -> Add Conditions ->
(See Detail)

Group Properties Left Window: Right click your Group -> Properties ->
-> Group ID
-> Description

-> Notes
Questionnaire Left Window: Right click your Experiment/Group/Subject -> Questionnaire ->

-> Select All
-> Select None

Backup Left Window: Right click your Experiment/Group/Subject ->
-> Backup

Subject Properties Left Window: Right click your Subject ->
-> Subject ID
-> First Name
-> Last Name
-> Date Added
-> Inactive FALSE
-> Default Experiment
-> Number of experiments participated in 1
-> Private Notes [Tel#, DOB, etc]:
-> Private Notes [Gender, Race, Handedness, etc]

View Relationship Left Window: Right click your Experiment/Group/Subject -> View Relationships ->
-> Subjects
-> Stimuli
-> Categories
-> Groups
-> Conditions
-> Elements
-> Feedbacks

Subject Process Left Window: Right click your Subject -> Process ->
-> Reprocess Trials
->Remove Process Files
->Remove Process Files -> Recorded Files -> Raw Data Files FALSE
->Remove Process Files -> Scratch Files -> TF Files [Time TRUE
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Function]
->Remove Process Files -> Scratch Files -> SEGFiles [Segmentation] TRUE

->Remove Process Files -> Trial Results Files -> EXT Files [Extraction] TRUE

->Remove Process Files -> Trial Results Files -> CON Files [Consistency Scratch] TRUE

->Remove Process Files -> Trial Results Files -> ERR Files [Error] TRUE

Subject Export Left Window: Right click your Subject -> Export ->
-> Specify Export Location
-> Include experiment support files [instructions, notes, sorting, etc]?
-> Include experiment trials? TRUE

Subject Move Group Left Window: Right click your subject ->
-> Move To Group
-> Remove From Group

Trial View Numerical Data
Left Window: Right click your Trial -> View Numerical Data ->
-> View Raw Data 
-> View Processed Data 
-> View Segmented Data
-> View Extracted Data 
-> View Consistency Error Data
-> View Consistency Data

Trial Chart Data Left Window: Right click your Trial -> Chart Data ->
-> Chart Raw Data 
-> Chart Raw Data (3D)
-> Chart Raw Data (Real time)
-> Chart Processed Data 
-> Chart Processed Data (3D)
-> Chart Processed Data (Real time)

Trial Linearity Test Left Window: Right click your Trial -> Test Linearity ->
(See Detail)

Stimuli Properties Left Window: Right click your Stimuli -> Properties ->
-> Stimulus ID
-> Description
-> Stimulus Elements
-> Available Targets
-> Target Use/Sequence

Stimuli Left Window: Right click your Stimuli ->
-> Stimulus Editor
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-> View Stimulus Relationships
-> Test in Recording Window
-> View Data
-> Chart Data
-> Add Element(s)
-> Duplicate
-> Client – Server
-> Delete

Elements Left Window: Right click an Element ->
-> Properties
-> View Element Relationships
-> Display in Recording Window
-> View Data
-> Chart Data
-> Duplicate
-> Client – Server -> Download
-> Client – Server -> Upload
-> Remove From Stimulus
-> Delete

Elements General Properties
Left Window: Right click an Element -> Properties -> General ->
-> Element ID
-> Description
-> Use a shape TRUE
-> Use a pattern [data file] FALSE
-> Use a Bitmap FALSE
-> Start Time [s] 0
-> Duration [s] 0
-> Indefinite TRUE
-> This element will be a Target FALSE
-> Category No Category

Element Pattern Left Window: Right click an Element -> Properties -> Pattern ->
-> Experiment
-> Group
-> Subject
-> Trial

Element Dimensions Left Window: Right click an Element -> Properties -> Dimensions ->
-> Shape Rectangle
-> Center Point X-coord. [cm] 3
-> Center Point Y-coord. [cm] 5
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-> ½ Length of X [cm] 0.2
-> ½ Length of Y [cm] 0.2
-> Target Allowable Error -> X Allowed Error [cm] 0
-> Target Allowable Error -> Y Allowed Error [cm] 0

Element Appearance Left Window: Right click an Element -> Properties -> Appearance ->
-> Category Main/Initial
-> Line Appearance -> Line Size 2
-> Line Appearance -> Line Color Black
-> Line Appearance -> Fill Color White
-> Text Appearance -> Text Blank
-> Text Appearance -> Font Size 10
-> Text Appearance -> Font Color Black

Element Results Left Window: Right click an Element -> Properties -> Results ->
-> Hide when correctly reached target? FALSE
-> Hide when incorrectly reached target? FALSE
-> Display this element when correctly reached target? FALSE
-> Display this element when incorrectly reached target? FALSE

Element Animation Left Window: Right click an Element -> Properties -> Animation ->
-> Animate This element? FALSE
-> Sampling Rate [Hz] 100
-> Existing pattern TRUE
-> Random pattern FALSE
-> Random pattern -> Randomly generated FALSE
-> From a subject of an experiment TRUE

User Login Left Window: Open MovAlyzeR ->
-> Select existing user -> OK
-> Create New -> Settings -> User -> User ID Blank
-> Create New -> Settings -> User -> Name/Description Blank

User Preferences Settings
Left Window: Open MovAlyzeR -> Create New -> Settings -> Settings ->
-> Root data path [WRITE permissions required] …\\Data
-> Backup path [WRITE permissions required] …\\Data\BACKUP
-> Log all actions to “Actions.log” FALSE
-> Sort alphabetically [Default is chronologically] FALSE
-> ID/Name delimiter [names of items cannot contain this character] .

User Preferences Input Device
Left Window: Open MovAlyzeR -> Create New -> Settings -> Input Device ->
-> Select Input Device -> Mouse TRUE
-> Select Input Device -> Tablet FALSE
-> Mapping -> Entire Desktop [real-size recording TRUE
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unavailable]
-> Mapping -> Recording Window [needed for real-size feedback in exp. settings] FALSE

-> Mapping -> Display Width [cm] 40.64
-> Mapping -> Display Height [cm] 30.48
-> Mapping -> Tablet Width [cm] 20.32

-> Mapping -> Tablet Height [cm] 15.24
-> Mapping -> Communications port for trigger pulses CommunicationsPort [COM1]
-> Mapping -> Communications port for trigger pulses -> Show only available ports FALSE
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Download & Install
This is a common topic for MovAlyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Note: This page has overlapping information with the application downloads page and is intended to provide offline information from within the application. 
Requirements
Trial Version
Purchased Version
To Deactivate (move to another computer)
To Uninstall

Requirements
System: MS Windows XP or later and 30MB of free space.
NOTE: Before installing the program, please make sure that you want to install the software on that specific computer, as once installed the program cannot be moved to another computer without a deactivation and new activation code for the new computer. 
User Privileges: To install/uninstall the application, define new users, or to work with the example experiments, administrative privileges are required. Alternatively, an administrator can install the application in an accessible/shared/writeable location.
Activation code: You will be required to enter an activation code:
* For your first installation of MovAlyzeR trial version to unlock the copy protection.
* Every time you install a newer version (trial or purchased). 
* When you make a new purchase of MovAlyzeR or suite items. 
Please refer to the next section for detailed description. Activation codes are immediately issued during the normal working hours. 
^Top

Trial Version
o Download the installation file from the downloads page using the user ID and password you registered with.
Note: You can use the same ID and password for future downloads of installation files.
o Uninstall older MovAlyzeR programs.
o Install the application by running (double-click) the downloaded file. 
The program will automatically run after the installation and prompt by asking whether you want to unlock the software. Click OK to unlock the software. You will be given an option to enter your NeuroScript account login information for tracking purposes, but it is not required. The system will then automatically unlock the software for your immediate use if you are connected to the internet.
If you are not connected to the internet, or choose not to use the internet method for unlocking, an activation window will open. Make a note of the Authorization Request Code. Click CANCEL to close the window.

* Email NeuroScript at sales@neuroscriptsoftware.com and provide the Authorization Request Code (to unlock). Please include your name, organization, and contact information. You will receive the Activation/Unlock Code for the trial version.

Installation
NeuroScript MovAlyzeR Help Send comments on this topic.
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* Once you receive the activation code, open the MovAlyzeR application. You will get the message again asking whether you want to unlock the software. Click OK for the activation window to appear and enter the activation code provided by Neuroscript. Click OK to release the copy protection and open the application.
* The program will be active for 30 days after you unlock it. After 30 days, you will be informed each time you run the application that your trial period has expired and given the option to purchase MovAlyzeR (and/or other components). During your trial period, you will also be sent periodic emails checking on your progress and reminding you of your pending trial expiration. 
* Help files are accessible in the application by pressing the F1 key, from the Help menu, or go to online help for documentation.
^Top

Purchased Version 
Make a backup of your user folders, if required. The root data path for a user is shown at Settings > Data path and Settings.
Note:
A new installation of MovAlyzeR will not overwrite the user data in folders created by the user.
Data in the example users UU1 and UUU will be overwritten. Do not store any valuable data in these locations. 
To purchase/activate MovAlyzer Suite items, open the MovAlyzeR trial version software, go to License in the application menu and choose Activate Product. 
NOTE: If the trial version has expired, you will be automatically prompted to activate features when you start the MovAlyzeR program. 
* Choose the items you want to purchase and click OK to display the activation window. Make a note of the Authorization Request Code. Exit by hitting cancel (if you do an online purchase, you will receive an email almost immediately and can leave this window open while you await the email containing your Activation Code). 
* Email NeuroScript at sales@neuroscriptsoftware.com or call us at 1.480.350.9200 with the Authorization Request Code to obtain a Activation Code for the purchased items. You will receive the Activation Code after payment has been received. 
* Start MovAlyzeR. Go back to the activation window as described in the first step of this section. Activate the program by entering the Activation Code provided in the activation window. MovAlyzeR is now ready!
^Top

To Deactivate (move to another computer)
There might be instances where you want to move your purchased MovAlyzeR software to another computer. This can be done by going to the License menu and choosing "Deactivate License". Doing this will render that copy of MovAlyzeR unusable at that point. You will be presented with an Authorization Request Code which you will need to send to NeuroScript at sales@neuroscripsoftware.com. This will inform us that one of your puchased licenses has been deactivated. When ready to install on a new computer, we will be able to get you up and running back to your original state knowing that you have deactivated your previous license.
It is important to remember, however, that the data you have collected on a previous computer (if locally stored) will need to be either exported and manually copied to the new computer. We are not responsible for any loss of data. You can contact support for further help. A system administrator might be required in order to achieve this. 
^Top
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To Upgrade/Update
Go to Help > Check for Updates to check if any new versions of the MovAlyzeR suite have been released. The updates will download and install automatically, unless additional directions are given by the updater. An internet connection is required to use this feature.
^Top

To Uninstall 
Go to Control Panel > Add/Remove programs > List > Select MovAlyzeR > Remove > Follow the instructions.
OR
Start menu > All Programs > NeuroScript > MovAlyzeR > Uninstall MovAlyzeR Suite
NOTE: For versions 3.40 and earlier, if you uninstall MovAlyzeR and then reinstall on the same computer, you can unlock the software by using the same Activation Code. The Activation Code expires after 10 days for a trial version.
^Top

© NeuroScript LLC. All Rights Reserved.

Defining New User
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
o Start MovAlyzeR by clicking the Start > Program Files > NeuroScript > MovAlyzeR > MovAlyzeR application or by double clicking the MovAlyzeR desktop icon. 

Click to EnlargeLabels of user ID:

Users
NeuroScript MovAlyzeR Help Send comments on this topic.

Page 3 of 8Installation

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh7798.htm



Green Check Mark - This user is in a valid and/or recommended location.Green Folder - This user is accessible, but is not in a recommended location.Red Folder - This user is located in a non-accessible location and must be moved.Red Check Mark - This is a private user of another windows user and is not accessible.
o You can select an example user from a list of predefined user that are provided for reference (UU1, UU2..) with the download. 
o To Create a new user click the '+' button.

o Move User Data Dialog:
In Vista, all users (even administrators) run applications with the least level of privilege. Therefore, certain physical locations on the operating system drive are not accessible (eg., under "Program Files"). Previous versions of MovAlyzeR defaulted user data to directly under the application's install location. With Vista, these locations will no longer be accessible. It will be required to "move" this user data (actually it just copies to a new location) by using the Move button in the User Management dialog. You can determine whether a user needs to or should be moved based upon the icons next to the user ID in this dialog.
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o User:
User ID: Type in a three letter user ID and description.
Change Password: To view or change subject-identifiable data (e.g., name, address, telephone, birth date, ...) you must unlock that information by entering a password. This password can be defined per user. The default password is userpass (the password is blank for the sample users UU1, UU2, etc.).

If you forget (have forgotten) your password, retrieve and send the following files to support@neuroscriptsoftware.com: user.dat and user.idx. The location of these files are in the installation directory of MovAlyzeR (default = C:\Program Files\NeuroScript\MovAlyzer). If you do not remember the location where you installed MovAlyzeR, right-click on the icon to run MovAlyzeR and select properties. In the field named "Start In", you will find the location mentioned above. 
o Settings: The settings specify the Root data path for data and for backup (e.g., on another disk). 
For each user, the root directories for the recorded and the backed-up data and other user preferences can be selected. It is recommended not to use "c:\program files" as data root directory but, rather an easy-to-identify directory on your local disk. 
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Private user?: Set the user as private if you do not want other Windows users to be able to open.
Generate subject IDs automatically?: Check if you want MovAlyzeR to generate subject IDs for you. Specify a starting ID (default=000) and an ending ID (default=ZZZ). The "Current" ID is the ID that is the last ID that has been generated. Clicking the "Reset Current" button will reset it to the starting ID. This is useful if you have removed several subjects. It will not, however, overwrite any existing subjects.
Sort alphabetically: By default the trials in an experiment per subject are sorted chronologically. You can also have them sorted alphabetically by checking the option in this window.
ID/Name delimiter: The character specified in this box is used to seperate ID and description of an item in the interface. For example, if the character is :, a group with ID ELD and description Elderly, will be displayed as ELD: Elderly. 
o Input device: Select mouse, tablet or Gripper as the input device. You can change the tablet mapping to map to the entire display screen or limit it to the recording window. Refer selecting input devices for more details.
~NOTE: The same window appears from main task bar, Settings > Select input device.
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To add more users/View all users while logged in as an exisiting user:
o MovAlyzeR main menu > File > Users
o Click on + to add users.  
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NSHelp: Experiment Input Device | Tablet Mapping
Getting Started: Recording Devices

© NeuroScript LLC. All Rights Reserved.

See Also 
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Wintab Digitizer Driver
This is a common topic for MovALyzeR and ScriptAlyzeR. Both programs will be referred to as MovAlyzeR on this page.
* Install Driver Software
* Adjust Settings

1. Mapping/Speed
2. Sampling Rate and Pen Pressure
3. Using Pen as Mouse 

Install Driver Software
o You will need to login with Adminstrator privileges on WinNT/2000/XP and later systems.
o The Wintab driver should be installed according the manufacturer's instructions. In general, the following steps can be followed: 

~ First uninstall (e.g., Double click My Computer > Control Panel > Add/Remove Programs) any existing Wintab driver version, disconnect any old digitizer, power down the PC, start the PC, power down the PC again.
~ Connect the new digitizer via USB or COM port. When you connect, your system may discover new hardware. 
~ Use the "have disk" option if you have an installation disk or start the driver install program downloaded from the tablet manufacturer's website (first open it to unzip the actual install program). Then follow installation instructions. It is recommended to store the downloaded install file for future reference.

o If install fails you may need to manually delete wintab32.dll in your \windows\system\ or \winNT\system32\ directory.
o If troubles persist, contact your digitizer manufacturer or see Trouble Shooting. 

Adjust Settings
o To adjust the settings, go to the tablet properties. Usually, by clicking Start > Settings > Control Panel > Digitizer or pen tablet (e.g., Wacom Tablet) > properties.
o Mode affects the sampling rate constancy (first most important) and height (second most important). Rates of about 100 Hz (e.g., 50 - 200 Hz) are acceptable. Standard mode is recommended.

1. Mapping/Speed
The following settings should be used in the driver properties. 
l Set entire Tablet is mapped
l Set entire Display is mapped
l Set scaling To Fit 
l Click ok to save
l Minimize all the application windows
l Place the pen on the bottom left corner of the tablet. (The tablet cursor should point to the bottom left corner of the monitor.) Move the pen over the tablet to the top right corner. (The cursor should now correspond to the top right corner of the monitor.) 

Note: If any of the above mentioned options are not available for your tablet, contact Neuroscript with tablet specifications to find out about alternatives. 
Any kind of tablet size mapping should be performed from within the MovAlyzeR program. (Refer this section on help)

2. Sampling Rate and Pen Pressure
o Differences between using the mouse and digitizer pen are: 

Wintab Digitizer Driver
NeuroScript MovAlyzeR Help Send comments on this topic.
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The use of Wintab precludes the selection of particular sampling rates. The sampling rates are, however, known and constant per setting. The actual, instantaneous sampling rate is shown while recording. For Wacom GD digitizers the following results are available.    
o The actual sampling rate can be measured from Settings > Testing Input Device. Refer to Test/Record input device.
The temporal accuracy does not necessarily improve with higher sampling rates as segmentation interpolates between successive sampling points. 

(*) The Recognition Data mode may offer the highest sampling rate but the isochronous sampling seems to be better in the Standard mode and is therefore prefered. 

3. Using Pen as Mouse 
o This property should be adjusted if you have a digitizer with a pen and you want to use the pen as mouse.
o Pen switches can be set to perform all mouse functions.

o IMPORTANT. Disable pen barrel switch to prevent problems when subjects unintentionally press the pen barrel switches during recording. 

o The double-click distance and speed may need to be adjusted to allow double-clicking with the double pressing the pen instead of Pen Switch. 

Data Mouse Pen
Position Neglects mouse movements in the air Absolute position on tablet
Direction Depends on the mouse orientation Depends on tablet orientation
Pressure 0 (when mouse button is released) or 99 (when mouse button is pressed) Continuous range from small (when the pen is lifted), to values higher than the Minimum Pen Pressure (when the pen is pressed)
Sampling rate Low, and falls to 0 when not moving the mouse High, and constant
Handwriting Awkward Natural
Hardware requirements No new equipment needed other than a high-quality (optical) mouse Requires digitizer

Setting >Select Input Device
Device actually used

Wacom Tablet Properties >Connection Mode=Standard   (RECOMMENDED)
Wacom Tablet Properties >Connection Mode=Recognition Data Constancy of Sampling Rate Pen Pressure Data

Pen Pen 100-130 Hz Max 200 Hz (*) Sampling rate constant while pen is in proximity of the tablet P = 0 - tablet max 
Pen Mouse N/A N/A N/A N/A
Mouse Pen 60 Hz Max 100 Hz (*) Sampling rate slows while pen is not moved 0 or 99 (if left switch pressed)
Mouse Mouse 40 Hz 40 Hz Sampling rate slows while mouse is not moved 0 or 99 (if left switch pressed)

Pen Function Mouse Function Equivalent
Press pen tip Click
Double press Double click
Upper pen switch: Switch 2 Double click
Lower pen switch: Switch 1 Right click
Move while pressing Move while clicked (dragging)
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Select Recording Devices
This is a common topic for MovALyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page. 
o Select recording device for the current user by clicking Settings > Recording Devices.

o By default, the input device is a mouse. You can select alternative movement recording devices, namely tablet or gripper. 
Tablet mapping:
Entire desktop: The tablet is mapped to the entire desktop to-fit. This means that the recording window will be a part of the tablet.
Recording window: The tablet is mapped to-fit to the recording window (whose size is determined by the size of the tablet mentioned in this interface).
For detailed information on tablet mapping, please refer to this section in help. 

- Conversion Table: You can use this table to convert from inches to centimeters (and vice versa) and also degrees to radians (and vice versa).
Display width & height: Specify the width and height of your computer monitor screen in cm. 
Tablet width & height: Specify the width and height of your tablet in cm. 
Acquire: The size can also be automatically obtained from the tablet driver installed, by using the 'Acquire' button. Please note that if you switch between tablets (even same manufacturer), you need to reinstall the driver to see the correct results in the automatic acquire options. 
Communications port for trigger pulses: Please refer this section on help

NSHelp: Tablet Mapping | Experiment Input Device | Device Setup Wizard
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Tablet to Display Mapping
This is atopic for MovALyzeR. 
The procedures and tests for display mapping options for various tablets are described in this section. Perform all the different tests to completely understand the procedure.
* Driver Settings
* MovAlyzeR settings
* Printing Elements/Stimuli Real Size

Driver Settings
First verify the driver properties: Control Panel > YourTabletDriver (Eg., Wacom) > Properties > Mapping/Speed tab.
o Reset all to default values if you have previously changed some settings (for Wacom tablets: click 'Reset Tablet to default').
o Verify that the entire tablet is mapped to the entire display and the aspect ratio is to-fit.

In Wacom: Tablet area = Entire tablet; Display Area = Entire Display; Aspect = Proportional; Orientation = Landscape.

MovAlyzeR Settings

See Also 

Recording Devices
NeuroScript MovAlyzeR Help Send comments on this topic.

Tablet Mapping
NeuroScript MovAlyzeR Help Send comments on this topic.

Page 3 of 28Wintab Digitizer Driver

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh1521.htm



Since the Wintab Driver does NOT pass its mapping properties on to MovAlyzeR, any kind of mapping must be done ONLY in MovAlyzeR. 
MovAlyzeR > Settings > Select Input Device > Tablet Mapping 
A. Choosing the Tablet area
o Specify the width and height of the display in cm.
o Tablet width and height: The height and width of the portion of the tablet to be used, measured from the bottom left corner of the recording window. 
1. To use the entire tablet, specify the original width and height of the tablet. 
2. To use a portion of the tablet, specify the size of the tablet as the area required instead of the actual area. 

For example, suppose the actual size of the tablet is width =12" and height = 12". If a mapping of tablet width = 12" and tablet height = 9" from the bottom left corner is needed, specify 30cm (12") and 22.5cm (9") in Tablet size boxes. 
Effectively you have a tablet mapping as below:

NOTE: MovAlyzeR will read only the mapped part of the tablet.
B. Mapping Options
NOTE: In this section, the term 'Tablet' will refer to the tablet area mapped as in the section above (Entire or Portion).
1) Tablet to Entire display
Settings: Choose options 'Entire Desktop' and 'Proportional' > click ok to save and close. 

Corresponding Experiment Settings:
l Select the experiment > right click > Experiment settings. 
l Choose the option, 'maximize recording window'. (The recording window expands during recording to fit almost the entire display, excluding the toolbars).

Test:
l Create a test experiment, group, subject and condition in MovAlyzeR.
l Select the scratch Subject > right click > Run experiment. 
l Record a trial by placing at pen at (0,0) of the recording window and moving it to the top right corner. 
l During recording, the entire diagonal will not be shown in the recording window, but is recorded.
l Verify that in Trial > right click > Chart data > Chart processed data > x,y chart.
l The diagonal would be such that the longer dimension of the tablet portion is accomodated. (e.g., if a 20x15 cm portion of a 30x30cm tablet is mapped, then the x-size of the diagonal would be 20 cm, but the y-size is smaller than 15 cm). 
l When using a stimulus, the origin from which the target position is measured is that of the display and hence the targets are shifted. On the tablet, the corresponding target position will still be in the same position as defined. 

2) Tablet to Recording Window 
Settings: Choose options 'Recording window' and 'proportional' > click ok to save and close. 
The entire tablet is mapped to the recording window as follows:

Corresponding Experiment Settings:
Experiment > right click > Experiment settings > Recording

Option (1): Check option 'Maximize recording window'. 

Page 4 of 28Wintab Digitizer Driver

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh1521.htm



The recording window expands during recording and the tablet is mapped proportionally to this. 
Option (2): Check option 'Make recording window real-size' (REAL SIZE TARGETS). 
In experiments with visual feedback, it is crucial that the size of the targets on the computer display and the tablet are real-size. Additionally, the recording on the tablet when visually fed back should reflect the actual sizes of the strokes.

Test: 
For Option (1)

l Select the scratch Subject > right click > Run experiment. 
l Record a trial while producing a diagonal from (0,0) of the recording window to the top right corner. 
l During recording, the entire diagonal should be just visible inside a portion of the recording window. 
l Verify the data by Trial > right click > Chart data > Chart processed data > x,y chart . 
l The diagonal should measure from 0,0 to x-size,y-size (of the mapped portion of the tablet) . 

For Option (2)
Test 1:

¡ Select the scratch Subject > right click > Run experiment. 
¡ Record a trial while producing a diagonal from (0,0) of the recording window to the top right corner. 
¡ During recording, the entire diagonal should fit exactly with the recording window on the screen. 
¡ Verify the data by Trial > right click > Chart data > Chart processed data > x,y chart . 
¡ The diagonal should measure from 0,0 to x-size,y-size (of the mapped portion of the tablet) .

Test 2: 
¡ Define an element > Square of 1x1 cm in the middle of the tablet portion (x-halfwidth=1cm/2, y-halfwidth=1cm/2).
¡ At the center of the tablet (Center point X= tablet portion width/2 and Centerpoint Y = tablet portion height/2).
¡ Create a new stimulus > add the element to the stimulus. Then add the stimulus to the experiment condition.
¡ Experiment > Run a trial > Measure the size of the stimulus on the screen, using a ruler. 
¡ The data should be exactly 1x1 cm.
¡ Run another trial > Make of recording by drawing on the outline of the stimulus square.
¡ Verify the data by Trial > right click > Chart data > Chart processed data > x,y chart .
¡ The recording should show a square of 1x1 cm.

Printing Elements/Stimuli Real Size
To print a stimulus in real-size on paper (i.e., the same size as on the digitizer), so that subjects can perform writing tasks with direct visual feedback instead of displaced visual feedback via the display, MovAlyzeR needs to know the actual sizes of the x and y axes produced by the particular printer.
l Chart the stimulus by right clicking the particular stimulus > Chart or > Properties >Chart.
l Check MonoChrome.
l Print (yielding an as-is print).
l Measure the actual size of the x and y axes (e.g., 21 cm and 14 cm, respectively).
l Specify these sizes in MovAlyzeR by right clicking inside the stimulus chart > Customization > Axis. Fill out the min and max of the x-axis (e.g., 0 cm and 21 cm, respectively) and similarly 0 cm and 14 cm for the y-axis.
l Print (yielding the real-size print).

NSHelp: Experiment Input Device | Device Setup Wizard
Getting Started: Recording Devices | MovAlyzeR to Test Digitizers
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Testing Digitizer/Mouse
This is a common topic for MovAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Before starting the tests, choose the device to be tested (settable per user), main Tool bar > Settings > Select input device. Verify that the dimensions and mapping are correctly set.
Device Settings
1. Resolution
Resolution can be obtained from Manufacturer's specifications. This is however the hardware resolution and the driver in some tablets may not be able to provide data at such a resolution. Resolution can be verified from the following tests:
a. By making a recording

See Also 

Testing Digitizer/Mouse
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o Settings > test input device > test device free hand.
o In the Dialog window, use the default settings:

o Place a ruler on the tablet and consider two points A and B horizontally, at a distance D1 cm. In case of the mouse, place a ruler on the mouse pad instead.
o Click Go to start the recording > Place the pen at point A and move till point B.
o Go to the raw data chart after recording by trial > right click > chart raw data
o Derive the distance between the two y coordinates precisely = |x1-x2| points.

Device Resolution (in cm) = D1/|x1-x2|
For example: For a graphire3, the difference in X coordinates in the x-y raw data plot, yielded 4000 points, when a line of 5cm recording was made on the tablet. Hence, the resolution is 5/4000 = 0.00125 cm
The difference in coordinates can also be found by opening the raw data file (user root folder > folder named with experiment ID > test.hwr), and considering the first and last Y coordinates (2nd column). The user root folder is the folder where you store the data for your current experiment (file > users..> click on user ID >

o Repeat the test by drawing a line in the vertical direction and measuring the Y-coordinate distance.
o Take the average of the two results or perform more iterations, to arrive at a device resolution.
Note:
Alternatively, if you want to keep the recording stored, you can create an experiment with two conditions, one for horizontal line and one for vertical line and record the movements under a subject.
b. Obtain values from the driver
MovAlyzeR has a provision to obtain the resolution, sampling rate and pen-pressure, returned by the tablet wintab driver. In case of mouse, the default settings from Windows are displayed.
You need to go to an experiment under the current user > right click > experiment settings > input device settings > click reset defaults > the corresponding values returned by the driver are displayed.
Results (tablet)

2. Sampling Rate
a. By making a recording
o The test procedure can be started by Settings > Test/Record Input Device.

Tablet make Wacom Aiptek GTCO Calcomp
Type Graphire 3 Intuos 2 8000U CAD Pro
Size (WxH") 8x6" 8x6" 8x6" 9x6"
Manufacturer Specified resolution 0.00125 cm (80 L/mm) 0.001 cm (1000 L/cm) (2540 L/in)  Max. 3048 lpi / 120 lpmm 0.000625 cm (1600 L/cm) (4000 L/in)
Resolution from test a. 0.00125 cm 0.001 cm  0.00508 cm 0.00253 cm
Actual resolution (obtained from the tablet driver)

0.00125 cm 0.001 cm  0.00508 cm 0.00254 cm (394 L/cm)
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The following window is displayed:

o 'Test device free-hand' > GO
o In the resulting dialog window, specify the resolution obtained from previous testing, and use the defaults for sampling rate and pen-pressure.
o Make a free-hand recording (say loops) on the tablet by looking at the recording window on the screen.
o During recording, read the Timer Call and the Position Update frequencies (i.e., frequency that the PC calls for and receives points, respectively). These frequencies should be equal. If not contact NeuroScript. Use the value that occurs most frequently during the movement, as the sampling frequency.

~ The recording window properties are derived from the settings of the previous experiment run for that user. If you have not yet recorded through an experiment, in the current user, the recording window will be as default: Expanded and mapped to the entire tablet.
~ When the pen exceeds the digitizer window, recording discontinues.
~ Lifting the pen too far away from the digitizer may suspend recording.

o After completing the recording, the data recorded are shown.
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o The small squares mark the individual samples. The distances between the samples (representing time intervals of 1/Sampling Rate) should vary fluently and should not show any gaps. Irregular spacing implies undesirable, non-constant sampling. The pen-ups are marked with a grey color.
o Charts of recorded data: X-Y, X-Z, Y-Z, Sample number vs. X, Y, and Sample number vs. z are available. Charts can be customized and exported, for more details, refer chart properties help page.
b. Obtain values from the driver
MovAlyzeR has a provision to obtain the resolution, sampling rate and pen-pressure, returned by the tablet wintab driver. In case of the mouse, the pen pressure is always 1.
You need to go to an experiment under the current user > right click > experiment settings > input device settings > click reset defaults (need to do this only if you have not already done so, while determining the resolution) > the corresponding values returned by the driver are displayed.
o To see how the tablet driver or mouse settings can affect the sampling rate, see this section. The mouse speed can be manipulated via My Computer >Control Panel >Mouse. Under Pointer Options > Select Pointer Speed. Also in Pointer options> Switch OFF the option 'Enhance Pointer Precision'. For maximal resolution, set mouse speed as fast.
Results (tablet)

Pen Pressure
To see how the tablet driver settings can affect the pen pressure, see this section.
a. Obtain values from the driver
MovAlyzeR has a provision to obtain the resolution, sampling rate and pen-pressure, returned by the tablet wintab driver. In case of the mouse, the pen pressure is always 1.
You need to go to an experiment under the current user > right click > experiment settings > input device settings > click reset defaults (need to do this only if you have not already done so, while determining the resolution or sampling rate) > the corresponding values returned by the driver are displayed.
Results (tablet)

Pen Proximity
The distance from the surface of the tablet up to which pen movements are detected and recorded.
o Keep a ruler vertically on the tablet.
o In MovAlyzeR, Settings > Test/Record input device > Test device free-hand > go.
o Move the pen back and forth over the tablet and move vertically down from say 3 cm, until the point where the cursor on the display shows some movements and gray lines.
o Repeat the process to get the position more precisely moving in the area detected earlier, to find the point beyond beyond which there is no movement detected.

Tablet make Wacom Wacom Aiptek GTCO Calcomp
Type Graphire 3 Intuos 2 8000U CAD Pro
Size (WxH") 8x6" 8x6" 8x6" 9x6"
Manufacturer Specified Sampling rate (Hz) 100 100 (200Hz in recognition data mode)

 150 200 (Max data rate of 200 Coordinates per second)
Measured sampling rate (Hz) (from the above test) 100 101 to 103 127 67

Measured sampling rate (Hz) (from the tablet driver ) 100 100  150  75

Tablet make Wacom Wacom Aiptek GTCO Calcomp
Type Graphire 3 Intuos 2 8000U CAD Pro
Size (WxH") 8x6" 8x6" 8x6" 9x6"
Pen-Pressure (from the driver)  1  1  8  1
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Getting Started: MovAlyzeR to Test Digitizers
NSHelp: Testing Subject (Gripper)

© NeuroScript LLC. All Rights Reserved.

Testing Digitizer / Tablet Linearity
This is a common topic for MovAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Manual diagonal line
This test is available only when input device selected is tablet.
The linearity and accuracy of a pen tablet can be tested manually by generating a diagonal line with a fluent movement using a ruler. In this test, the orthogonal error, longitudinal error and number of missing samples are charted as well as logged in to the results window & log file.
Enable Logging To view the numerical results of the test, first clear the existing log file by File > Logging > Clear Log File. Then enable logging by File > Logging > Content > Select All, followed by, File > Logging > Log Actions to File.
Input device settings Main tool bar > Settings > Test/Record input device > Settings, select the option 'make recording window real size'.
Note: If you are repeating the test, and you want to look only at the newest results, do File > Logging > Clear Log File.
o Select 'Test device for linearity' > 'Manually draw a diagonal line' > GO.

Perform Recording Using a ruler, draw a line from the 0,0 point of the recording window to the top right corner of the window. Make sure that the pen tip is kept touching straight on the tablet without much tilt. Otherwise, this could lead to linearity errors introduced manually. Also, the movement must be made as smoothly as possible, to avoid introduction of temporal errors.
The raw data plot is displayed.

Data charts: They are displayed automatically after the recording. Use the up-down arrow keys beside the Chart drop down box to see plots of the following parameters.
1 a. Orthogonal Error- Horizontal Spacing between successive samples (X coordinate)
1 b. Longitudinal error- Distance between samples (Y coordinate), which is also the vertical velocity per sample. Go to the chart of x Vs y > Right click > Plotting method > Points + Line. See if the samples are spaced uniformly.

Note approximately the average level of the curve (average vertical velocity).

Tablet make Wacom Wacom Aiptek GTCO Calcomp
Type Graphire 3 Intuos 2 8000U CAD Pro
Size (WxH") 8x6" 8x6" 8x6" 9x6"

Specified by manufacturer  0.04" (1mm)  0.24" (6mm)  0.32" (8 mm)  0.4" (10.16 mm)

Measured from the above test
 10mm 16 mm 26 mm 12-13 mm

See Also 

MovAlyzeR to Test Digitizers
NeuroScript MovAlyzeR Help Send comments on this topic.
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2. Number of missing samples: The number of missing samples from the tablet can be viewed with 1 sample as reference.

The chart values indicate the following:
0 to 0.58 (2 or more samples extra)0.58 to 0.75 (1 sample extra)0.75 to 1.5 (Perfect, 1 indicates NO samples missing)1.5 to 2.5 (One missing sample)2.5 to 3.5 (2 missing samples)3.5 and above (3 or more missing samples)

Example 1: Noisy tablet - missing samples.

The test consisted of a back and forth movement. The two movement regions above average velocity are between samples 26 - 50 and 72 - 93. Between samples 26 - 50, there are 6 cases of 1 sample missing shown by the 6 peaks. Similarly there are 5 cases of 1 missing sample in the region samples 72 - 93. 
Example 2: Multiple missing samples
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1 missing sample at sample number 23
2 missing samples at sample number 26
In all the above charts, the error values (y-axis data) are all zeros, for samples which have an absolute velocity smaller than the average absolute velocity. This is done to ensure that the calculations are performed only for the movement data and not the noise/pen-up movements.
Numerical data/View log file or Results window: The log file and results window now contain all the numerical values from the test/record input device. Log file can be viewed by File > Logging > View Log File.
o Click here for an example of the resultant log file
The relevant information from the above file are summarized below:
Linearity Test: *****DEVICE SETTINGS *****Linearity Test: Device Resolution = 0.00508 cmLinearity Test: Sampling Rate = 150 HzLinearity Test: Minimum Pen Pressure = 1Linearity Test: |***** SAMPLES *****Linearity Test: | # Input samples = 125.Linearity Test: # Samples after trailing penlift removed = 107Linearity Test: Xlength =   2013 units = 10.23 cm, Ylength =   2073 units = 10.53 cm, Absolute length = 2889.55 units = 14.68 cm.Linearity Test: Average velocity = 27.3 units/sample = 20.8 cm/s.Linearity Test: Consider points with velocity > 1.33 * (Avg Vel of entire movement).Linearity Test: Segment 0: Samples 55 to 91.Linearity Test: |  ***** SPATIAL ERROR (Accuracy of the device)*****Linearity Test: |  RMS coordinate error = 2.14 units = 0.0109 cm.Linearity Test: RMS quantization error due to the device resolution = 0.289 units = 0.00147 cm.Linearity Test: RMS spatial error relative to quantization error = 7.43Linearity Test: RMS coordinate error without quantization error = 2.12 units = 0.0108 cm.Linearity Test: (If RMS coordinate error without quantization error approaches the spatial error, a better device resolution will not improve accuracy).Linearity Test: Length of fitted line = 427 units = 2.17 cm; Straightness Error = 0.00502.Linearity Test: Rotated counterclock (rad)= 0.775 = 88.8 degree.Linearity Test: |  ***** TEMPORAL ERROR (Missing/extra samples)*****Linearity Test: |  Total sampling irregularities = 24.3%Linearity Test: # Samples above average velocity to be used in the linearity test = 37Linearity Test: # Cases of     1  Samples Missing = 9Linearity Test: # Cases of     2  Samples Missing = 0Linearity Test: # Cases of >=3 Samples Missing = 0Linearity Test: Total             # Samples Missing = 9 = 24.3%Linearity Test: # Cases of     1  Samples Extra = 0Linearity Test: # Cases of     2  Samples Extra = 0Linearity Test: # Cases of >=3 Samples Extra = 0Linearity Test: Total             # Samples Extra = 0 = 0.0%Linearity Test: Refer to DIS file for further missing sample information.

Results (tablet)
The above test was performed two or more times, and the best result is presented for each tablet in the table below:
Tablet Wacom Intuos 4 Wacom Intuos 3 Wacom Intuos 2 Wacom Graphire 3 Aiptek 8000U GTCO Calcomp CAD Pro
Size (W"xH") 8"x6" 8"x6" 8"x6" 8"x6" 8"x6" 9"x6"
RMS sample error (cm) 0.00662 0.00914 0.00685 0.00811 0.0136 0.00827
#Samples in movement range 54 175 133 224 205 144

Frequency of Missing Samples
1 sample missing 0 % 0 % 0 % 0 % 25.85 % 2.9 %
2 samples missing 0 % 0 % 0 % 0 % 0 % 0 % 
3 samples missing 0 % 0 % 0 % 0 % 0 % 0 %
Frequency of Multiple Samples
Double samples 0 % 0 % 0 % 0 % 4.39 % 2.08 %
Triple samples 0 % 0 % 0 % 0.04 % 22.92 % 0.07 %
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Real-Life testing
Aim of this test is to replicate the behavior of the tablet from within the program by data generation and simulation (using the device parameters specified and the noise value calculated from previous test)
Generate Data
First, make a note of the user root folder, where all the current user data is stored on your computer, (can be determined from files > users > click user ID > properties > settings)
1. Settings > Test/Record input device > Test device for linearity > Generate a diagonal line
2. To generate 8 circles of 1 cm diameter at 5 Hz, Click the 'settings' button > predefined = custom > fill out the following settings

a. with no noise:
Noise = 0, Device Settings => uncheck the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)

Click ok > Click 'Go' > Input the actual resolution, sampling rate and pen pressure for the tablet
3. On the test/record window click ok to display the chart. Leave the chart open.
4. Go to the user root folder in windows explorer
5. Navigate to test.hwr > open > save as EEEGGGSSSCCC01.hwr in any local folder (say 'trials')
6. Repeat steps 1. - 5. saving the files as EEEGGGSSSCCC02.hwr, EEEGGGSSSCCC03.hwr, EEEGGGSSSCCC04.hwr EEEGGGSSSCCC05.hwr and EEEGGGSSSCCC06.hwr using each of the following settings and instructions for step 2.

b. With quantization noise and no white noise
Noise = 0, Device Settings => check the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)
c. With no quantization noise and white noise = RMS noise obtained from previous test
Noise = RMS noise, Device Settings => uncheck the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0.4), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)
d. With quantization noise and white noise = RMS noise obtained from previous test
Noise = RMS noise, Device Settings => check the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0.4), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)
e. with no noise and one in 5 samples missing:
Noise = 0, Device Settings => uncheck the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)
On the test/record window click the button view/edit.
In the test.hwr displayed, remove 1 in every 5 samples (Click here for a procedure to automatically do this. Extract the .zip file contents, read readme file for instructions)
Save the file > close file. Click ok on the test/record window to display the generated data chart.
f. with no noise and random samples missing:
Noise = 0, Device Settings => uncheck the option 'Round raw data', Start time = 0, stroke duration = 0.2, number of strokes = 16, trail time = 0, X-movement pattern (position start = 0.3, size of stroke = 1, start phase = 90, velocity = 0), Y-movement pattern (position start = 0.3, size of stroke = 1, start phase =0)
On the test/record window click the button view/edit.
In the test.hwr displayed, remove random samples (To automatically do this, refer the procedure mentioned in the previous step)
Save the file > close file. Click ok on the test/record window to display the generated data chart.

7. Repeat steps 1. - 6. for 1 Hz frequency movement (that is, to set, stroke duration = 1 sec and x velocity = 0.4 cm/s) for the step 2. settings. Save the files with EEEGGGSSSCCC(07 to 12). hwr respectively.
Process data
1. Create an experiment EEE, with group GGG, subject SSS and condition CCC. Refer to the tutorial to create a minimum-size experiment.
2. Verify in Settings > select input device, the tablet dimensions and mapping. Refer to the section on mapping for mapping options.
3.Experiment > right click > experiment settings > processing > time functions > filter frequency, set to 7 Hz.
4. File > import > data import wizard > data type = Movalyzer, path = select the path to the 'trials' folder with all the trials > select experiment EEE, group GGG, condition CCC, and subject SSS > click finish.
5. All the 12 trials should now appear under the experiment when the left tree is expanded.
6. Right click subject SSS > Reprocess trials.
Analyse data
To summarize, the trials indicate the following:

EEEGGGSSSCCC01 - 5 Hz data with no noise
02 - b. With quantization noise and no white noise
03 - c. With no quantization noise and white noise = RMS noise obtained from previous test
04 - d. With quantization noise and white noise = RMS noise obtained from previous test
05 - e. with no noise and one in 5 samples missing
06 - f. with no noise and random samples missing
Similarly for trials 7-12 with 1 Hz data

Trial > right click > chart processed data > normalized jerk vs. time: This chart shows the effect of the above scenarios on the normalized jerk.
For example, the presence of RMS noise (introduced by the noise from tablet) might increase the jerk to a certain extent. Also the missing samples result in a huge jerk value. Thus, the comparison of the different trials yields to an understanding of the effect of linearity error and missing samples on the data, for the particular tablet under test.

IV. Results
Tablet make Wacom Wacom Aiptek GTCO Calcomp
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NSHelp: Testing Subject (Gripper) | Discontinuity settings - Processing Time Functions
Getting Started: Testing Digitizer/Mouse

© NeuroScript LLC. All Rights Reserved.

Trigger Pulses / Synchronization
(Serial Port Triggers)
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
MovAlyzeR/GripAlyzeR programs allow synchronization of the program with external hardware or software. A trigger pulse can be sent through the DTR and RTS pins of the serial (communications) port of your computer. 
The option is available only in systems running Windows2000/XP or later. 
Port Selection: First select the comm port you want to use for this purpose (typically COM1 - COM4).
From the main menu, if you select Settings > Select Input Device > Communications port of trigger pulses.

Checking the option 'Show only available ports' detects and lists only the ports that are available for use.
Setting Trigger pulses per condition: Trigger pulses can be set for each condition of an experiment. In the "Sound" section of a particular condition, there is a checkbox to send a trigger pulse to the communications port. This is described in the help > creating experiment conditions.Operation: 
When the communications port is first opened, both DTR and RTS are on. 
When an event occurs, both DTR and RTS are set off for a duration of 25 milliseconds, then both turned on again (trigger pulse of high to low transistion and duration 25ms).
Eg., if the condition settings > sound, the options are set to send trigger pulse for the event - start of recording, the following would be the representation. 

Type Graphire 3 Intuos 2 8000U CAD Pro
Size (WxH") 6x8" 6x8" 6x8" -

Average Normalized Jerk per trial

5 Hz 1 Hz 5 Hz 1 Hz 5 Hz 1 Hz 5 Hz 1 Hz
7.7586 7.9855 7.7586 7.9855 7.7586 7.9855 7.7586 7.9855
7.9857 10.0705 7.7510 10.0705 7.7510 10.0705 7.7510 10.0705
7.7941 102.8650 7.8230 132.6889 7.8881 223.5679 7.7950 121.8871
7.7876 104.6471 7.8203 120.6653 7.9066 208.205 7.7950 133.1956
7.7506 8.1397 7.7506 8.1397 7.7506 8.1397 8.7541 8.1397
8.7897 81.8999 8.7897 79.8216 8.7897 81.8999 8.7541 81.8999

See Also 

Synchronization
NeuroScript MovAlyzeR Help Send comments on this topic.
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Installing DAQPad
This topic is ONLY for GripAlyzeR.
The operation of the gripper device or another external interface device is through a Data Aquisition Device (e.g., DAQPad 6020E from National Instruments).
o Interaction of GripAlyzeR program with the device requires the appropriate driver for the data acquisition module. The following device is normally used with the gripper device from Neuroscript. 

- Data Acquisition Pad NI-DAQPad-6020E for USB, <100 kS/s, 12-Bit, 16 Analog Input Multifunction DAQ. Download Driver for this module from the NI website here. 
o Run the NI Measurement & Automation explorer that is installed with the driver.
o Go to MySystem > Devices & Interfaces
o Verify that the DAQpad 6020E is listed and if not, try rerunning the NI Measurement & Automation, or press Refresh (F5). Also make sure that it shows the DAQPad as Device1. If not, right click on the device listed > Properties > Set Device number = 1
o Connect the DAQpad Interface provided with the device and the upper and lower gripper to the connector pins on the interface. 
o Use a 12 V, - to + AC/DC power supply for both the NI DAQpad and the interface circuit.
o Switch on the NIDAQ pad. The Device configured green LED at the back of the device should now be on. 
Testing the channels using Measurement & Automation explorer 
o Run the NI Measurement & Automation explorer
o Right click on the MySystem > Devices & Interfaces > DAQPad6020E > Test Panel.

o Choose Channel = 0 and lightly tap/apply pressure to the upper grip sensor plate. The test panel window will show the corresponding variations. The output from all the channels at rest is 5 V. For Channel 0, the range of voltage variations is 5-10 V. 
o Similarly, Channel = 1 corresponding to load sensor and Channel = 2 for lower grip can also be tested. For Channel 1, the voltage range is 5 V - 0 V (Negative direction) as it is pushed in to make contact between upper and lower grip. For channel 2, range is 5 - 10 V. 

© NeuroScript LLC. All Rights Reserved.

Gripper/DAQPad as Recording Device 
This is a topic ONLY for GripAlyzeR.
o Select the recording device by clicking Settings > Select Input Device > Input Device
o By default, the input device is a mouse. 
o Select the DAQPad as the alternative movement recording device.

Installing DAQPad
NeuroScript MovAlyzeR Help Send comments on this topic.

DAQPad Device
NeuroScript MovAlyzeR Help Send comments on this topic.
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o Select the mapping by:
Entire desktop: The recording window with the MovalyzeR toolbars will be maximized to fit the entire desktop. 
For proper functioning of this option, verify per experiment, that in experiment > experiment settings > Option 'Maximize recording window' is checked.

OR
Recording window: The tablet is mapped just to the recording window proportionally.
For proper functioning of this option, verify the setting in experiment > experiment settings > Option 'Make Recording Window real-size' is checked.
Display width & height: Specify the width and height of your computer monitor screen in cm. 
NOTE: If any of the above settings are changed (e.g., running it with a different size display), they need to be updated in the settings, before any of the experiments under that user is run. 
Input Device Settings
o Set the DAQPad settings by clicking Settings > Select Input Device > DAQPad settings

o Device=1: To use the gripper device by Neuroscript, this device number should be set to 1, otherwise, use the device number that is configured by Measurement and Automation Explorer as below. 
NOTE: Start the Measurement & Automation Explorer that comes with the NIDAQPad driver. Mysystem > Devices and Interfaces > DAQPad6020E > right click > properties > Check the device number. For the gripper device, set it to 1 if it's not set to that already. In other devices, update the Movalyzer device settings with the device number used in DAQPad. 
o #Channels=3: For the gripper device set the number of channels to 3. In other devices, set this as the number of channels to be scanned for input from the DAQPad. 
o Scan Rate=100 (Hz): The scan rate is comparable to the digitizer sampling rate. 
WARNING: Setting the scan rate very high, example 500 Hz will result in the loss of sampling points and empty processed data files. During processing of the trial (by default, after recording the trial), warning messages are displayed in the results window (and eventually actions.log file), when this happens and any further processing/recording of data is terminated. Also a message that the corresponding .SEG file is missing might be displayed after recording the first trial. 
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NOTE: During processing, this scan rate should be entered under Input Device Settings Sampling Rate. Right-click the particular experiment > Experiment Settings > Recording > Input device > Sampling rate=200 Hz.
o Sampling Rate=100000 (Hz): This is the rate of sampling BETWEEN the channels and is chosen maximally.
o #Samples: (per trial) The duration (s) of a trial is equal to #Samples/Sampling Rate (Hz). 
For example, if you want to run a trial for 10 sec and the sampling rate is 100Hz, then the number of samples should be set to 10*100 = 1000 samples in the input device settings.
These settings are per user, hence, each time the user runs a new experiment, verify that the number of samples will satisfy the duration/trial for the new experiment. 
o #Baseline Samples is the initial number of samples to calibrate the current zero levels for all Gripper sensors. NOTE: During that time, the Gripper should be at rest and not touched. 
o Report Data type to be stored in the raw data files: Raw DAQpad units, Volts, or Newtons (recommended for gripper). 
NOTE: During processing, data should not be converted. Right-click the particular experiment > Experiment Settings > Recording > Input Device > Device resolution=1 N.
o Single Buffer Mode: Data are stored first and then displayed (Single Buffer). #Samples option for double-buffering is disabled in this case. 
o Double Buffer Mode:# Samples specified are stored and displayed while the next #Samples are stored in the other buffer (Double Buffer). This allows almost real-time feedback of Gripper recordings. On fast machines, use #Double-buffer samples=10. On slower machines this number should be increased.
o Channel Selection and properties: For Lower Gripper, Upper Gripper and Load force.
The channel selection depends upon the interface card. Gripper III requires Lower Grip=Channel 1, Upper Grip is Channel 2, and Load is Channel 1. 
Manufacturer's test data of the particular sensors (e.g., Entran ELPM-T2E-251*) determine the following settings: Gain=2.5 mV/V, Full Scale=25 Lbs, Calibration=1260, Excitation=5 V. 
o Gain (mV/V) is the output voltage under full scale load per Volt excitation. This setting is needed to report voltages or Newtons.
o Full-Scale Load (Lbs) is the maximum calibrated force that can be measured accurately. WARNING: Exposing the sensors to higher forces may result in irreversible damage.
o Calibration Constant is the scale factors expressing N/mV per sensor. In the Gripper, the two grip forces are calibrated for (positive) compression force and the load force for (negative) tension force. The calibration constant increases with the Gripper board's multiplication factor. 
o Excitation (V) is the voltage across the sensor. The sensor outputs a voltage that is a fraction of the excitation voltage. This setting is needed to report voltages. The fraction depends on the load. The normal excitation voltages for the gripper are as in the above settings window. WARNING: High excitation voltages may cause irreversible damage.

© NeuroScript LLC. All Rights Reserved.

Testing Gripper
This topic is for ONLY for GripAlyzeR. 
Bimanual force coordination (GripAlyzeR & Gripper) - Hardware/Software Testing Protocol
This section provides procedures to test the gripper device using GripAlyzeR. The results obtained when performed at NeuroScript are also provided for comparison. 
Introduction
The tests listed below need to be conducted by users:
l To familiarize and characterize how the GripAlyzeR measures 
l To characterize the sensor performances
l To verify that the Gripper functions within the specifications and with accuracy

These tests also have to be conducted:
l When receiving a new Gripper device and updating the device settings
l Before starting a new study
l After completing part of a study to verify the Gripper was stable
l After an extraordinary event that may have compromised the Gripper

Contents
I. Determine Baseline

Baseline for tests
Effect of magnet weight on the load sensor baseline

II. Test Force Sensors
1. Static Measurements

1.1. Calibration
1.1.1. Bottom grip-force sensor1.1.2. Top grip-force sensor 1.1.3. Load sensor

1.2. Random noise
1.3. Frequency spectrum
1.4. Force sensor plates: Central and off-central pressure

2. Dynamic Measurements 
2.1. Relative linearity
2.2. Calibration of sampling rate and time

Testing Gripper
NeuroScript MovAlyzeR Help Send comments on this topic.
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2.3. Sudden force changes
2.4. Inertial forces

2.4.1. Internal sensor inertia2.4.2. Inertial forces due to the magnet
2.5. Timing of the peak of the load force relative to the magnetic polarity change

III. Test Magnet properties 
1. Magnet strength
2. Residual Magnetism
3. Vacuum Suction
4. Friction

I. Determine Baseline
1. Baseline for tests
The baseline or reference level per session is the signal level determined during the first n baseline samples (set as 10 samples). Ideally, this value should be kept as close to 0 level as possible. The following procedure ensures this:

~ Place the top and bottom units horizontal on the table at rest.~ Start GripAlyzeR > Run one trial for the grip-force experiment. If required, stop after first trial. ~ Trial > Chart processed data, the reference/starting level should be close to zero or zero. If not, restart the application and repeat the test. 
Perform the test each the application is started. 
2. Effect of magnet weight on the load sensor baseline

~ Place the top and bottom units horizontal on the table at rest.~ Start GripAlyzeR > Run one trial for the grip-force experiment. ~ For the second trial, place the lower unit vertically on the table with the magnet facing up first and run the trial with units at rest. ~ Second Trial > Chart processed data > Z value vs. time, shows the difference in the baseline value after having included the effect of the magnet (since the second trial is with the magnet facing upwards) ~ The effect of the weight of the magnet on the magnet sensors baseline has shown to be about 0.5 N during our tests. Hence it has to be accounted during other tests involving the pulling force on the magnet. ie., there is already a pushing force of about 0.5 N on the load sensor, when placed vertically. 
Eg., 

We can notice from the above chart, there is a difference of about 0.5 N in the baseline values. 

II. Force Sensors
1. Static Measurements
Equipment: The gripper consists of 3 force sensors (Entran's ELPM-T2E-03-25L, S/N 02102H31-B02, B03 and B04). The gripper is connected to the PC through the National Instruments DAQpad 6020E (12 bits). 
Testing Environment/Settings in GripAlyzeR:
The tests were performed in GripAlyzeR 2.8/2.85 and will also apply to future versions of GripAlyzeR. 
Input device settings (GripAlyzeR menu > Settings > DAQPad settings):

~ Set Scan rate per channel = 100 Hz (3 channels were sampled each time at a rate of 10000 Hz). ~ Set Number of samples = 1000 (10 s) next to the scan rate. (Recording time (s) = number of samples/scan rate). Baseline samples = 10. (After the application is started, the input value during the first 10 samples is set as the zero level for the entire session)~ Choose the options 'Report in Newtons' and 'Double buffer mode' (20 buffer samples)~ For all 3 channels, Gain = 100 mV and excitation voltage = 5 V (Specify the values as designed in the interface circuit)~ Specify the full-scale load (25 lbs) and the calibration constant values as derived from the specification sheet of the corresponding sensors. Refer to Selecting Gripper Device topic on the help for detailed information on these terms. 
Data collection/Experiment settings
Grip-force experiments, groups and subjects are created in GripAlyzeR. To collect trials for the different tests, add conditions/subjects to the experiment. Alternatively, you can split the data collection across two or more experiments. 

~ Experiment > Experiment Settings > Recording > Choose 'Delay trial until Enter key pressed' and 'Accept/Redo trial', as required. Please refer help on Experiment Settings for the implications. 
~ Settings > DAQPad settings > scan rate. Set the scan rate between 100 - 200 Hz. Also in Experiment > Experiment settings > input device settings > sampling rate, set the value equal to the scan rate. 

Note: An experiment can be run per subject and not condition. If you want to redo only a particular condition, you need to perform trial > redo trial, per trial. The exact organization of the experiment(s) is defined by you. 
Note: More tests/Enhancments to the existing tests might be added in due course. Check regularly for updates.
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1.1. Calibration
Note: For the following calibration tests, the sensor units need to be placed horizontally at +/-6 degrees, so that the error is less than 0.1%, which is much smaller compared to the sensor accuracy of 1%
1.1.1. Bottom Grip-force Sensor
Purpose: To verify the GripAlyzeR system is measuring the correct force as applied to the lower grip sensor. 
Procedure:
Run two trials for each of the 3 different weights as follows:

~ Before starting the recording, place the weight on the force sensor plate of the lower Gripper unit resting on a horizontal surface. 
~ After the trial starts, wait for 2-3 s and then remove the weight.
~ After every trial recording ends, put the weight back on the sensor plate for the next trial during the trial-trial pause. (before pressing enter key to start the consecutive trial) and perform three trials. 

The weights used in our tests were 50 g, 100 g, and 200 g. The equivalent force level is F = g * m, where g = 9.81 m/s2 or N/kg. Thus the equivalent forces were 0.4903, 0.9807, or 1.9614 N, respectively. 

Analysis:
View raw data: View the raw data for a trial (Trial > View raw data) from the GripAlyzer consists of X, Y and Z values. The bottom sensor output is the X-axis data.
Derive & transform relevant data: 

~ For each trial, input the numerical values of the raw (Unfiltered) data file in to MS Excel sheet. ~ Remove the data containing the transition corresponding to the weight removal, indicated by a change in the X-values. The stable data with weight (level1) and without the weight (level2) will be retained. ~ For example, in the below chart, the moment that the weight is being removed is visible by a sudden change (transition). The transition period displayed here is very small. Hence all the data before this transition starts is one level and after the transition ends is a second level. 

~Calculate the average of the high and low levels (or vice versa) of X as AvgX1 and AvgX2. Also, calculate the standard deviation, SDX1 and SDX2. The difference in the average levels between before and after removing the weight |AvgX1-AvgX2| is an estimate of the measured force. 
~In the chart above, the trial starts at 0 N level with the weight, and after the removal of the weight goes to -1.86 N level. Hence the force change is 1.86 N. 

Results from our tests: 
The sensitivity of the sensors from the manufacturer is approx. 2.5 mV/V at a full load of 25 N. And the amplification factor from circuitry is 504. Hence in the experiment settings, we use a calibration constant of 2.5*504 = 1260. 
For two trials performed for each of the weights applied on lower grip sensor, the follows values were derived from analysis:
Table 1. Lower grip force measurements

Conclusions:
The measured force levels are up to 5% lower than the actual force levels. That the relative departures are fairly constant implies that the sensors are fairly linear. 
To obtain accurate results, the lower grip (x) calibration constant can be fine tuned by increasing it by 5%, ie, setting it to 1266.3. After changing the settings, an accuracy better than 0.5% is observed for the above measurements. 

1.1.2. Top Grip-force Sensor
Purpose: To test whether the GripAlyzer system is measuring the correct force as applied on the upper grip sensor. 
Procedure: The procedure used is the same as that used to test the bottom sensor

Weight applied (g)
Actual Force(N 
) = weight applied in N

Trial 1 Trial 2 
Measured Force = |AvgX1 -AvgX2|

% Error = (Actual -measured)/ 
actual x 100% 

Measured Force = |AvgX1 -AvgX2|
% Error = Actual -measured/ 
actual x 100% 

50 0.4903 0.4707 -4.0 0.4674 -4.9 
100 0.9807 0.9462 -3.5 0.9424 -4.0 
200 1.9614 1.9030 -2.9 1.8624 -5.0 
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Analysis: Same as lower grip sensor, except that the Y-axis data (upper grip) are taken in to consideration, instead of x-axis data, to obtain, AvgY1, AvgY2, SDY1 and SDY2.
Results from our tests:
For two trials performed for each of the weights applied on upper grip sensor, the follows values were derived from analysis.
Table 2. Upper grip force measurements. 

Conclusions:
The measured force levels are approximately 1% lower than the actual force levels. The upper grip (y) calibration constant could be left as the same 2.5, since is the error is negligible. 

1.1.3. Load Sensor
Purpose: To test whether the GripAlyzer system is measuring the correct force as applied on the load sensor.
Procedure: A similar procedure was used as for the lower grip sensor

Analysis: Same as lower grip sensor, except that the Z-axis data are taken in to consideration, instead of x-axis, to obtain, AvgZ1, AvgZ2, SDZ1 and SDZ2.
Results from our tests: 
For two trials performed for each of the weights applied on load sensor, the follows values were derived from analysis.
Table 3. Load force measurements

Conclusions:
The measured force is approximately 11% lower than the actual force. To obtain more accurate results, the load sensor (z) calibration constant should be increased by 10% or so for the load sensor. ie., from 1260 to 1368.

1.2. Random Noise
Purpose: Estimating static equipment noise in comparison to the quantization noise. 
Procedure: 
Quantization Test: 
Place the upper and lower units flat on the table, with the upper and lower grip force sensor plates facing upwards. 
Measure 3 trials with the units at rest. 
Analysis:

1. From quantization test in the section:
Right click trial > chart raw data > X and Y vs. sample number
Right click on the chart > plotting method
2. From tests in previous sections:
~ For each of the trials in lower grip (1.1.1), upper grip (1.1.2) and load sensor (1.1.3), the SD values, SDX1, SDX2, SDY1, SDY2, SDZ1, SDZ2, are considered. 
~The minimum of the two trials per channel per trial reading is calculated as SDX = min (SDX1, SDX2), SDY = min(SDY1, SDY2) and SDZ = min (SDZ1, SDZ2), displayed in table 4. The minimum value is used as the best estimate, because the measured device cannot be underestimated but easily overestimated. 

Results from our tests: 

Weight applied (g)
Actual Force(N) = weight applied in N

Trial 1 Trial 2 
Measured Force = AvgY1 - AvgY2 % Error = (Actual - measured)/ 

actual x 100% 
Measured Force = AvgY1 - AvgY2 % Error = Actual - measured/ 

actual x 100% 
50 0.4903 0.4875 -0.5% 0.4899 -0.1% 
100 0.9807 0.9865 +0.6 % 0.9680 -1.3 % 
200 1.9614 1.9383 -1.2 % 1.9362 -1.3% 

Weight applied (g) Actual Force(N) = weight applied in N
Trial 1 Trial 2 
Measured Force = AvgZ1 - AvgZ2 % Error = (Actual -measured)/ 

actual x 100% 

Measured Force = AvgZ1 -AvgZ2

% Error = Actual - measured/ 
actual x 100% 

50 0.4903 0.4367 -10.8 % 0.4386 -10.4 % 
100 0.9807 0.8578 -12.4 % 0.8711 -11.1 % 
200 1.9614 1.7367 -11.4 % 1.7387 -11.3 % 
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Table 4. Averages and static noise levels

Conclusions:
Quantization Noise: The DAC unit in NIDAQPad converts the analog signal into a 12 bit digital value (2^12 = 4096 values). The step size for the signal will be full scale voltage/(4096 - 1) Volts. For example, if the full scale voltage is 0-5 V, then the step size (1 LSB) is (5/4095) = 1.22 mV. Hence, for each 1.22 mV change in the signal, a bit difference in the digital value is encountered. This implies that ANY signal that has an amplitude less than 1 LSB may not be detected. The corresponding Newton value for this noise is 0.0126N with 25N full scale and 5 V excitation. 
Quantization noise (RMS) = 0.0126/sqrt(12) = 0.0036 N
Note from table 4.,Noise/Channel calculated from the data, is much higher than the quantization noise. Therefore, the quantization noise has negligible effect on the noise estimate. 
Interestingly, the static noise level does not depend on the load force. The static noise consists of random noise plus a quantization noise. (SD^2 Noise = SD^2 Random Noise + SD^2 Quantization noise). 

1.3. Frequency Spectrum
Purpose: To detect the presence of specific interference frequencies.
Procedure:
For each sensor (lower unit, upper unit and load), collect two trials as follows:

~ Place the units on the table horizontally (for upper and lower unit trials) and vertically (for load sensor trials). 
~ In the first trial, the data is collected with the sensor unit at the rest, without any weight placed.
~ In the second trial, place a known weight after 2-3 s from start of recording. 

Analysis:
~ View the trial > view processed data > Velocity Vs Frequency Spectrum plot. 

Conclusions: 
In the first trial (at rest) for each sensor, as in the chart below, the frequency spectrum ranges from 0 Hz to half of sampling frequency (256 Hz), ie, 128 Hz. The unfiltered frequency shows frequency harmonics at around 50 Hz, 100 Hz  ...etc. with the amplitude increasing with every 50 Hz frequency. The filtered plot displays the data filtered with a filter frequency of 12 Hz. 

In the second trial, there was no weight initially and then a weight of 50 g was placed gradually. Here also, the unfiltered frequency shows frequency harmonics at around 50 Hz, 100 Hz  ...etc. with the amplitude increasing with every 50 Hz frequency. 

Lower Grip Weights placed Force corresponding to weights placed (N)
SDX1 (trial1) SDX2 (trial2) Noise in lower grip channel per weight = SDX

Noise (N) /channel = Avg of noise for different weights
50 g 0.4903 0.0256 0.0255 0.0255 0.02453
100 g 0.9807 0.0259 0.0237 0.0237
200 g 1.9614 0.0339 0.0244 0.0244

Upper Grip Weights placed Force in N for weights placed SDY1 (trial1) SDY1 (trial2) Noise in lower grip channel per weight = SDY
Noise (N) /channel = Avg of noise for different weights

50 g 0.4903 0.0229 0.0254 0.0229 0.0227
100 g 0.9807 0.0389 0.0220 0.0220
200 g 1.9614 0.0245 0.0232 0.0232

Load Weights placed Force in N for weights placed SDZ 1 (trial1) SDZ 1 (trial2) Noise in lower grip channel per weight = SDZ
Noise (N) /channel = Avg of noise for different weights

50 g 0.4903 0.0180 0.0217 0.0180 0.0188
100 g 0.9807 0.0193 0.0199 0.0193 
200 g 1.9614 0.0192 0.0241 0.0192
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Addendum:
When the trials where the units are at rest, are processed to obtain the raw data spectrum instead, the spectrum shows a triangular increase of noise with frequency suggesting the presence of white noise. 

1.4 Force sensor plates: Central and off-central pressure
Purpose: To verify if there is a difference in forces measured by upper and lower grip sensors, depending on where the pressure is applied on the force-sensor plate (3.8 cm dia.). 
Procedure:
Verify that the system is measuring with reference to a basline at or close to 0. (Refer section I.)
For each of upper and lower grip units,
Collect two trials as follows: place a known weight on the center of the sensor plate.
Collect two trials as follows: place a known weight on the edge of the sensor plate.
Analysis:

~ For each trial > chart processed data > X Vs. time plot for lower sensor and Y vs. time for the upper sensor. 
~Note the force value measured in the above charts for each trial.

Results: 

1.5 Temperature Effects on the sensor senstivity
Refer http://entran.com/elpm.htm for the sensor specifications
The manufacturer specified "Thermal Sensitivity Shift" is 0.01 FS/C, where FS is the full scale voltage. 
The effects of temperature on the measurements can be roughly estimated by using the above value. 
Example: If the sensors are normally placed in an temperature controlled room at 18C (65 F), and when the sensor comes in contact with hands for sometime at 37C (98.4 F), the increase in temperature is 19C. 
Change in FS = 0.01 * 19 = 0.19
For a FS of 25 N, Change in N = 0.19 *25 = 0.475 N.

II. Dynamic Measurements
2.1. Relative linearity
Purpose: To verify the sensor data vary proportionally with a variable force applied. The goal is to apply equal forces on all of the sensors and show that the values vary proportionally (as sensitivity is approximately the same for all the sensors).
Procedure:
1. Relative linearity between lower and upper grip unit sensors
Collect two trials as follows:

~Place both the gripper units on a table, facing each other. 
~Move the units, such that the sensor plates of the two units touch each other.

Position of the weight (100g = 0.9807 N) Average Force measured (N) 
Lower Sensor Upper Sensor

Center 0.899 0.94
Edge 0.897 0.933
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~ Press the units together with one hand repeatedly 10 times. That is, apply equal forces on the bottom and top sensors.
2. Relative linearity between upper grip unit and load sensors
Collect two trials as follows:

~Place the bottom unit upright on the table and place the upper unit on the lower one, such that the sensor plate and the magnet surface touch each other. 
~Press the upper unit over the lower unit downwards with one hand repeatedly 10 times. That is, apply equal and opposite forces on the upper grip sensor and the magnet. 

3. Relative linearity between lower grip unit and load sensors
Derive from 1. and 2. 

Analysis: 
For each of the two combination of sensors, observe the processed data chart for each trial. 
Conclusions: 
1. For Relative linearity between lower and upper grip unit sensors,

~The X vs Y chart of the trial data, implies a proportional change for the force applied between the lower and upper grip sensors. 

2. For Relative linearity between upper and load grip unit sensors, 
~The Y vs Z chart of the trial data implies a proportional change for the force applied. The curve also shows hysteresis loops, which indicate that there is a small lag between the two forces. The width of the hysteris loop can be obtained difference in y coordinates from the chart by considering the center of the outermost elliptical loop. The average peak width of the hysteresis loop is around 1 N. 

3. For Relative linearity between lower and load grip unit sensors,
~ From 1. and 2., we can see that there is no lag between X and Y and they are proportional, but there is some lag between Y and Z. Hence, we can say that there will a lag between X and Z also. 
This also shows that the forces from the magnetic load sensor, when compressed may be obstructed by the cables between the sensor. In general, this effect may be as much as +/- 2 N, depending on increasing and decreasing tension. 

2.2. Calibration of sampling rate and time
Purpose: To evaluate any differences in time between the instant at which change is enforced on any of the sensors and the corresponding change in the measured data. This could imply the sampling rate time and sensor response time. 
Procedure: 
For each sensor (lower unit, upper unit and load), collect two trials as follows: 
~Place a known weight after 5 sec accurately from start of recording. The 5 s was measured using a stop watch. 
Analysis: 

~ View processed data: For each trial, observe, X (Lower grip) Vs. time, Y (upper grip) Vs. time and Z (Load) Vs. Time. 
~ The transition time is very small and mostly ends with a small peak. To maintain consistency, the time instant corresponding to the peak is considered as the point of transition for each trial. 

Results from our tests:
Table 8.

Conclusions: 
It can be observed that there may be up to 10% deviation in the sensor data change time from the actual instant at which the change was forced. This could be due to the sensor response time, interface units delay, and/or sampling time.

Trial 1 Trial 2
Time Error % (Deviation from 5 s) Time Error % (Deviation from 5 s)

Lower Grip 4.74 (5-4.63)/5 * 100 %  = 5.2 % 4.869 2.6 % 
Upper Grip 4.5 10% 4.468 10.64% 
Load 4.67 6.6% 4.68 6.6% 
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It can be observed in the chart above that the change from high to low of the plot occurred very close to the 5 s, (up to 10% error) from the actual time.

2.3. Sudden force changes
Purpose: To verify the sensor's ability to detect sudden force changes.
Procedure: 
For each sensor (lower unit, upper unit and load), collect two trials as follows: 

~ A trial starts with the system at rest. 
~ Take two known weights. In our tests, weights of 100 g and 200g were used. 
~ After a trial has started, within a few seconds, drop the first weight on the horizontal surface of the sensor plate from a distance of about 0.5 -1 cm. 
~ During the trial-trial pause (before pressing enter to start next trial), remove the weight from the sensor plate.
~ Perform the second trial with the other weight. 

Analysis: For each trial,
~Open raw data file, by trial > view raw data 
~ Determine the sample number (row number in raw data file) at which the transition from low to high or high to low starts. 
~Determine the sample number at which the transition ends.
~The response time is the difference between these sample numbers. 

Results from our tests:
Table 9.

Conclusions: 
The sensor force should ideally show a step function. The resulting curve shows an oscillation during the impact and then comes to the rest value, as show below.

The time at which the sensor was at rest to the time it takes to switch to a higher value is measured as the response time of the sensor. 
In average, the response time including the oscillations was 5-10 samples. This can be visually assessed by viewing the raw data chart for the corresponding sensor after zooming in on the transition area. 

Sensor Trial Sample # at the end low/high values
Sample # at the start of high/low values

# Samples for transition = response time
Bandwidth (Hz) = Sampling rate/2*(#samples)

Lower #1 (200g weight) 163 169 6 21.33 
#2 (100g) 168 177 9 14.22

Upper #1 (200g) 130 137 7 18.28
#2 (100g) 263 270 7 18.28

Load #1 (200g) 273 278 5 25.6
#2 (100g) 293 299 6 21.33
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2.4. Inertial forces
2.4.1. Inertial forces due to the sensor
Purpose: Estimate what load the sensor (lower grip & upper grip sensor) measures due to the sensor's mass or cover.
Procedure:
For each of the following conditions, collect trials as: Place the lower grip unit on the table with the load sensor facing upwards. Lift the lower unit before a trial starts (in the trial-trial interval or press enter key delay). After trial starts, shake it with high acceleration and frequency.

Repeat the procedure using the upper grip unit. 
Do not touch the grip-force sensor.
Analysis: Per condition, measure the lower grip-force sensor oscillation amplitude (peak to peak), from processed data chart, X-time graph (average of the 3 trials). Similarly, observe Y-time graph for upper grip sensor. 
Results: 
Old force plates (weight not available, the steps 2. and 4. done in vertical direction instead of sidewards)

Old force plates (weight = 10 g)

Conclusions: 
For the lower grip sensor, it can be observed that having the transducer cover has a small effect on the sensor readings. Also, shaking in different directions the horizontal plane in different directions have similar effects. However, there is a slight difference in the readings between upper and lower sensors, which could be due to additional cables for the lower unit. 

2.4.2. Inertial forces due to the magnet
Purpose: Estimate what load the sensor measures due to the mass of the magnet.
Test (A): Procedure
For each of the following conditions, collect trials as: Place the lower grip unit on the table with the magnet facing upwards. Before the trial starts, lift the lower unit. After the trial starts, shake it with high acceleration and frequency.

Task 1. Collect 3 trials shaking in horizontal plane with the transducer cover facing towards the side. Donot touch the sensor plate with fingers

2. Collect 3 trials shaking in horizontal direction with the transducer cover facing towards you. 

3. Collect 3 trials shaking in horizontal plane without the transducer cover (1 N magnet force)

4. Collect 3 trials shaking in horizontal direction without the transducer cover (1 N magnet force) 

Task
1 (shaking in horizontal plane with the transducer cover)
2 (shaking in vertical direction with the transducer cover)
3 (shaking in horizontal plane without the transducer cover)
4 (shaking in vertical direction without the transducer cover)

Task Amplitude of the largest variation (N)
Lower Grip sensor Upper Grip sensor

1 0.7 0.57
2 0.63 0.55
3 0.68 0.47
4 0.6 0.46
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1. Collect 3 trials shaking in horizontal plane (1 N magnet force)2. Collect 3 trials shaking in vertical direction (1 N magnet force) 3. Collect 3 trials with pulling the BOTTOM unit RAPIDLY and suddenly with the two hands holding each of upper and lower units, laying the two units put together flat on the table (1 N magnet force) 
Note: Do not attempt to remove the magnet. Do not touch the load-force sensor.
Test (B): Procedure
Repeat 1. and 2., but while shaking, the thumb is placed on the lower grip sensor. This is done in addition to test (A) as when a subject is performing a pulling task, the thumb would be pressing the lower sensor and hence, is closer to the experimental scenario.
Analysis: For each trial, measure the load-force sensor oscillation amplitude (peak to peak), from processed data chart, Z-time graph. In the last 3 trials, the force includes: Residual magnetic force + suction force + inertial force.
Results: 

Conclusions: 
In both tests (A) and (B), shaking in the vertical direction has more of an effect on the load sensor readings. This is due to the weight of the magnet mounted on the load sensor. Also, in test (B), placing the thumb on the sensor while shaking the unit in vertical direction produces an oscillation in the lower grip data (X amplitude), although pressure is not applied intentionally. 

2.5.Timing of the peak of the load force relative to the magnetic polarity change
This test is for your review only, as this was not conducted using GripAlyzer, but an internal program, GripView. 
Purpose: To show that the magnetic polarity change (Channel 4) during the disengagement of the upper and lower grip occurs almost simultaneously to the load force reaching a peak (Channel 3) and hence the measurement on Channel 4 can be bypassed. 
Procedure:
Grip force data with time, X, Y, Z and magnetic polarity were obtained in 3 conditions for 3 trials per condition.

~ In Condition 1, trials were performed by pulling apart the upper and lower units in the sideward direction, with a fixed magnetic strength (e.g., 8 N). 
~In Condition 2, the pull was on the forward direction. 
~In condition 3 the pull was in the vertical direction. 

Analysis: For each trial, 
~ Raw data values were taken into consideration. 
~ From magnetic polarity values, the point of transition of the polarity from high to low or from low to high was determined. 
~ From the Z values, the point of transition to the peak value of the load was noted. It was found that the two transitions were one or two samples apart. (table 7)

Results from our tests:
Table 6. Data to indicate the transition of peak z-value and repolarization of the magnet.

We found no difference between between the conditions. See Table 7.
Table 7. Timing of the repolarization of the magnet.

Conclusions: 
The time corresponding to the magnetic polarity change (Point of disengagement) can be found from the peak Z value taken from the Z-value Vs time plot, while tolerating an average of 1.5 samples. 
In the trial below, the magnetic polarity switches AFTER sample 203, while the load value reaches its peak AROUND sample 205, although it seems unlikely that at sample 205, the load force is on its way to decrease. It seems safer to say that the load force will have its sudden decrease AFTER its peak. Therefore, there seems to be a delay of 2 samples between the moment of repolarization of the magnet (to facilitate disengaging) and the maximum grip force. 

Condition
Test (A) Test(B)
Z amplitude (load sensor) N Z amplitude (load sensor) N X amplitude (Lower Grip sensor) N

1 (shaking in horizontal plane) 0.19 0.2 uneven variations
2 (shaking in vertical direction) 1.24 1.1 1.51
3 (pulling the BOTTOM unit RAPIDLY) 0.95 This is not done for task 3. 

Sample # Upper Grip- Y value Load - Z value Lower Grip- X Value Magnet Polarity (+/-) # Samples difference
203 41.6637 9.0071 42.4489 5.0635

2

204 41.5635 9.3417 42.6409 0.0977(repolarization)
205 41.7138 9.5329 (max) 42.8329 0.0977
206 42.2651 7.8121 42.7369 0.0977

Condition # samples difference between the max load force sample and the last sample nr before magnet repolarizes (For trials 1-12)Average difference
Sideward 2 2 2 2 2 1 1 1 2 1 1 1 1.5
Forward  2 1 1 1 1 2 2 2 2 2 1 2 1.58
Upward 1 1 2 2 2 1 1 1 2 2 1 1 1.416
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Addendum:
When the above test was repeated for 16 N force value, the lag of the Z value load force measurement with respect to repolarization was much larger (as many as 14 samples)

II. Magnet 
1. Magnet strength
Purpose: To verify magnet force as specified in the GripAlyzeR condition properties. That is, set a specific magnet force and verify that the magnet disengages at the critical force. 
Procedure:

~ Measure the weight of the lower grip unit on a scale (300 g ~3 N). 
~ Attach a 200g weight (2 N extra) to the lower grip unit by using a scotch tape or band. 
~ In the grip-force experiment in GripAlyzeR, Condition that will be used to collect trials > Condition properties > gripper > set the force to approximately equal to the force required to lift the lower gripper plus the added weight (5 N). 

Collect the trial: Method I 
~ Place the bottom unit on the table with the magnet face upwards with the top unit placed on it. 
~ After a trial starts, lift the top unit in to the air carefully against the force. (keep the lower unit very close the surface of the table)
~If the applied force (5 N) is accurate, it should be able to hold the bottom unit (with effective weight of 5 N). 
~ Reduce the weight attached by 50 g (now attached weight is 150 g ~ 4.5 N) and repeat the trial. As you go further in to trials reduce the weight by smaller units (see results table 1)
~Keep reducing the weight and repeating the trial until the lower unit is held by the upper unit. 
~Note down the extra weight attached each time and tabulate as in table 1. 
~Repeat the above steps for 1 more repetition. 

The above test can be repeated by going from lower to higher units of weight (see results table 2). 
Results: 

Weight of the lower unit = 300 g ~ 3 N
Weight of the upper unit = 200 g ~ 2 N 
Table 1: 

Table 2: 

Force applied by magnet (condition setting) Weight Attached (in g and N)
Effective weight of the lower unit = 3 N + attached weight in N

Effective pull force on the magnet = effective weight of lower unit - weight of the upper unit (push force)

Lower unit attached or detached?
Repetition 1 Repetition 2

5 N 200g ~ 2 N 5 N 7 N Detached Detached
5 N 150g ~ 1.5 N 4.5 N 6.5 N Detached Detached
5 N 100g ~ 1 N 4 N 6 N Detached Detached
5 N 50g ~ 0.5 N 3.5 N 5.5 N Detached Detached
5 N 40g ~ 0.4 N 3.4 N 5.4 N Detached Detached
5 N 30g ~ 0.3 N 3.3 N 5.3 N Attached Attached
5 N 20g ~ 0.2 N 3.2 N 5.2 N Attached Attached

Force applied by magnet (condition setting) Weight Attached (in g and N) Effective weight of the lower unit = 3 N + attached weight in N
Effective pull force on the magnet = effective weight of lower unit - weight of the upper unit (push force)

Lower unit attached or detached?
Repetition 1 Repetition 2

5 N 20g ~ 0.2 N 3.2 N 5.2 N Attached Attached
5 N 30g ~ 0.5 N 3.3 N 5.3 N Attached Attached
5 N 40g ~ 0.4 N 3.4 N 5.4 N Attached Attached
5 N 50g ~ 0.5 N 3.5 N 5.5 N Attached Attached
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Analysis and Conclusions:
From table 1, it can be noticed that units remain detached at a pull force of 5.4 N on the magnet, and attached at 5.3 N. If the magnetic force was exact, this value should be very close to the applied force of 5 N. Hence we can see an error of 0.3 to 0.4 N. 
From table 2, also similar transition is observed between 5.5 N and 6 N, and hence a difference of up to 0.5 N (10% of 5 N)
This difference could be accounted to some extent to the human hand holding the upper unit and the forces on the wires. Nevertheless 
we can conclude that the magnet strength is more than 90% accurate. 

Addendum: 
For the trial where the lower unit starts to be detached, (from our results table 2, it can be noted that this is when 100 g is attached),
Right click the trial > chart processed data > Z value vs. time chart (load sensor)
From the chart, we notice that the effective pull force on the load sensor at the time of detachment while lifting was about 4.5 N (peak value of Z in the chart). This is about 0.5 N off the applied force of 5 N, which is accounted by the weight of the magnet on the load sensor (see section I. > test 2., where this difference is shown to be about 0.5 N)
Note: You can repeat this test for the trial with 100 g, if you have not saved or overwritten the trial. 

2. Residual Magnetism
Purpose: Measure the load force due to residual magnetism. 
Procedure:

~ Create two conditions for zero Newton and non-zero Newton, say 00N and N0N. 
~ Assign the condition 00N with value 0.1 N and N0N with 2 N force (Condition properties > gripper > force in N). Assign number of trials per condition as 1. Add conditions N0N and 00N to the experiment used to collect trials in the same order. 
~ The conditions have to be executed in the same order as listed under the experiments, as defined by, Experiment > Experiment settings > Recording > Uncheck the option 'randomize condition and trial order'.
~The trials have to be paused after the first trial, during which the magnet has to be manually switched off. Do this by: Experiment > Experiment Settings > Recording > 'Delay trial until enter key is pressed' 
~ Start recording and perform each trial as follows: Lay units flat. Pull TOP unit SLOWLY without shock. Make sure the bottom unit does not move whatsoever. When the message prompt to start next trial appears, unplug the power supply to the magnet, click ok and perform the trial similar to last one. 
~ For each trial, View processed data: Z axis-time; Note down the amplitude difference of the peak to the next segmentation point. 
~ Repeat the above steps for 3 trials.
~ Repeat the above steps by setting the force of condition N0N to 4N, 8N,..etc. 

Analysis:
~Note the force at the point of disengagement (based on the Z-data) from the processed data chart after the magnet was turned off for each trial. 

Results: 

Conclusions:
Ideally, residual magnetism should be close to zero once the magnet is turned off. The data indicate that residual magnetism increases with increasing the force when the magnet is turned off. Increasing the time of the trial-to-trial interval may reduce residual magnetism, although that has not yet been tested. 

3. Vacuum Suction
Purpose: Estimate the magnitude of the load force that could be cause by vacuum suction when the units are pulled apart.
Procedure:
~ Use the same experiment and conditions, 00N and N0N from the Residual Magnetism test. 
~ Assign the N0N with 8 N force 
~ Start recording and perform each trial as follows: Lay units flat. Pull TOP unit off QUICKLY and suddenly. When the message prompt to start next trial appears, unplug the power supply to the magnet, click ok and perform the trial similar to last one. 
~ For each trial, View processed data: Z axis-time; Note down the amplitude difference of the peak to the next segmentation point. 
~ Repeat the above steps for 3 iterations.
Analysis:

~Note the force at the point of disengagement (based on the Z-data) after the magnet was turned off for each trial. 
Results:

5 N 100g ~ 1 N 4 N 6 N Detached Detached
5 N 150g ~ 1.5 N 4.5 N 6.5 N Detached Detached
5 N 200g ~ 2 N 5 N 7 N Detached Detached

Z Peak Amplitude (point of disengagement)
20 N 0 N 10 N 0 N 2 N 0 N

Repetition 1 14.56 0.429 6.95 0.32 1.05 0.29
Repetition 2 13.87 0.418 6.34 0.128 1.037 0.178
Repetition 3 13.77 0.69 6.64 0.38 1.102 0.38
Average Residual Magnetism For 20 N: 0.513 N For 10 N: 0.276 N For 2 N: 0.282 N

Z Peak Amplitude (point of disengagement)
8 N (low) 0 N (zero) - Average Z value

Iteration 1 3.09 -0.5
Iteration 2 3.55 -1.25
Iteration 3 3.87 -1.25
Average suction-induce load-force amplitude For 8 N: -0.75 N
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Conclusions:
Ideally, the vacuum suction should be close to zero once the magnet is turned off. The data indicate that a small negative load force exists due to the vacuum suction of pulling the units apart. The suction should remain fairly constant between trials however, if the speed of pulling the units apart remains constant. Thus, the impact of a vacuum suction is negligible. 

4. Friction
Purpose: Estimate the magnitude of the load force that could be cause by friction of the magnet touching the walls of the magnet cylinder.
Procedure: 
~ Use the same experiment and conditions, 00N and N0N from the Residual Magnetism and Vacuum Suction tests. 
~ Assign the N0N with 8 N force. 
~ Start recording and perform each trial as follows: Lay units flat. Lay units flat. Pull TOP unit SLOW and suddenly, but SLANTED so that the magnet rubs inside the hole. When the message prompt to start next trial appears, unplug the power supply to the magnet, click ok and perform the trial similar to last one. 
~ For each trial, View processed data: Z axis-time; Note down the amplitude difference of the peak to the next segmentation point. 
~ Repeat the above steps for 3 iterations
Analysis:

~Note the force at the point of disengagement (based on the Z-data) after the magnet was turned off for each trial. 
Results:

Conclusions:
The results demonstrate that friction induced by rubbing the magnet against the unit increases the magnitude of load force. Therefore, participants should be instructed to use a parallel motion of pulling the units apart, without slant.

© NeuroScript LLC. All Rights Reserved.

Z Peak Amplitude (point of disengagement)
8 N (low) 0 N (zero) - Average Z value

Iteration 1 4.8 0.87
Iteration 2 5.33 1.167
Iteration 3 5.23 0.53
Average friction-induceed load-force amplitude For 8 N: 0.85 N
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MovAlyzeR/ScriptAlyzeR Overview

Click on Settings details to go to the respective page. 
Steps: Setting up, Conducting and Analyzing Experiments 
The following procedure outlines the basic steps required to conduct an experiment, designed to help a beginner user. 
These steps are the same for MovAlyzeR and ScriptAlyzeR. The deviation would be that ScriptAlyzeR does not involve creating stimuli or submovement analysis. Please review individual sections to explore more advanced options.

MovAlyzer
NeuroScript MovAlyzeR Help Send comments on this topic.
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Initially see installing the MovAlyzeR and device driver for the device you are using. Start the MovAlyzeR application by Start Menu > Programs > Neuroscript > MovAlyzeR OR click the MovAlyzeR icon on the desktop.
1. Create a new user or select from a list existing users. An example user 'UU1' has been provided with the download for reference. 
2. Select and test the input device if required. 
3. Create a new experiment or import an experiment from a different user. The user can also import data from other sources or generate data.
4. Add groups, subjects and conditions. You can view the relationships between them.
5. Set up a questionnaire for a group after making a master questionnaire list. 
6. Review the recording settings and input device settings under experiment settings before you start the recording. Other options in experiment settings can also be set after recording. 
7. Set the number of trials per experiment by right-clicking on a condition. 
8. Run a subject by following the steps given in testing a subject.
9. Inspect/process the trials.

o The valid trials are displayed with a green checkmark and the invalid ones with a red checkmark. (In the case of word extraction with sub-conditions, subject > reprocess trials has to be done to view all trials). If a trial is not processed, it is displayed with a gray checkmark.
o To view the reason for which the trial was discarded, right click on the trial > View numerical data > View err data.
o If the error is just because of the properties in the experiment settings (even if the subject did it correctly), change the experiment settings and right click the experiment or subject > reprocess trials. 
o The user can also perform a reprocessing of a single trial (in case you wanted to see the changes before applying it to all the trials), by trial > reprocess trial > append results (to perform consistency checking).
o The user can redo an invalid trial by Right-clicking "Redo Trial" on the particular trial. However, there are also "missing trial substitution" methods during the Summarization, useful to compare learning cycles.
o The order of trials is chronological during the experiment. The sequence can be set to alphabetical in the user setting.

10. View the trial data - ScriptAlyzer / MovAlyzeR.
11.View the charts for the trials - ScriptAlyzer / MovAlyzeR.
12. Perform Statistical Analysis.

o Summarize the experiment after excluding the subjects that are not in the experiment or that you don't want to include.
o After Summarization, right click on the experiment to view the summarized feature extraction data or the data for all the error trials.
o To obtain the analysis charts right click on the Experiment name > Analysis > Analysis charts.

13. To Export this experiment to another user or to be emailed to a different MovAlyzeR user (include the .exp file for the experiment and .zip for the trials).
14. Before you close the application, it is recommended that you backup your data.
15. Report any problems to Neuroscript or refer to Troubleshooting for commonly encountered problems and the solutions.

Typical Events (Linked to the corresponding source help page)
Setting up an experimento Create a new experimento Add/create groups to experimento Add/Create conditions to experimento Create stimulio Add Stimuli to Conditionso Test/Chart Stimuli o Add/Create test subject SSSo Setup questionnaire
Before testing a subject (participant)
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o Select Input deviceo Test input deviceo Verify experiment settings related to recording, ie, all the options under 'Running experiment' and 'Recording' pageso Verify condition settings per conditiono Select the number of trials per condition
Start testing a subject
o Run experiment
Before recording a trial
o Fill out Questionnaire (by participant)o Display stimuli as set in condition properties

* Views stimuli instructions* Stimulus Instruction* Sound: Start of warning stimulus* Warning stimulus (for specified duration)* Sound: End of warning stimulus* Latency * Sound: Start of precue stimulus* Precue stimulus (for specified duration)* Sound: End of precue stimulus* Latency
During recording a trial
o Stimuli used as specified in condition properties

* Sound: Start of recording* Imperative stimulus shown* Delay recording until pen touches tablet* Sound: Pen is placed down on the tablet
o Instruction constantly displayed on the screen (Experiment settings) o Recording: Realtime visual feedbacko Sound: Pen is lifted (condition properties)o Waiting for recording timeout, pen lift timeout, whichever comes first (Experiment settings) o Recording with pen /mouse (by participant)
After recording a trialo Sound: End of recordingo Delay: Until keyboard Enter to start next trial (Experiment settings)o Delay: Until accept/reject trial to start next trial (Experiment settings)o Processing trial (as per the specifications set in Experiment settings)

+ Word segmentation+ Lowpass Filtering, Time Differentiation, Frequency Spectra+ Stroke and Submovement segmentation+ Feature Extraction+ Consistency Error checking per trial 
o Chart trial, Wait for keyboard or mouse (Experiment settings) 
After recording all trials
o Chart individual trialso View trial datao Summarize current subject including Consistency Error rechecking per conditiono Chart analysis graph
Data analysiso Summarize selected subjects including Consistency Error rechecking per conditiono Chart analysis grapho Export graphs and data for statistical analysis

© NeuroScript LLC. All Rights Reserved.
NeuroScript MovAlyzeR Help Send comments on this topic.
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GripAlyzeR Overview

Basic Steps: Setting up, Conducting and Analyzing Experiments
The following procedure outlines the basic steps required to conduct an experiment, designed for the beginner user. Please review through individual links to explore more advanced options.
First install the GripAlyzeR and the DAQPad. Start the GripAlyzeR application by Start Menu > programs > Neuroscript> GripAlyzeR OR click the GripAlyzeR icon on the desktop.
1. Create a new user or select from a list existing users. An example users 'UU1' has been provided with the download for reference. 
2. Select the gripper device and test if required. 
3. Create a new experiment or import an experiment from a different user. The user can also import data or generate data for a new experiment or an existing experiment.
4. Add groups, subjects and conditions. You can view the relationships between them.
5. Set up a questionnaire for a group after producing a master questionnaire list. 

GripAlyzeR
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6. Review the experiment settings as needed. 
7. Set the number of trials per experiment by right-clicking on a condition. 
8. Run a subject by following the steps given in testing a subject.
9. Inspect/process the trials.

o The valid trials are displayed with a green checkmark next to them, while invalid trials have red checkmarks. (In the case of word extraction with sub-conditions, subject > reprocess trials has to be done to view all trials). If a trial is not processed, a gray checkmark is displayed next to it.
o To view the reason for which the trial was discarded, right click on the trial > view numerical data > view err data
o If the error is simplt due to he properties in the experiment settings (even if the subject did it correctly), change the experiment settings and right click the experiment/subject > reprocess trials. 
o The user can also perform a reprocessing of a single trial (in case you want to see the changes before applying it to all the trials), by trial > reprocess trial > append results (to perform consistency checking).
o The user can let redo an invalid trial by Right-clicking on that trial "Redo Trial". However, there are also "missing trial substitution" method during the Summarization, useful to compare learning cycles.
o The order of trials is chronological during the experiment. The sequence can be set to alphabetical in the user setting.

10. View the trial data 
11. View the charts for the trials
12. Perform Statistical Analysis

o Summarize the experiment after excluding the subjects that you don't want to include.
o After Summarization, right click on the experiment to view the summarized feature extraction data or the data for all the error trials.
o To obtain the analysis charts, right click on the experiment name > analysis > analysis charts.

13. To Export this experiment to another user or for emailing to a different MovAlyZer user (include the .exp file for the experiment and .zip for the trials).
14. Before you close the application, it is recommended that you do a backup of your data.
15. Report any problems to Neuroscript or refer Troubleshooting GripAlyzeR for commonly encountered problems and the solutions.

© NeuroScript LLC. All Rights Reserved.
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Experiments
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
* You can create a new experiment by: 

(1) Experiment Setup Wizard: The wizard will setup a basic experiment (with one condition, one group, and one subject). Multiple conditions/groups/subjects may be manually added afterwards; 
(2) Manual Experiment Setup

* Deleting an Experiment
* Organization of Experiments/Terminology
* Notes

Experiment Setup Wizard
o Start the wizard by clicking File > Experiment Setup Wizard.

o Step 1: Click Create Experiment. >Type ID and Description > Click OK > Click Next.
o Step 2. Select Condition from a list (this shows all the conditions defined for the user). 

OR If no conditions are defined, click Create Condition > Type ID, User's Description, Subject's Instruction, MovAlyzeR's Stroke Description > Click OK (other data are described in Condition Properties).
o NOTE: Only one condition can be created or added with the Experiment Setup Wizard. Additional conditions may be added manually. 
o Type #Repetitions (Number of trials per condition) > Click Next.
o Step 3. Select Group from a list (this shows all the groups defined for the user) 

OR If no Group is defined, first click Create Group > Type ID and Description > Click OK > Click Next.
o NOTE: Only one group can be created or added with the Experiment Setup Wizard. Additional groups may be added manually. 

Experiments
NeuroScript MovAlyzeR Help Send comments on this topic.
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o Step 4. Select Subject from a list (this shows all the subjects defined for the user) 
OR If no subjects are defined, first click Create Subject > Type ID and First and Last Names > Click OK > Click Next.

o NOTE: Only one subject can be created or added with the Experiment Setup Wizard. Additional subjects may be added manually. 
o Click Finish. 
o If additional conditions are needed, Create Conditions and add to the experiment.
o Add new/existing groups or subjects as described in creating new groups and creating new subjects.
o Change the Experiment Settings if needed. 
o Run the experiment using the Run Experiment Wizard.

Manual Experiment Setup
o Right-click Experiments > Create new 

o Create your new experiment and set its properties.
o Notes: Use Control-M to insert a new line in the notes. You can add additional notes by right-clicking experiment > extended notes. 
o Select between Handwriting or Grip-force experiment.
o Create Conditions and add to the experiment.
o Add new/existing groups or subjects as described in creating new groups and creating new subjects.
o Change the Experiment Settings if needed. 

Deleting an Experiment
o First remove all groups, subjects and conditions individually from the experiment.
o Expand the experiment tree up to the last detail.
o Right click on the experiment condition/group/subject > Remove from experiment.
o Then right click on the experiment > delete.

Organization of Experiments/terminology
To start building a large database of recordings, create a new experiment/test as described at the beginning of this page. Once this is done one or more conditions and one or more groups of subjects/participants can be added from an existing master list or created on the spot. 
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o The data navigator (Left window experiment tree) and the experiment control window employ the following symbols (On the program's main tool bar- Click View > Symbol Legend or Click the Toggle Legend toolbar button). 

Each experiment has the following hierarchy:
 Experiments are stand-alone tests that are collected with the same device (Wacom UD series, mouse, imported data, Gripper data) requiring specific device settings.
 Groups may be different populations of participants (e.g., 8-year olds, Grade 5, Young Adults, Patients) or different sessions that a person participated (e.g., before drug intake, the first training session) or different locations where data is collected (e.g., hospital, home, Phoenix). 
Subjects are individual participants in an experiment (e.g., name and other characteristics are entered). The experiment date is generated automatically and is used to calculate the subject's age a the time of the experiment. An updateable questionnaire is produced for each subject. A subject may participate in multiple sessions, or experiments.

 Conditions may be different writing patterns (e.g., stroke to a 0.2-cm target at 45 degrees direction, write the word "elite") or may be the same writing pattern but executed under different instructions (e.g., as fast as possible, 2 cm large) or under a different exposure condition (e.g., distracting sounds) within the same experiment. Conditions may also differ by different stimuli or precues.
 Trials are multiple replications of the same condition. In learning tests, Trial may be a dimension of analysis by itself. A gray checkmark next to the trial indicates that the data have not yet been processed, a green checkmark indicates a good trial and a red checkmark indicates a bad trial (based on the specified criteria).

Strokes are the segments of movements that string together the movement patterns. Currently, strokes are segmented using the vertical velocity zero crossings. More segmentation options may be implemented. There can be 1-25 strokes.
Submovements are the separate subsegments of a stroke. Currently, a stroke is segmented into 2 submovements at the first negative-to-positive zero crossing, or minimia, of the velocity profile after peak velocity.
Samples are the coordinates delivered by the recording device, the importing device or the data simulator. Ideally the samples are taken at a known and constant rate that is specified.
Coordinates are the individual position values produced by the movement recording device: x (horizontal position), y (vertical position), z (axial pen pressure) coordinates. More coordinates may be implemented in the future. Coordinates may have (integer or floating-point values) and are space separated with 3 coordinates maximum per line.
EXAMPLE: Experiment Graphire 4, Group GP4, Subject INK, Conditions SSL, and Trials 1-5 are represented as follows. Additionally, Subjects with IDs GRP, GP2, GFB and KFB of that group are shown but have not been expanded.
Left window experiment tree
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Notes
Two lists for conditions, groups, subjects, stimuli, elements
o Master list of items ever created (Right click to create new items) 
o List of items added to a particular experiment (Right Click to add existing ones or to create new ones) 
Two experiment setup methods
o Open a particular experiment, choose to add new conditions/groups/subjects, and use the + button to instantly define new ones in the master list, etc. 
o Add new conditions/groups/subjects to their master lists and then, at a later time, open a particular experiment to add those. This facilitates consistent multi-experiment project. 
Two add conditions/groups/subjects methods
o Right-click Conditions/Groups/Subjects under a particular Experiment Add..., select items, and 
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click OK. 
o Drag a particular condition/group/subject from the master list to a particular experiment/experiment/group.

NSHelp: Experiment Settings | Experiment Properties | Run Experiment Trial Settings

© NeuroScript LLC. All Rights Reserved.

Relationships
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
A cross-referencing tool helps to find in which experiments a particular group, subject or condition was involved. Each master list of items can be searched by code. 
o Select a particular subject 

NSHelp: Condition right click

See Also 

See Also 

Relationships
NeuroScript MovAlyzeR Help Send comments on this topic.
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Questionnaire 
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Prior to the testing of each subject, a list of questions can be given to the subject. The list can be built from a master list of questions, which can be tailored per experiment and per group. Brief information per subject can also be stored in the properties when defining a new subject.
* Experiment Questionnaire
* Group Questionnaire
* Subject Questionnaire

Experiment Questionnaire
o Build a master list of headers and questions, each with their own code by Settings > Questionnaire Template. To create new questions they need to be added to a master list, then selected to be added to a particular experiment. This assures consistency of the entire database. 

o Click on the + button to add (and on the x button to delete). The question or header is inserted below the selected question. After insertion, the position of a selected question in the master list can be changed with the up and down arrows. 

o Enter a unique Question ID and question text or, if it is a header, a header text. The next and 

Questionnaire
NeuroScript MovAlyzeR Help Send comments on this topic.
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previous buttons let you move through the following and previous questions. 

Group Questionnaire
o Different questionnaires may be developed per group. 

o A selection list appears after Right-click a particular group questionnaire.

Subject Questionnaire
Before testing a subject a questionnaire can be completed when this option is checked in the start experiment dialogue. At any time, it is possible to view or update the questionnaire by Right-clicking on a particular subject. 
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o View the questionnaire by Right-clicking on a particular subject > Questionnaire 

o Fill out or update the questionnaire by pressing the + button. Next and Previous buttons let you conveniently move through all questions. 
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Experiment Settings
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.

The experiment settings designate specific parameters to run and process a particular experiment.
Before applying these settings to the trials in the experiment (through processing), the appropriate input device settings for the device used to collect the trials must be specified in the experiment 

Experiment Settings
NeuroScript MovAlyzeR Help Send comments on this topic.
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settings > input device settings. Thus, every time the input device or its features are changed, its settings should be updated.
Settings per experiment include:

NOTE: The Reset Defaults button in each settings window restores the initial values.
NOTE: Report settings shows the summary/report of all the experiment settings in a .txt file.

NSHelp: Experiment Properties | Experiment Input Device | Run Experiment Trial Settings | Processing Time functions| Processing Segmentation Settings | Processing Extraction Settings | Word Extraction | Processing Summarization| Experiment Draw Options Settings | Experiment Settings Report | Experiment/Group/Subject Process
Getting Started: Recording Devices

© NeuroScript LLC. All Rights Reserved.

Import/ Export Movement Data

Settings Sub-Topics
Applicable to

ScriptAlyzeRMovAlyzeR GripAlyzeR
General Properties

Input Device Settings

Running Experiment

Trials
Procedure
Drawing Options
Charting
Summ/Analysis
View Data

Processing 
Time FunctionsSegmentation
Extraction
Consistency
External Apps

SummarizationSettings
Norm DB Settings

Advanced

Discontinuity
Segmentation
Extraction
Word Extraction
Image Processing

See Also 

Import and Export
NeuroScript MovAlyzeR Help Send comments on this topic.
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This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
* Importing or Exporting an Experiment
* Importing Data
* Customized Data Import

Importing or Exporting an Experiment
Export
o Right-click a particular experiment > Export. 

~ Specify Export Location: Specify the directory to store the .exp file. When exporting experiment APK, the name of the file will be APK.exp. In addition, Support and Trial files can be generated.
NOTE: The .exp file is editable with Notepad as long as the number of lines is not altered.
~ Include experiment support files (instructions, notes, sorting, etc)? These are additional customization files. 
~ Include experiment trials? Trials will be compressed. Still this file can be large. 
~ Show subject identities? The subject identities are by default concealed. 
Import
An entire MovAlyzeR experiment can be imported after it has been exported by another MovAlyzeR user. To import an experiment you need to have a .exp file for the experiment. If you are importing the trials, you need a .zip file that includes all the trial data (i.e., .hwr and other files).
o Click File > Import > Import Experiment.
o Specify the directory of the .exp file. 
o Decide whether to include the trials as well. Currently the limitation is that the trial data need to be online available.
o Decide to delete the .exp file after the import.

Importing Other Data
Ascii data extracted from e.g., Oasis, Eyelink, Gripper, can be imported using the wizard or, if desirable, self-customized.
Data Import Wizard
Click File > Import > Data Import Wizard, and answer the questions.
o Step 1:
Select the input data format and click Next.
Data Formats Options
MovAlyzeR Entire directory
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NOTE: .csv are common comma-separated-value files. .dat and .asc files are space-separated-value files.
o Step 2: This step varies for the different data formats (a, b, c, or d). 
a. MovAlyzeR data import: Importing external MovAlyzeR data in to the current MovAlyzeR.

o MovAlyzeR data is imported trial by trial.
~ Datapath: Choose the file to be imported from your local drive for the trial you want to import.
~ View data: Clicking this displays the information in the chosen data file in ASCII format.
o To import the remaining trials: At the end of the first trial import, click next instead of finish to loop through the trials for a particular subject, as all the settings are retained until you click finish in the last step. 
b. Gripper data import: Importing external GripAlyzeR data in to the current GripAlyzeR.

Gripper .dat or .csv files. Allow selection of columns and sequence.
Oasis .asc or ,csv files.
Eyelink .asc or ,csv files.
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Trial by Trial:
~ Datapath: Choose the file to be imported from your local drive for the trial you want to import > next.
NOTE: To import additional trials at the same time: At the end of the first trial import, click next instead of finish to loop through the trials for a particular subject, as all the settings are retained until you click finish in the last step. 

Group of Trials:
o Gripper data files can also be imported in a group from a folder if the trial files are named ending in sequential numerical order. 
EXAMPLE You can import data files S1t01.csv, S1t02.csv.....etc stored in a folder. The first trial to be imported could have a file name ending in any number, say 100. But the following trials you want to import should have file names ending in 101, 102..etc.
~ Datapath: Choose the first file to be imported from your local drive for the group of trials to import. Example, file C:\.....\S1t03.csv.
~ Import multiple starting with above for __ additional trials: Check the option and Choose the number of the sequential files to be imported in addition to current file chosen. Example, 3 files in addition (S1t04, S1t05 and S1t06.csv).
~ Number of lines to skip: If there is additional text (header) in your data file before the columns of data appear, choose the number of lines this text occupies. Do not include column headers in the number of lines.
~ Are there column headers: If there are any column headers in a single line for the columns of data, choose this option. 
EXAMPLE

Trial Segment Condition Duration1 2 1 0.2345 1 3 1 0.4211 
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Here, "Trial Segment..." is the column header. 
~ View data: Clicking this displays the information in the chosen data file in ASCII format.
~ Columns: Choose the columns of data in the file that correspond to the x, y and z, (that is, lower grip, upper grip and load data) and also the order. Note: If you don't choose it using this button, clicking next will automatically ask for it. This choice is also retained for the following trials/group of trials by clicking next in the last step.
o At the last step, clicking 'next' or 'ok' would display the number of trials imported with a message such as "4 trials imported".

c. Oasis data import: Importing external Oasis data in to the current MovAlyzeR.
o Oasis data contains a group of trials in a single .asc or any extension file with columns of data. MovAlyzer uses the input from a single data file and automatically parses the data in to trials. 
~ Datapath: Choose the file to be imported from your local drive.
~ View data: Clicking this displays the information in the chosen data file in ASCII format.
o Step 3:
Select the experiment to write the data to. If not defined, setup an experiment using the Experiment Setup Wizard > Click Next.
o Step 4:
Select condition from the list. If not defined, click Create Condition > Type ID, Description, Instruction, Stroke Description, Min, Max #strokes > Click OK > Click Add > Click Next. 
NOTE: In case of importing MovAlyzeR data, check Retain Original Conditions if the files in the source directory satisfy eeegggsssCCCnn.hwr where CCC is the condition ID, otherwise all files in the directory will be considered as successive trials. 
o Step 5: 
Select Group from the list. If not defined, click Add Group > Type ID, Description > Click OK > Next.
o Step 6:
Select Subject from the list. If not defined, click Create Subject > Type ID and First and Last Names > Click OK > Click Next or Finish. 
NOTE: The procedure can loop through Steps 2-6 by clicking next in the last step. The previous setting is automatically remembered.
d. Other format data import: Importing other externally formated data (accelerometer, Eyelink) in to current MovAlyzeR.
Same as (a).

Customized Data Import
You can import data yourself by:
o Define the experiment using the Experiment Setup Wizard. 
o Create all data files as follows.
File Format
The data have to be stored according to particular rules, which assure the continued integrity of the database. 
o Store the x, y, and z (= pen pressure) coordinates on one line (separated by one or more spaces) in ASCII text files. 

- Successive coordinate trios are in successive lines separated by CR or CR LF. 
- The sampling rate in Hz should be constant. 
- The scales of x and y in cm per unit are equal. 
- Small or negative pen pressures signify movements above the paper. Larger pen 
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pressures signify that the pen is pressed on the paper. 
- Store one trial or condition per file. 

File and Directory Names
o The file names and directories should be of the form relative to a particular root directory and stored in specific subdirectories:   \root\eee\ggg\sss\eeegggsssccc01.hwr 
with: 

- 3-letter alphanumeric experiment code eee, 
- 3-letter alphanumeric group code ggg, 
- 3-letter alphanumeric subject code sss, 
- 3-letter alphanumeric condition code ccc, 
- 2-letter numeric trial code starting at 01 with increments of 1 (maximum is 99). 

o Create the data root directory \root if needed and the experiment, group, and subject directories: 
\root\eee \root\eee\ggg \root\eee\ggg\sss 
o If need, set the data root path by clicking File > Click Particular or Define New User > Properties > Settings > Root Data Path.

o To see the experiment, groups, and subjects added Refresh the database directory by View > Refresh. 
o To see the trials, right click a subject and select Refresh Trials or Right-click a particular experiment > Process > Reprocess Trials.

See Also 
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NSHelp: Export Summarized Data | Data Generation Wizard | Summarizing | Processing Summarization | Run Experiment Summ/Analysis

© NeuroScript LLC. All Rights Reserved.
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Experiment Conditions
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Introduction

Create/add a new condition
Remove a condition
Duplicating a condition
Generate multiple conditions

Trial Replications per condition
Condition Properties

Introduction
After creating a new experiment the particular experiment shows the Groups and Conditions headings, otherwise double click Experiments.
When creating new conditions or editing existing conditions, they will be added to a master list, and can be used for future experiments. This assures consistency of a user's database. For example, in the window below, the conditions CCC and DDD appear both under the experiment and in the Master 'conditions' list.

Condition Properties
Applicable to:
ScriptAlyzeR MovAlyzeR GripAlyzeR

General
Stimuli
Consistency Checking
Stroke Description
Word Extraction
Visual Feedback
Knowledge of Results
Sound
Gripper

Experiment Conditions
NeuroScript MovAlyzeR Help Send comments on this topic.
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Create/Add a condition to an Experiment
o Right click on the experiment >Add Condition(s).
o The 'Add conditions' window will appear as follows:

Add condition
Pick an existing condition in the list (e.g., 'LPP') by clicking on the ID and click 'add'.
Previously added conditions will not appear on the list, but are still in the master list.
Create new condition
Add a new condition to the master list by clicking the + button.
Set the necessary properties as described in the following sections: General, Stimuli, Stroke descriptionand word extraction and click OK. The condition will be added to the master list.
NOTE: Alternatively, fill in the general information and click OK. You can add the other properties by right-clicking the condition > condition properties later.
Select the condition(s) to be added and click add.
The other tasks that could be done in this window are: 1) Remove a condition from the master list: click 
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the 'X' button, 2) Check the condition properies: click the hand button, 3) View relationships : click the tree button.
Remove a condition from an experiment
Go to the Experiment (e.g., EEE) and expand the tree by clicking '+' buttons. Experiment conditions (EEE conditions), right click > Remove from experiment.
The condition will be in the master list to make it available for the current EEE experiment or other experiments for the user.
To permanently remove the condition, navigate to master list of the conditions, right click > delete..
To permanently remove the condition you can also right click on the experiment > add conditions > select the condition > click the 'X' button.
Duplicating an existing condition
Go to the condition you want to duplicate by either expanding the experiment tree and looking under experiment conditions or go to the master list of conditions.
Right click on the condition > Duplicate.
All the properties are retained except the three letter ID. Change the three letter ID, alter any properties you want, and click 'OK'.
The condition is then added to the master list, not to the experiment. You can then add it to any experiment as described above.
This option is extremely useful to create a number of similar conditions without having to enter all the information repeatedly.
Generate multiple conditions
This feature can be used to generate a set of multiple conditions based on a generic condition. Word Extraction experiments, which require a large number of conditions to extract individual words, can be readily implemented using this option.
Right click on the condition to replicate > Generate Multiple Conditions

Number of condition to generate
Number of new conditions to create that will be based on the current condition.
Shared description for new conditions
Generic condition description for newly created conditions.
Word Extraction
Generate word extraction conditions
Check to setup newly created condtions to extract words from a specific parent condition.
Parent condition
Condition from which individual words will be extracted.
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Starting word
The word index to begin word extraction. eg: entering 5 in this field and generating 10 conditions in total will enable the extraction of word numbers 5-14 from the parent condition STO.

Trial Replications per condition
Properties per experiment condition (condition added to an experiment):
The number of trial replications of a particular condition can be chosen per experiment.
Double click a particular experiment > Double click conditions > Right click a particular condition > Click Trial Replications.
Never collect only 1 trial. The absolute minimum is 2 trials. Accuracy improves linearly with 4, 8, 16, 32, ... trials. Since trials may fail the consistency test, it is recommended to collect at least 6 trials.
NOTE: Since the number of trials are specific to an experiment, when the same condition is used in different experiments, you cannot set the number of trial replications for a condition in the Master list.

Condition Properties General | Condition Consistency Checking | Condition Word Extraction | Condition Visual Feedback Settings | Condition Sound Settings | Feedback | Stimuli | Stimulus Editor | Stroke Description | Experiment/Group/Subject Process

© NeuroScript LLC. All Rights Reserved.

Trials
The trial is the core of the system. Settings are made at three levels: The computer (hardware-related that cannot be changed often), the experiment (settings that should remain constant for all conditions), and the condition.
* Computer-Level Settings
* Application-Level Settings
* Experiment-Level Settings
* Condition-Level Settings
* Trial Structure and Flow 

Computer-Level Settings
This is tablet specific. Please refer to the documentation from the manufacturer for the tablet which you use. 
NOTE: Important digitizer driver settings may be altered via the control panel >digitizer driver. However, we recommend the default driver settings as much as possible. 

Application-Level Settings
To alter the application settings, click "Select Input Device..." from the Settings menu.
Important settings involve not only the type of input device, but also tablet size, screen size (needed for real-size feedback) and whether mapping of the digitizer is the entire desktop (e.g., required for pen computers) or the recording window (required when tablet and display have different sizes).

See Also 

Trials
NeuroScript MovAlyzeR Help Send comments on this topic.
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Experiment-Level Settings
To alter the experiment settings, right-click on a given experiment and choose "Experiment Settings..." from the popup menu. 
The following picture shows the options available during the actual trial procedure. You have the option to view/answer the subject questionnaire (must already be setup). Randomization of trials of trials can be done at the condition level only and even at the repetition level. Trial instructions (per condition) and end-of-trial events are also available...such as delays and trial acceptance. 
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The following picture shows the options available during the actual trial procedure. You have the option to view/answer the subject questionnaire (must already be setup). Randomization of trials of trials can be done at the condition level only and even at the repetition level. Trial instructions (per condition) and end-of-trial events are also available...such as delays and trial acceptance. 

Condition-Level Settings
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To alter the condition settings, right-click on the desired condition and choose "Properties..." from the popup menu. Then select the "Stimuli" option in the tree on the left. 
In the condition, you impact a trial with the user instruction and various stimuli. 

Trial Structure and Flow
o Instruction as alphanumerics above the recording window shown when the trial begins. It can remain visible throughout the trial or disappear when the pen touches the tablet.
o A stroke description for determining consistency. 
o A graphical warning stimulus with duration and a latency following it.
o A precue stimulus with duration and a latency following it.
o Then, the system is ready to start recording. The start and end of the recording depend upon the settings:

o Pressed means: Pressure >=Minimum Pen Pressure.
o Lifted means: Pressure <Minimum Pen Pressure but the lift is not as high as "out of proximity"..
o Out of proximity means: Pen lifted so high (~0.7 cm) that no data are received. Recording stalls. This causes a discontinuity. Any data after the first discontinuity will be disregarded when processing. These high pen lifts should only happen before the recording or after the recording.

o If no start option is checked, recording will start immediately. If the pen is lifted slightly, recording will start with a pen lift. However, if the pen is lifted outside of proximity, no data will be received. Recording resumes when the pen is in proximity. Therefore, it is not sure how much time has passed. The safest is to instruct subjects to have the pen on the paper (tablet) before the trial starts. The recording may thus start with a pen lift. When the pen is lifted, a faint trace is generated, and this trace is also recorded. Recording can start unnoticeably to the participant. This option must be used in reaction-time experiments. 
o The following 4 start and stop options can be combined arbitrarily (except where noted):

Option Description MovAlyzeROnlyDelay recording until pen touches 

Starts recording as soon as the pen is brought from lifted (pressure < Minimum Pen Pressure) to pressed (pressure >= Minimum Pen Pressure). The recording will start with the pen on paper. When the Minimum Pen Pressure = 0, the recording will begin as soon as the pen is brought 
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NOTE: For both options Stop recording on last target and Stop recording on wrong target, though recording stops after the last or the wrong target is reached, the pen movement trace after recording in stopped is still visible on the screen.
o In general, a trial can end when the pen is lifted for more than the pen-lift time. 
o In addition, a trial can end when the total recording time is exceeded, independently of whether the pen is pressed or lifted.

NSHelp: Viewing Trials | Run Experiment Trial Settings | Testing Subject

© NeuroScript LLC. All Rights Reserved.

Stimuli
This topic is ONLY applicable to MovAlyzeR.
View the navigation options to get to this help page.
A condition can include visual stimuli consisting of target or non-target stimulus elements. 
o The stimulus can be added to a condition as a precue, warning, or imperative stimulus. The precue and warning are shown before the recording starts. The imperative stimulus is shown when the recording starts.
* Create Stimulus
* Stimulus Properties & Features
* Add Stimulus to Condition

Create Stimulus
o Right-click on Stimuli in the left window experiment tree > Create New.
o The following window is displayed: Type a 3 letter ID and a description and click OK.

tablet within proximity of the tablet. NOTE: Cannot be used if "Start recording on first target" is selected. Start recording on first target

Starts recording as soon as the pen, while pressed, reaches the first target. As long as the pen is outside the target, a faint trace is generated as if the pen was lifted but no data is recorded. NOTE: Cannot be used if "Delay recording until pen touches tablet" is selected. 
X

Stop recording on last target

Stops recording when the pen is brought from outside the last target, irrespective of pen pressure, to inside the last target while pressure >=Minimum Pen Pressure. NOTE: If "Start recording on first target" is selected, the recording will NOT stop unless you have reached the first target with pen pressed.
X

Stop recording on wrong target

Stops recording when the pen is pressed inside an out-of-sequence target. NOTE: If "Start recording on first target" is selected, the recording will NOT stop unless you have reached the first target with pen pressed.
X

See Also 

Stimuli
NeuroScript MovAlyzeR Help Send comments on this topic.
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To Create/Add elements to a stimulus:
o Do the following without closing the previous window for creating a new stimulus by clicking '+'.
o Otherwise, after creating the stimulus, to come back to the above window, right click on the stimulus > Add elements.
o In both cases, the following window is displayed.

o To create and add new elements, click '+'.
o Refer 'stimulus elements' to set the properties and click 'OK'.
o The new element is added to the master list. You can add multiple elements to the list by repetitively clicking '+'.
o To add one or more elements to the stimulus, select a single element or choose multiple elements using 'shift' or 'ctrl' keys with the mouse/pen and click add.
To remove an element from the stimulus:
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o To remove an element from the stimulus, select the element in the 'Stimulus Elements' list of the Stimulus properties and click 'X'. This will not permanently delete the element. It will still be retained in the Master list.
o You can also remove an element from an existing stimulus by navigating to the stimulus elements on the left window experiment tree, right click the element > remove from stimulus. This will not permanently delete the element. It will still be retained in the Master list.
o To permanently remove an element for the user, go to the master list by clicking '+' from the stimulus properties window, select the element and click 'X'. You can also navigate to that particular element under the elements on the left window experiment tree, right click and click 'delete'.
To add stimuli to conditions, refer to creating new conditions.

Stimulus > Properties
o Select the stimulus from the left tree window > Right click on the stimulus > Properties.
o All the elements that have been previously added to the stimulus are listed in the 'Stimulus Elements' window.
o The Available Targets list shows all the elements from the above list that are defined as targets (To check whether an element is defined as a target select the element > right click > properties > This element will be a target).
o These target elements can be sequenced in a particular order for a stimulus by adding them to the 'target use/sequence' list using -> arrow to add a single element and the ->> arrow to append all the elements from the available targets list to the end of the target sequence list.
If you need to change the sequence after adding the elements use the up and down arrows.
If an element has to be moved back from the target use/sequence list use the <- for moving an element that is selected and <<- arrow to move all the elements back.

o NOTE: You can put the targets in a sequence to form your own patterns. In the target use list, you can repeat any element, by adding it again from the available targets list.
o For example, in the above window, the elements HOM, TO1,TO2, TO3...etc are added repeatedly in a particular order HOM, TO1, HOM, TO4, HOM, TO6, HOM....to create a pattern.
o When the experiment is run, the targets HOM, TO1, TO2... are displayed and the user has to hit the targets from Home to target 1, then back to home, Home to target 4, back to the Home and so forth.
NOTE: Target Use/Sequence may differ per Stimulus and Condition.
Features
o View data: The stimuli data can be viewed in a text file. It shows the x, y and z coordinates of the 
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elements in an order. Select stimulus > right click > view data.
o Chart data: This chart shows the positioning of the elements on the x and y axis, X-Z axis, Y-Z axis, X,Y & Z vs sample numbers.
uluso Test in Recording window: To view the stimulus on the recording screen right click on the stimulus > Test in recording window. This feature is very handy to see how a stimulus will look on the screen before it is added to a condition.
o To stop the test click 'STOP' on the main task bar of the program or hit 'ESC' key on the keyboard.
o NOTE: If you want to see the stimulus in the recording window in real size, set this option: Main tool bar > Settings > Select input device > Tablet/mouse mapping > 'Recording window' and 'proportional'.

Adding Stimuli to Conditions
When stimuli have been created, they can be used as a warning, precue, or imperative stimulus.
o Right click on the condition you want to add the stimulus to > properties > stimuli.

Navigation
1. Menu Bar: Tree Action -> Stimuli -> Stimulus -> Properties2. Left Window: Right-click Stimulus -> Properties3. Condition Properties -> Stimuli -> Warning Stimulus -> Create New / Properties4. Condition Properties -> Stimuli -> Precue Stimulus -> Create New / Properties5. Condition Properties -> Stimuli -> Imperative Stimulus -> Create New / Properties

NSHelp: Stimulus Editor | Elements

© NeuroScript LLC. All Rights Reserved.

Stimulus Editor
The Stimulus Editor is an application program for MovAlyzeR that allows you to visually design and  edit stimuli behavior and properties. It tremendously speeds up stimuli generation and experiment setup times. Stimuli can be seamlessly exchanged between MovAlyzeR and the Stimulus Editor.

See Also 

Stimulus Editor
NeuroScript MovAlyzeR Help Send comments on this topic.
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Create new Stimulus
1. Open Stimulus Editor: File (MovAlyzeR) > Stimulus Editor
2. Create new stimulus: File (Stimulus Editor) > New
3. The default stimulus S01 is loaded into the workspace. Edit the stimulus ID and description by clicking on the Stimulus name in the tree menu and changing the appropriate fields in the Properties window.
4. Add elements to the stimulus. Right click on the stimulus name > New Element or New Target. Optionally you may include an existing element from the current user by selecting Add Element.
Edit existing Stimulus
To edit an existing stimulus in the Stimulus Editor, right-click the stimulus and choose "Stimulus Editor" from the popup menu.

Working in the Stimulus Editor
The Stimulus Editor has a highly intuitive interface to creating and editing stimuli.
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Highlight any element by clicking on it. All the element properties are displayed in the Properties window and may be edited there directly. Position highlighted elements by dragging and dropping with the mouse or use keyboard arrow keys.
Target Sequence list may be set by Right clicking stimulus name > Target Sequence list.
Export stimulus to MovAlyzeR
A stimulus created in the Stimulus Editor can be saved and used in the following ways:
1. File > Export > To A MovAlyzeR user
This will export the stimulus to the current MovAlyzeR user in Stimulus Editor. To set the current user in Stimulus Editor, click on User in the tree menu and select the relevant user ID in the Properties window. Once exported to a MovAlyzerR user, the stimulus can be used in that user by Right clicking Condition name > Properties > Stimuli.
2. File > Export > To A File
This will export the stimulus to a .MEF file, the native MovAlyzeR experiment export file. The .MEF file thus generated can then be imported into any MovAlyzeR user by File > Import > Import Experiment.
3. File > Save As
Save the stimulus in a .sed file that can be later opened through Stimulus Editor for further editing or maybe exported to MovAlyzeR using either of the above steps.
Help on using the Stimulus Editor can be found in the dynamic help of the program.

NSHelp: Stimuli | Elements

© NeuroScript LLC. All Rights Reserved.

See Also 
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Subject Groups
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
After creating an experiment, the particular experiment is expanded, otherwise double-click on Experiments. 
When defining new groups, they will be added to a master list and can be selected for other experiments. This assures consistency of the entire database. Changes of the group are specific to that experiment. However, these changes will be overwritten by changes in the master list.
* To create/add a new group
* To remove a group from an experiment
* To delete a group

To create/add a new group
Go to the 'Groups' folder for the user > Create new..

o The group properties window is displayed.

o Enter a unique, 3-letter ID (must differ from reserved directory names CON and NUL), a description, brief notes, and 'OK'. 
To add groups to an experiment
o Right-click on Groups under a particular experiment > Add Group(s). 

Groups of Subjects
NeuroScript MovAlyzeR Help Send comments on this topic.
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o At this point you can decide to create one or more groups to be added to the existing list (master list) by clicking the '+' button (or click the x button to remove irreversibly from the list). 
o Select the Group(s) to be added and 'OK' (groups previously added are not available). 

To remove a group from an experiment
o Go to the group under an experiment> right click > remove from experiment..
This will detach the group (and the subjects under that) from the experiment, however, the group will be available to the other experiments from the master list. 
The data under all the subjects of the experiment group will also be retained. Hence, if you add the group and the subjects back to the same experiment, any existing data trials are restored. 

To delete a group
o Navigate to the 'groups' folder, where all the groups for the user are listed. 
o Right click on the group ID > delete..
NOTE: A message will be displayed to indicate if the group is attached to any experiments. Clicking Yes confirms that the group will be removed from all the experiments it has been added to and the corresponding trial data under the experiment groups will be permanently removed. 

NSHelp: Experiments | Subjects
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Subjects/Participants
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
After Creating a group the particular group is expanded. 
When defining new subjects they will be added to a master list, and can be selected for future experiments. This assures consistency of the entire database. Changes of the subject are specific to that experiment. However, these changes will be overwritten by changes in the master list.
* To create/add a new subject
* To remove a subject
* To move a subject from one Experiment group to another
* To Delete a subject

To create/add a new subject
Go to the 'Subjects' folder for the user > Create new..

See Also 

Subjects
NeuroScript MovAlyzeR Help Send comments on this topic.
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o The subject information window is displayed.

o Yellow fields indicate private information. See Subject Privacy Protection.
o Enter a 3-letter ID, up-to-25-character code, first and last names (aliases 1 and 2). 
o Site information is derived from user but can be edited via the "EDIT" link.
o Enter optional subject data in 'Private Notes' and 'Public Notes' and OK. Later, you can construct your extended questionnaire. 
o The subject's device resolution and sampling rate are only visible if the properties are chosen of a subject WITHIN an experiment. These values should not be edited unless necessary. They reflect the actual settings of the device used for the experiment.
o The subject's password is the same as the user by default. It can be changed by clicking on the "Change Password" button.
o Click ok to add the subject to the master list of subjects in the 'Subjects' folder of the user. 

To remove a subject from an experiment group
o Go to the subject under an experiment group > right click > remove from group..
This will detach the subject from the group, however, the subject will be available to the other experiments from the master list. 
The data folder for the subject will also be retained. Hence, if you add the subject back to the same experiment group, any existing data trials are restored. 

To move a subject from one Experiment group to another
o Select the subject under the experiment by expanding the experiment tree using '+' or by double-clicking.
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o Right click on the subject to be moved > move to group.
o The following message is displayed:

o Click 'yes' to confirm and Select the group.

o Select the group and click 'OK'.
o This will result in the subject and all the trials being moved into the new group.

To delete a subject
A subject can be permanently removed from a user, by expanding the subjects folder, select the subject > right click > delete subject..
NOTE: A message will be displayed to indicate if the subject is attached to any experiments. Clicking Yes confirms that the subject will be removed from all the experiment groups it has been added to and the corresponding trial data will be permanently removed. 
To add one or more subjects to an Experiment group:
A group can be added to different experiments (Experiment Groups). These experiment groups are different entities and hence, different subjects can be added to individual experiment groups. This is shown clearly in the following figure: 
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Subjects can be added to an experiment group, by Right-click on a particular group under a particular experiment > Add Subject(s). 
o The Master subjects list for the user is displayed. 

o At this point you can decide to create one or more subjects to be added to the existing list (master list) by clicking + button to display the subject information window. 
o An exisiting subject can be removed from this master list by selecting the ID and clicking the 'X' button on this window. Also the properties of an existing subject on this list can be modified by selecting the ID and clicking the hand symbol button listed first. 
o Select subject(s) to be added and OK (already added subjects are not available).  
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Testing a Subject 
This is a common topic for MovALyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page. 
Testing a new subject/Running an experiment can be done by the Run Experiment Wizard or manually.
* Run a subject using Run-Experiment Wizard
* Run a subject manually
* Recording feedback
* Experiment Control Window
* Actions Log

Run Experiment Wizard
o Adjust the experiment settings if required, by going to experiment > Experiment settings > Run experiment settings.
o Start MovAlyzeR > File > Run Experiment Wizard.

o Click 'Next'.
o Step 1: Click 'New Experiment' > Type ID 'E01' and any Description > Click OK.
o Step 2: Click 'New Condition' >Type ID 'C01', and any Description > Click OK.
Type #Repetitions (Number of trials per condition to be recorded, default = 2) > Click Next.
o Step 3: Click 'New Group' >Type ID 'G01' and any Description >Click OK.
o Step 4: Click 'New Subject' >Type ID 'S01', First and Last Names >Click OK. 
o Click Finish. 
o NOTE: This feature allows you to add only one group, one subject and one condition during the wizard.
o At the end of this procedure, your Left window experiment tree should look like this: 

Testing Subject
NeuroScript MovAlyzeR Help Send comments on this topic.
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o Click 'Finish'.

Run a Subject Manually
o Start MovAlyzeR > Experiments > chose a particular experiment > Groups. 
o Define a new subject or double-click Subjects.
o Make any last-minute adjustments for the settings by going to experiment > Experiment settings > Run experiment settings. Refer to Experiment settings for information on the parameters.

o Right-click a particular subject > Run Experiment. 
o During running an experiment, adjustments can be made in the Experiment Control Window or the Toolbar.
o If the subject does not produce the required pattern, a red checkmark appears in front of the trial, otherwise a green checkmark. 
o Chart trials by double clicking the particular trial item. 
o At the end of the experiment, the Error Report and the Extracted Features are shown per condition.

Recording feedback 
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o While using a mouse or tablet as the input device, during recording of data a visual feedback of real-time data is displayed on the recording window area as follows:

Experiment Control Window
o The text box on top displays the instruction to the user and participant. On the left is the sequence of trials with the correct trials marked green. Incorrect trials are marked with red.
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o Sliding the splitter down shows additional controls that can be altered during the experiment and become in effect after clicking Apply Changes. 
o Click on Stop Experiment, Stop Condition, Stop Recording if required.
o A trial can be redone immediately by clicking with the pen or mouse on "Redo Trial". You can also redo any other trial via the Data Navigator submenu.
o You can switch on/off immediate processing. Immediate processing shows after each trial whether the trial was performed correctly. You can also chart the raw data as they are stored, or the processed data and derived time functions with or without segmentation points. 
o After every change, click 'Apply changes'.

NSHelp: Experiment Properties | Experiment Settings | Feedback | Log | Run Experiment Trial Settings | Trials
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Testing a Subject 
This topic is ONLY for GripAlyzeR.
Testing a new subject/Running an experiment can be done by the Run Experiment Wizard or manually.
* Run a subject using Run-Experiment Wizard
* Run a subject manually
* GripAlyzeR Experiment Procedure: Example
* Recording feedback
* Experiment Control Window
* Actions Log

Run a subject using Run-Experiment Wizard
o Adjust the experiment settings if required, by going to experiment > Experiment settings > run experiment settings
o Start MovAlyzeR >File >Run Experiment Wizard

See Also 

Testing Subject (Gripper)
NeuroScript MovAlyzeR Help Send comments on this topic.

Page 4 of 9Testing Subject

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh54F0.htm



o Click 'Next'
o Step 1: Click 'New Experiment' > Type ID 'E01' and any Description > Click OK
o Step 2: Click 'New Condition' >Type ID 'C01', and any Description > Click OK 
Type #Repetitions (Number of trials per condition to be recorded, default = 2) > Click Next
o Step 3: Click 'New Group' >Type ID 'G01' and any Description >Click OK 
o Step 4: Click 'New Subject' >Type ID 'S01', First and Last Names >Click OK 
o Click Finish 
o NOTE: This feature allows you to add only one group, one subject and one condition using the wizard.
o At the end of this procedure, your Left window experiment tree should look like this: 

o Click 'Finish'
Run a Subject Manually
o Start MovAlyzeR >double-click Experiments >double-click a particular experiment >double-click Groups 
o Define a new subject or double-click Subjects
o Make any last-minute adjustments to the settings by going to experiment > Experiment settings > run experiment settings. Refer to Experiment settings for information on the parameters.

Page 5 of 9Testing Subject

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh54F0.htm



o Right-click a particular subject > Run Experiment 
o During running of an experiment, adjustments can be made in the Experiment Control Window or the Toolbar.
o If the subject does not produce the required pattern, a red mark appears in front of the trial, otherwise a green mark. 
o Chart trials by double clicking the particular trial item. 
o At the end of the experiment, the Error Report and the Extracted Features are shown per condition.

GripAlyzeR Experiment Procedure: Example
You can use the following procedure to make a recording using the gripper device

a. Before the recording starts, 
o Instruct the participant to grab bottom unit of the Gripper from the table, placing the non-dominant hand with thumb on the bottom unit sensor, the other fingers on the other side of the unit and lift the gripper. Then place the top unit on the bottom unit. 
o The experimenter then starts the experiment, by clicking on a particular subject > Run experiment. 
o The participant is allowed to view the experiment instructions on the screen and the experimenter clicks OK to start the recording. 

b. After a 'start recording' signal -- a beep or .wav sound as set in experiment settings, is heard:
o The participant has to grab the top unit of the Gripper with the dominant hand, similarly to that of the bottom unit.o Then pull the top unit off the the bottom unit. o The participant holds the units apart until the end-of-recording signal. (A message 'DONE: Press ENTER key to continue) is seen on the instruction screen.{At this point, the trial is paused as we have set the option 'Delay trial until enter key is pressed' in the Experiment settings - Recording. This option is necessary for consistent data}.

c. To prepare for the next trial 
o The participant places the top unit on top of the bottom unit.o The experimenter hits the 'ENTER' key to start the next trial

Repeat step b. and c. until all the trials are done. To test the system, you can do this example experiment with 5-10 trials. 
~NOTE: If the experimenter performs the experiment as a participant, for step c. : Place the top unit on the bottom unit. Then, keep the whole unit in the non-dominant hand, while using the dominant hand to hit 'ENTER' to start the next trial.
~NOTE: If the 'double buffer mode' option is chosen in input device > DAQPad settings, you can notice the visual feedback of the sensor signals on the screen in the recording window area. The blue line represents the lower gripper, the green line represents the upper gripper and the red line corresponds to the load sensor data. 

Recording feedback 
Visual Feedback after recording 
o If the option 'Single buffer mode' is chosen in the input device settings for the DAQPad, then there is no real time feedback, but after the recording stops, a visual feedback of the x-y data is displayed on the screen with sampling points (analogous to the feedback in handwriting experiments). 
Real-Time Feedback during recording
o If the option 'Double buffer mode' is chosen in the input device settings for the DAQPad, then a real time feedback is displayed on the recording screen, with x,y and z axes data plotted against time in real-time. 
The blue line represents the lower gripper, the green line represents the upper gripper, and the red line corresponds to the 
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load sensor data. 
o This feature is extremely useful for determining the relative forces applied on the sensors while recording and the associated noise. The figure below shows a snapshot of the GripAlyzer window during the recording. 

Experiment Control Window
o The text box on top displays the instruction to the user and participant. On the left is the sequence of trials with the correct trials marked green.
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o Sliding the splitter down shows additional controls that can be altered during the experiment and become in effect after clicking Apply Changes. 
o Click on Stop Experiment, Stop Condition, Stop Recording if required.
o A trial can be redone immediately by clicking with the pen or mouse on "Redo Trial". You can also redo any other trial via the Data Navigator submenu.
o You can switch on/off immediate processing. Immediate processing shows after each trial whether the trial was performed correctly. You can also chart the raw data as they are stored, or the processed data and derived time functions with or without segmentation points. 
o After every change, click 'Apply changes'

Actions Log
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o The Actions Log shows every elementary processing step and an indication of the status for the various processing modules. The top line is the most recent line. 
o This log may be useful in determining run time information about the experiment.
o Each line is also time stamped and written to a file (Actions.Log) in the program directory and is vital for identifying problems, which should be e-mailed to NeuroScript. Otherwise, the user may switch logging off by File >Logging >Log Actions to File.
o To view the total Actions.log history including time stamps: File >Logging >View Log File. The most recent entry is at the end of the file. Select, copy, and paste parts into e-mail messages if you want to report comments to NeuroScript.There is also an option to send the complete Actions.log file to NeuroScript.
o The current size is visible in the bottom status bar under Message Log. Files exceeding 5.00 Mb can be cleared totally (via Clear Log File) or partly (via View Log File). 
o To add comments at any time: File >Logging >Add Comments. 

Getting Started: Testing Digitizer/Mouse | MovAlyzeR to Test Digitizers
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See Also 
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Processing Movement Data
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
l Processing or reprocessing can be done per Trial (or) Condition (or) Subject (or) Group (or) Experiment by:

Right-click on trial/condition/subject/group/experiment as appropriate > Processing > Reprocess Trials. 
l Reprocessing is required after changing the processing settings (Experiment_Settings) or condition settings (Condition_Properties) or when immediate processing during the experiment is disabled.
l Reprocessing a particular trial offers two choices: to not update the condition results (ignore results) or append the particular trial's results to the condition results (append results). 
l Progressing can be monitored in the data navigator and by the progress meter (status bar) in the toolbar. 
l To optimize processing speed

¡ Toggle Rapid View in the Toolbar (even during processing) to switch off the trial-by-trial updating of the Data Navigator and the Results Window. However, the Red, Green, and Gray trial markings will not be shown until after processing is complete.
¡ Toggle Logging in the Toolbar clicking File > Logging > Uncheck Log Actions to File to suppress logging of all program steps to a file. 

Action Experiment Settings Input file (extension) Output file (extension) & link Output per Numerical Output (View)MovAlyzeR GripAlyzeR
Run Experiment Recording - hwr frd Trial Raw data

Process data
Steps: 
Subject (or) Group(or) Condition(or) Exp > Process > Reprocess trials
Trial > view data > processed data/ Extracted data/ segment data/ consistency error data/ consistent data

Time Functions hwr tf tf Trial
Processed time functions (= position, velocity, acceleration, jerk, spectra)

Segmentation tf seg seg Trial Segment
Feature Extraction tf and seg ext ext Condition (all trials)

Extracted data (= all trials and strokes)

Consistency Checking ext file

con (consistent data) con (consistent data)
Condition (all trials)
(Note: Ext file is processed for every trial and .con file written with data for last correct trial per condition)

Consistent data (= only accepted trials and strokes)

err (consistency error data) err (consistency error data) Consistency errors (= type of errors)

Steps:
Experiment > Summarize
Experiment > Summarize> view Extracted data > .inc file
Experiment > Summarize > view err data >.err file

Summarization

con and ext files inc

Selection of subjects and groups per experiment 
(Note: Ext and con files are read again for every trial and con files per condition rewritten with data for all correct trials)

Inc data (for standard statistical packages)

err (from consistency) err Consistency errors (= type of errors)

ext ers 

Experiment > Analysis > Analysis Chart 
(or) All trials, All data, averages, averages/sub)
Analysis Chart > Actions/settings> View raw data (.tmp file) OR 

Analysis & Statistics

inc tmp
Selection of subjects per experiment

Raw data
tmp xme, xm1 X-mean data 

xme txt Exported data (for standard graphing packages)

Processing
NeuroScript MovAlyzeR Help Send comments on this topic.
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NSHelp: Trials | Experiment/Group/Subject Process
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Segmentation Procedure
The segmentation methods are described on this page for:
I. ScriptAlyzeR and MovAlyzeR 
II. GripAlyzeR 
I. ScriptAlyzeR and MovAlyzeR 
Segmentation consists of 4 levels:
1. Segmentation of multiple writing-pattern recordings into individual words
2. Begin and end detection per writing pattern
3. Stroke segmentation per writing pattern
4. Submovement segmentation per stroke
Segmentation in to words (level 1) is based on raw data. Segmentation levels 2–4 are based on processed data. 
There are currently three segmentation methods available in MovAlyzeR to parse the input data in to segments: 
l Segmentation at zero crossings of vertical velocity
l Segmentation at the local minima of the absolute velocity
l Segmentation at pendown trajectories

The segmentation settings and flags are specified in: Experiment > Experiment settings > Processing > Segmentation > Settings/Flags, in which Various parameters in the calculations can be set. 
The phrases highlighted in maroon are the MovAlyzeR terminology used in segmentation settings/flags.
Segmentation by zero crossings of vertical velocity
Movements can be segmented into strokes by zero crossings of the vertical velocity after peak velocity. 
Features
o The pattern is segmented into successive up and down strokes.o This segmentation requires prior (Automatic) and or Fixed Unrotation so that the segmentation dimension will be vertical.o Fine detection finds the point where the velocity disappears in the noise. o In theory, minimum absolute vertical velocity coincides with a zero-crossing of the vertical velocity. The converse is not true, because zero-crossing of the vertical velocity may also coincide with a relative maximum of the vertical velocity. o Linear interpolation is done between the samples around the zero-crossing.
Advantages
o Accurate and simple.o Easy to chart.o Only 2 points around zero required.
Disadvantages
o Patterns needs a predominant orientation.o The predominant orientation needs to be rotated to vertical.
Input data
There are two input files used for segmentation: Raw data (.HWR) and Processed data (.TF). Refer to the section processing movement data for a description of the files.
Algorithm Description
1. Stroke Begin/End Detection:
o Calculate the dynamic range/Velocity level of vertical velocity (Vy) by: 

~ Find the maximum/peak Vy, for both positive and negative values.
~ The threshold level considered for segmentation uses the value: Minimum vertical velocity of 1st/last stroke (relative to absolute peak) - Vylev
For example, if minimum is specified as 0.05 (5%) and maximum as 0.1 (10%) then the range is 5% of peak Vy to 10% of peak Vy.

+++Begin point+++
Coarse detection:
o Find the first upward/downward vertical velocity (coarse point), exceeding the threshold level (Vylev), by searching forward from the first sample.
o If the first sample velocity already exceeds Vylev, then search again to find the sample with a velocity value less than Vylev, and to further find the next sample at which velocity exceeds Vylev (threshold).
Fine detection:
o Go backwards from the coarse point until a zero-crossing or minima is found (a).
o In addition, if the option 'Check for the minimum velocity level in cm/s' is checked, go backwards from the coarse point to find the sample at 

view xmean data(.xme and .xm1 file) OR view tabular data(.txt file)
xm1 > xme > eva > grp > lst lst (Statistics file) Statistics

See Also 

Segmentation
NeuroScript MovAlyzeR Help Send comments on this topic.
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which the velocity is still above the minimum velocity level (b).
o Identify the beginning of first upstroke, which is the latest occuring (highest sample number) among the points (a) and (b).
+++End point+++
2. Stroke Segmentation:
o Find all the zero crossings between the first and the last zero-crossing/minima.
o If the last point in the zero-crossing detected is within the minimum stroke duration, then add another point at the last zero-crossing/minima.

Note: If the time duration between adjacent zero-crossings is less than the minimum stroke duration, then the last segmentation point for that stroke is not considered. 
o Remove first segmentation point, if starting with non-zero vertical velocity except when there is only begin and end. Do not remove first point if it is at a velocity level smaller than the second threshold level as specified by: Maximum vertical velocity of 1st/last stroke (relative to absolute peak). 

~ For example, if the maximum vertical velocity is specified as 0.10 (10%), the first point is not removed by the procedure above if at a level lesser than 10% of the peak vertical velocity. 
o Remove last segmentation point, if stopping within non-zero vertical velocity except when there is only begin and end.
o Calculate the minimum stroke size and remove the strokes (corresponding segmentation points) which are smaller than this size by:

~ Use the value specified in settings for 'Minimum stroke size relative to max stroke' (ratio of Minimum stroke length/Length of longest stroke).
~ Tentative minimum stroke length = (Length of longest stroke in a trial) * value of ratio specified in settings.
~ Then actual minimum stroke size = Maximum of (Minimum stroke size from segmentation settings, Tentative minimum stroke length).
~ Example, Minimum stroke size relative to max stroke ratio specified = 0.1 (10%)If the length of maximum stroke in a trial is 10 cm, then the tentative minimum stroke length is 0.1*10 = 1 cm. If the minimum stroke size specified = 0.05 cm, then the actual minimum stroke size = max (1, 0.05) = 1 cm.
~ Note: In this case, then all the strokes with lengths less than 1 cm are ignored. Hence, in a trial if there is an indication there are some strokes missing or unduly terminated, then verify that the ratio is not too large and adjust the value accordingly. The lower the %(ratio), the more zero crosssings (segmentation points) are considered. 

3. Conditional processing based on segmentation flags set:
o If the option 'Add Last Segment at any rate' in segmentation flags is checked, then:

~ Add a last point (and a corresponding stroke) at the last data value, if there is data after the current last segmentation point, irrespective of the min/max velocity relative to peak, specified. 
o If the option 'Add First Segment at any rate' in segmentation flags is checked, then:

~ Add a first point (and a corresponding stroke) at the first data value, if there is data before the current first segmentation point, irrespective of the specified min/max velocity relative to peak velocity.
o If the option 'One Stroke analysis' in segmentation flags is checked, then:

~ Add a first point (and a corresponding stroke) at the first data value, if there is data before the current first segmentation point.
o If option (2), replace the first and last segmentation points with the acceleration zero crossing points determined earlier (in case they were replaced/altered during intermediate processing)
o MovAlyzeR ONLY: If the option 'Submovement analysis' in segmenation flags is checked, then:

~ Determine the secondary submovement points for every stroke (The first minima after the velocity peak in that stroke).
o Write the primary and submovement points, if any, to the output file.
Output data
Output data for segmentation consists of: 
Segmentation points:

tvyzero (sec): The time in sec corresponding to the primary segmentation points (vertical velocity zero crossings). Two of these adjacent points make up a stroke. 
If option (2), first and last point refer to vertical velocity minima instead.

Secondary submovement points (MovAlyzeR ONLY + submovement analysis checked): 
tayzero (sec): The time in sec corresponding to the secondary submovement points for every stroke. Hence, each of these points will have a value inbetween the current and next segmentation points. Eg., the first secondary submovement point value will be inbetween consecutive segmentation points. 

For more details, refer to the section processing movement data for a description of the files.
Example:
Red circle points show vertical velocity zero crossings (strokes) and cross points show submovement points
For a x-y data pattern as given below:
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The Vertical velocity data chart will be as follows:

Segmentation at the local minima of absolute velocity
Movements can also be segmented into strokes by minima of the absolute velocity. The time accuracy of the segmentation points has been improved by quadratic interpolation between three samples: the sample of the minimum and the 2 adjacent samples.
Features
o Does not require that a pattern has one particular orientation. o Strokes do not need to have an up-down sequence.o Quadratic interpolation is done around the minimum sample.
Quadratic Interpolation: Interpolation in the time domain is essential to achieve the required accuracy. For example, measuring a very short time interval, e.g., between samples 116 and 120, would yield 4 samples if no interpolation were applied. With interpolation, the sample numbers cold be 116.3 and 119.6, yielding an interval of 3.3, which is substantially different and most likely better.
Advantages
o Orientation free
Disadvantages
o Less accurate due to quadratic approximation. 
o Less trivial to chart (charts interpolate still linearly but the x-coordinate of the segmentations are taken from the quadratically interpolated minima and may seem higher than the lowest sample)
Input data
There are two input files used for segmentation: Raw data (.HWR) and Processed data (.TF). Refer to the section processing movement data for a description of the files.
Algorithm Description
1. Stroke Begin/End Detection:
o Calculate the dynamic range/Velocity level of absolute velocity (Vabs) by: 

~ Find the maximum/peak of Vabs, for both positive and negative values.
~ Find the range of Vabs levels considered for segmentation using the value: Minimum vertical velocity of 1st/last stroke (relative to absolute peak)- Vlev. 
Note: In above, the 'vertical velocity' term is taken as absolute velocity for this segmentation method.

~ For example, if minimum is specified as 0.05 (5%) and maximum as 0.1 (10%) then the range is 5% of peak Vabs to 10% of peak Vabs.
Coarse detection: 

Find the first upward/downward absolute velocity (coarse point), exceeding the threshold level (Vlev), by searching forward from the first sample for begin point detection, and last sample for the end point detection.
Fine detection - Begin point: 

Identify the beginning of first upstroke, by going backwards from the coarse point until a minima is found.
Fine detection - End point:

Identify the ending of last stroke by searching forwards from the coarse point until a minima is found. 
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2. Stroke Segmentation:
o Find all the minima between the first and the last points.
o If the last point in the minima detected is within the minimum stroke duration, then add another point at the last minima.

Note: If the time duration between the adjacent minima is less than the minimum stroke duration, then the ending segmentation point for that stroke is not considered. 
o Remove first segmentation point, if starting with non-zero absolute velocity except when there is only begin and end. Do not remove first point if it is at a velocity level smaller than the second threshold level as specified by setting: Maximum vertical velocity of 1st/last stroke (relative to absolute peak). Here, the term vertical velocity refers to absolute velocity for this segmentation method.

~ For example, if the maximum vertical velocity is specified as 0.10 (10%), the first point is not removed by the procedure above if it is at a level lesser than 10% of the peak vertical velocity. 
o Remove last segment if stopping with non-zero absolute velocity except when there is only begin and end.
o Calculate the minimum stroke size and remove the strokes (corresponding segmentation points) which are smaller than this size by:

~ Use the value specified in settings for 'Minimum stroke size relative to max stroke' (ratio of Minimum stroke length/Length of longest stroke).
~ Tentative minimum stroke length = (Length of longest stroke in a trial) * value of ratio specified in settings.
~ Then actual minimum stroke size = Maximum of (Minimum stroke size from segmentation settings, Tentative minimum stroke length).
~ Example, Minimum stroke size relative to max stroke ratio specified = 0.1 (10%)I f the length of maximum stroke in a trial is 10 cm, then the tentative minimum stroke length is 0.1*10 = 1 cm. If the minimum stroke size specified = 0.05 cm, then the actual minimum stroke size = max (1, 0.05) = 1 cm.
~ Note: In this case, then all the strokes with lengths less than 1 cm are ignored. Hence, in a trial if there is an indication there are some strokes missing or unduly terminatedl, verify that the ratio is not too large and adjust the value accordingly. The lower the %(ratio), the more minima (segmentation points) are considered. 

3.Conditional processing based on segmentation flags set:
o If the option 'Add Last Segment at any rate' in segmenation flags is checked, then:

~ Add a last point (and a corresponding stroke) at the last data value, if there is data after the current last segmentation point, irrespective of the specified min/max velocity relative to peak velocity.
o If the option 'Add First Segment at any rate' in segmentation flags is checked, then:

~ Add a first point (and a corresponding stroke) at the first data value, if there is data before the current first segmentation point, irrespective of the specified min/max velocity relative to peak velocity. 
o If the option 'One Stroke analysis' in segmenation flags is checked, then:

~ Add a first point (and a corresponding stroke) at the first data value, if there is data before the current first segmentation point.
o MovAlyzeR ONLY: If the option 'Submovement analysis' in segmenation flags is checked, then:

~ Determine the secondary submovement points for every stroke (The first minima after the velocity peak in that stroke).
o Write the primary and submovement points (if any) to the output file.
Output data
Output data for segmentation consists of: 
Primary segmentation points: 

tvabsmin (sec): The time in sec corresponding to the segmentation points (absolute velocity minima). Two of these adjacent points make up a stroke. 
Secondary submovement points (MovAlyzeR ONLY + submovement analysis checked): 

tvabssec (sec): The time in sec corresponding to the secondary submovement points for every stroke. Hence, each of these points will have a value inbetween the current and next segmentation points. e.g., the first submovement point value will be inbetween the first and second segmentation point values. 
For more details, refer to the section processing movement data for a description of the files.
Example:
Red circle points show absolute velocity minima and cross points show submovement points.
For the slow pattern shown below, using the default settings would yield many more segmentation points (points at all the velocity minima). Here, the minimum stroke duration setting in experiment settings, was increased to 0.3 s, to yield the up and downstrokes as shown below:

The absolute velocity chart will be as follows:
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Summary: 
Segmentation consists of 4 levels:1. Word segmentation of multi-writing-pattern recordings2. Begin and end detection per writing pattern3. Stroke segmentation per writing pattern4. Submovement segmentation per stroke
Segmentation 1. is based on raw dataSegmentations 2–4 assume are based on processed data 
Vertical Velocity
1. Begin/End Detection:
Coarse Detection: First search coarsely from begin and end of the recording for a point where the absolute value increases above, or drops below, respectively, the Minimum Velocity Level relative to the absolute peak (threshold velocity). 
If the inital or final sample already exceeds Maximum Velocity, then search first for the sample with an absolute value less than threshold velocity.
Fine Detection: This finds the point where the velocity disappears in the noise by searching in opposite direction where velocity drops below threshold. Then continue searching for the FIRST occurrence of o Zero crossing of the vertical velocityo Relative minimum of the absolute vertical velocity, thus closest to zero.
2. Stroke Segmentation
o Find all zero crossingso Remove a zero crossing closer than the Minimum Stroke Size from the previous segmentation point.o Remove a zero crossing closer than the Minimum Stroke Duration from the previous segmentation point.o Remove a zero crossing if the next stroke has the same direction (up or down) as the current stroke.
3. Conditional processing based on segmentation flags set, including add first/last segment and submovement analysis.
Absolute Velocity Segmentation
1. Begin/End Detection:
Coarse Detection: First search coarsely from begin and end of the recording for a point where the value increases above, or drops below, respectively, the minimum velocity level relative to peak (threshold).
Fine Detection: Then search in opposite direction for the first occurrence of minima.
2. Stroke Segmentation
o Find all minimao Remove a minimum closer than the Minimum Stroke Size from the previous segmentation point.o Remove a minimum closer than the Minimum Stroke Duration from the previous segmentation point.
3. Conditional processing based on segmentation flags set, including add first/last segment and submovement analysis

Segmentation at Pendown Trajectories
All continuous pendown points without a single penup in between are collected as one segment.

II. GripAlyzeR
The gripper data segmentation is based on the z value from raw data (Load force in N/Volts/raw units)
Notes
The previously described segmentation flags and settings are NOT applicable in the case of gripper.
GripAlyzeR always yields 5 segmentation points spanning the following 4 phases:
Phase 1: Preloado The load force as well as the upper and lower grip forces are relatively stable.o The first few samples (adjustable) are used to calibrate baseline forces.o The left hand grabs the bottom unit. The LowerGrip force increases.o The right hand grabs the top unit. The UpperGrip force increases.o The load force may show increases or decreases, depending on how stable the participant is.o This phase starts at the beginning of the recording.
Phase 2: Loado The participant tries to pull the two units apart while a programmable magnet remains active until a certain pulling (load) force. The Load force increases.
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o When the load force exceeds the preset magnet force, the electromagnet is repolarized so that it detaches instantly. This method allows to precisely control the magnetic force.o This phase starts when the measurable load force increases beyond noise level.
Phase 3: Post lift-offo The load force drops dramatically to zero level.o This phase starts when the load force has reached its peak value during the entire recording.
Phase 4: Recoveryo The load force will oscillate around the stable zero level.o This phase starts when the dramatical drop in load force reaches noice level.o The end of the recovery phase is the end of the recording.

Input data
Raw data file (.FRD) is used in segmentation. Refer to the section processing movement data for a description of the files.
Algorithm Description
1. Add begin point of preload phase
Add a first point (and a corresponding stroke) at the first sample.
2. Detect begin of load phase 
Coarse Detection: First search coarsely from begin of the recording for a point where the value increases above the threshold velocity level relative to peak velocity. 
Fine Detection: Then search backwards for the first occurrence of zero crossing or minimum.
3. Detect end of post lift off/begin of recover phase
Coarse Detection: First search coarsely from end of the recording for a point where the value increases above the threshold velocity level relative to peak velocity. 
Fine Detection: Then search forwards for the first occurrence of zero crossing or minimum.
4. Detect Positive peak
Find the highest positive peak between the begin and end of load phase points from steps 2. and 3. 
5. Add end point of recover phase
Add a last point (and a corresponding stroke) at the last sample.
Output data
Output data for segmentation consists of: 

tseg(sec): The time in sec corresponding to the five segmentation points as described in notes

© NeuroScript LLC. All Rights Reserved.

Charting Trial Data
This is a common topic for MovAlyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
* Charts
* Chart properties and Export
* Examples
* Graphical Button Descriptions
* Spectral Analysis

Charts
Chart How to plot Description of the chart
Raw data per trial(MovAlyzeR & ScriptAlyzeR)

Right click on the trial > chart data > chart raw data This will chart the raw position data as X versus Y (that may extend for the first 2-3 charts)
Additional charts include X,Y and Z as a function of time (sampling 

Charting Trials
NeuroScript MovAlyzeR Help Send comments on this topic.
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Chart Properties and Export
Click here to go to the corresponding section on help

Examples
RAW DATA CHART PER TRIAL

coordinates).
Raw data per trial(GripAlyzeR) Right click on the trial > chart data > chart raw data The Raw Data charts display the following forces for each trial:

~LowerGrip (N) and UpperGrip (N) as a function of sample number~ Load (N) as a function of sample number.
All forces are calibrated in Newtons

Raw data per subject Right-click on the subject > plot all raw data Shows all the raw data for a particular subject in an experiment.
Note: In the case of very data intensive recordings, the time taken to display this chart is comparatively increased.

Raw data in real-time per trial Right click on the trial > chart data > chart real-time data This shows the data as it was recorded in real time by the subject. This option is useful in determining glitches during recording.
Raw data in 3D per trial(MovAlyzeR & ScriptAlyzeR)

Right click on the trial > chart data > chart raw data (3D)
This will chart the raw position data as Y versus X (that may extend for the first 2-3 charts) with Z as a third dimension
Additional charts include X,Y and Z as a function of time (sampling coordinates).

Processed data per trial(MovAlyzeR & ScriptAlyzeR)
Double-click a particular trial
<OR>
Right click on the trial > chart data > chart processed data

Charts Time Function Data in X versus Y.
Additional charts include positions, Z-coordinate, velocities, accelerations, jerks in X, Y, or absolutely. All curves are calibrated in units of cm and s.

Processed data per trial(GripAlyzeR) Double-click a particular trial
<OR>
Right click on the trial > chart data > chart processed data

o Lower versus Upper Grip Forces to estimate their proportionality.o LowerGrip versus Load Forces to estimate their proportionality.o UpperGrip versus Load Forces to estimate their proportionality.o LowerGrip (N) as a function of time.o UpperGrip (N) as a function of time.o UpperLoad (N) as a function of time (showing the proper segmentation)o vLowerGrip (N/s) = Change of Lower Gripper Force in Newton/so vUpperGrip (N/s) = Change of Upper Gripper Force in Newton/so vLoad (N/s) = Change of Load Force in Newton/so aLowerGrip (N/s**2) = Acceleration of the Lower Gripper Force in Newton/s2o aUpperGrip (N/s**2) = Acceleration of the Upper Gripper Force in Newton/s2o aLoad (N/s**2) = Acceleration of the Load Force in Newton/s2o V_Spectrum = Amplitude Spectrum of Lower and UpperGrip forces (i.e., absolute spectrum multiplied by 2*pi*Frequency in Newton/s)o V_Spectrum_Filtered = Lowpass Filtered Amplitude Spectrum
Processed data in real-time per trial Right click on the trial > chart data > chart processed data real-time This shows the data as it was recorded in real time by the subject. This option is useful in determining glitches during recording.

Processed data per trial(MovAlyzeR & ScriptAlyzeR) Right click on the trial > chart data > chart processed data (3D)

Charts Time Function Data in Y versus X with Z as the third dimension.
Additional charts include positions, Z-coordinate, velocities, accelerations, jerks in X, Y, or absolutely. All curves are calibrated in units of cm and s.
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CHART ALL RAW DATA PER SUBJECT

PROCESSED DATA CHART
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o Stroke segmentations are marked by o.
o The submovement points are denoted by a X.
3D DATA CHART

Submovement Analysis (MovAlyzeR ONLY)
Example of a movement segmented by (o) and a submovement segmentation (x) between primary and secondary submovements if submovement analysis is enabled in the Experiment Settings.
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Graphical Button Descriptions
From left to right (some buttons apply only to certain charts):

- New Chart - Opens another chart of your choosing (raw, processed, real-time, 3D)
- View Numerical Data - Display the data used to generate the chart
- Extracted Data - Display the extracted data for that trial
- Consistency Errors - Display the consistency results for that trial
- Export - Export the chart to an image, clipboard, or printer
- Print - prints the chart
- Line Thickness - Allows you to choose the line thickness for the chart
- Proportional Scaling - Choose between proportional and optimal scaling
- Monochrome - Choose between color and monochrome display
- Invert (3D only) - Inverts the Y and Z axes
- X/Y Values - Toggles the X/Y values at each segmentation point
- Segmentation Points - Toggles the display of segmentation points

Spectral Analysis
o The TF charts include the frequency spectra before and after filtering to allow inspection of whether signal frequencies have been filtered. The horizontal axis is calibrated in Hz.
o The vertical axis is calibrated in terms of velocity. This yields a balanced spectrum between low and high frequency components.
o The height of this spectrum at a certain frequency corresponds to the average, absolute velocity observed for that frequency.
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NSHelp: Analysis Charts | Chart Properties and Export

© NeuroScript LLC. All Rights Reserved.

Viewing Numerical Data
This is a common topic for MovAlyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
View Numerical Data from the collected trials.
* Data files Description
* Description of listed parameters

Time functions file
Segmentation file
Extract File
Consistency Error File
Consistent Data File
Discontinuities File
Word Extraction Data File

Data files Description

See Also 

File Extension How to view Notes
Raw data per trial .HWR Right click on the trial > View Numerical Data > View Raw Data The raw data shows the x, y and z position per sampling point in three columns, including the pen-up points. The z-coordinate for the pen-up points will be zero.
Raw data per trial(GripAlyzeR) .FRD Right click on the trial > View Numerical Data > View Raw Data The raw data shows the x (Lower grip), y (Upper grip) and z (Load force) data of the sampling points in three columns.
Processed data per trial .TF Right click on the trial > View Numerical Data > View Processed Data

View Time Function (TF) Data shows the numerical and calibrated time functions and several important parameters.

Segment data per trial .SEG Right click on the trial > View Numerical Data > View Segment Data
Displays the number of segmentation points and the time (sec) at which they occur.

Extracted data per trial .EXT Right click on the trial > View Numerical Data > View Extracted Data...
View Extract File shows the sequence of extracted features for each trial and segment (stroke = 1 segment, for no submovement and = 3 segments with submovement -MovAlyzeR ONLY).

Viewing Trials
NeuroScript MovAlyzeR Help Send comments on this topic.
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Description of listed parameters
Time functions (.TF) file

Segment (.SEG) File

Note: This file contains details of all the trials of the same condition as the trial being viewed. Navigate by trial number.
Consistency errors per trial .ERR Right click on the trial > View Numerical Data > View Consistency Error Data

View Error File shows the reason for a consistency error compared to the target movement. The criteria can be set in the Stroke Description when creating the experiment conditions.
Note: This file contains details for all the trials in the same condition as trial being viewed. Navigate by trial #.

Consistent data per condition .CON Right click on any trial for that condition > View Numerical Data > View Consistency Data
Consistent data file shows the same information as the .EXT feature extraction file only for trials that passed consistency checking.
To view the data corresponding to all the good trials per condition, go to Experiment settings for that experiment > Summarize > Select the subjects and then open the .CON file.
Note: This file will contain details for all the trials in the same condition as trial being viewed. Navigate by trial #.

Discontinuities per trial .DIS Right click on trial > View Numerical Data > View Discontinuities
Discontinuity is a sudden jump in the recorded data. The jump can be in time or distance between samples.

Word Extraction data per condition .WRD Right click on trial from which words were extracted > View Numerical Data > View Word Extraction Data

Word Extraction can be used to automatically extract individual words from longer handwriting paragraphs. The .WRD file has the following format
Word number: Sample numbers in original .HWR file | Reason for being detected as a new word

Parameter Listed Description
sec Time between individual samples in seconds as set by Right-click particular Experiment >Experiment Settings > Processing > Time Function settings
prsmin The minimum pen pressure that determines whether the pen is lifted or the pen is down.
beta Counterclockwise rotation angle in radians (automatic unrotation till vertical upward direction or fixed angle rotation).
x(cm), y(cm) x and y position samples
z Axial pen-to-paper pressure
x, y, z (Newton)(GripAlyzeR) Lower Grip/Upper Grip and Load force values respectively for every sample

V_Spectrum, V_Spectrum-Filtered Frequency spectrum of the velocity before and after filtering using the low-pass filter frequency. The velocity spectrum is used rather than the position spectrum to enhance the visibility of the high-frequency part.
A_Spectrum The acceleration spectrum is the velocity spectrum multiplied by 2*pi*frequency. Therefore the higher frequencies are becoming more visible. The unit is cm/s**2. The amplitude is the average absolute acceleration of the movement pattern.
vx(cm/s), vy(cm/s), vabs(cm/s) x, y and absolute velocity (first time derivative)
ax(cm/s**2), ay(cm/s**2) x and y acceleration (second time derivative)
jx(cm/s**3), jy(cm/s**3), jabs(cm/s**3) x, y and absolute jerk (cm/s**3) (third time derivative)

Parameter Listed Description
# tvyzero Number of segmentation points and the time in sec at which each point occurs.

The time in seconds corresponding to the zero-crossing velocity points.
# tayzero(MovAlyzeR ONLY) Number of submovement points and the time in sec at which each point occurs.

If you do a sub-movement analysis, there is another set of data for the sub-movement points. The sub-movement points correspond to the point after the peak velocity for a segment.
tseg(sec)(GripAlyzeR ONLY) Always shows five segmentation points. The load force as a function of time is segmented into 4 phases or strokes ( 5 segmentation points)

Refer to segmentation procedure for detailed description of the segmentation method
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o NOTE: Submovement analysis option can be chosen by Experiment Settings for an experiment > Processing > Segmentation > Submovement analysis (in MovAlyzeR ONLY).
Extract (.EXT) File
Segment features in each column are (MovAlyzeR and ScriptAlyzeR):
Features per stroke Listed Description
Trial Trial number
Segment Stroke/Segment number within that trial, for analysis without and with submovement respectively. (NOTE: submovement analysis only available in MovAlyzeR)
StartTime Start time relative to the start of the recording

Start time is the start time per stroke, that is the time in seconds from the beginning of the recording (= Sample 0) till the beginning of the stroke (= Beginning segmentation point). StartTime together with Duration of the stroke will tell when exactly the stroke was performed. When setting the start of the recording at any rate, the recording will being when the imperative stimulus begins. StartTime of Stroke 1 is Reaction Time (RT).
Duration Time interval (sec) between the first and last samples in a stroke
StartVerticalPosition Vertical start position relative to the lower edge of the active digitizer area
VerticalSize Vertical vector difference between beginning and end of a stroke
PeakVerticalVelocity Maximum of vertical velocity values
PeakVerticalAcceleration Maximum value of vertical acceleration values
StartHorizontalPosition Horizontal start position relative to the lower edge of the active digitizer area
HorizontalSize Horizontal vector difference between begin and end of a stroke
StraightnessError Straightness error or the normalized standard deviation from a straight line. The estimation is calculated as follows:

~ Estimate the length of the straight line [cm]~ Fit a straight line~ Estimate the (perpendicular) distances of each point to the fitted line [cm]~ Estimate the standard deviation of the distances [cm]~ Divide by the length of the line between begin and end [cm]
FORMULA: StraightErr = (1/length) * sqrt (Sum (y(t) - yd(t))**2 / N)
REFERENCE: Contreras-Vidal, J.L., Teulings, H.L., & Stelmach, G.E. (1998). Elderly subjects are impaired in spatial coordination in fine motor control. Acta Psychologica, 100, 25-35.

Slant Direction from beginning point to endpoint in radians
LoopSurface Surface or the area of the loop enclosed by the previous and present stroke in cm**2. The surface is not normalized. If the the crossing does not occur within the previous stroke, although a loop has been formed, the loop area will be zero.

So, if within an apparent loop a segmentation point is detected, the loop may fail to be detected. If data are insufficiently filtered, extremely small loops are sometimes detected where no loops should be detected. This feature can be verified by measuring (in cm on paper) the long and the short axes of ellipse-like loops. The loop area should be 3.1416 * (0.5 * short axis) * (0.5 * long axis).
RelativeInitialSlant Departure of the direction during the first 80 ms relative to the slant of the entire stroke
RelativeTimeToPeakVerticalVelocity Ratio of the time duration at which the maximum peak velocity occurs (from start time) to the total duration
RelativePenDownDuration Ratio of penup duration to total duration

The value ranges from 0 to 1. 0 corresponds to no pendown and 1 corresponds to all pendown and the values in between show the ratio.
RelativeDurationOfPrimary The ratio of primary submovement duration to the total duration. If total duration is 0, this value is set to 0.0001
RelativeSizeOfPrimary The ratio of the vertical size of the primary submovement to the vertical size of total movement. If total size is 0, this value is set to 0.0001
FrequencyOfSecondary This value is set to 1 if a nonzero secondary submovement is detected in a stroke, otherwise shows a value 0.0001. The average yields the frequency of a secundary submovement per stroke.
AbsoluteSize Absolute size of a stroke/segment calculated from the vertical and horizontal sizes.
AverageAbsoluteVelocity Average absolute velocity across all samples of a stroke or segment
AbsoluteJerk The Root Mean Square (RMS) value of absolute jerk across all samples of a stroke or segment
NormalizedJerk Dysfluency measure, theoretically independent of stroke duration and size and marginally dependent upon stroke shape. Normalization can only be done per stroke and is not meaningful for multiple strokes or for submovements. Normalized Jerk is unitless as it is normalized for stroke duration and size. It is primarily meant for goal-directed movements but can also be applied in repetitive, reciprocal strokes, drawing stroke sequences, or handwriting stroke sequences. Strokes can be segmented by vertical/tangential velocity zero crossings or by absolute velocity minima at points of sharp curvature. Normalized jerk is dependent upon the choice of the low-pass filter. Normalized jerk increases with increasing duration because the limited-bandwidth motor system has more options to generate dysfluencies. A maximally smooth, straight harmonic strokes yield a value of 7.75 (pi**3/2**2) and perfectly circular, 
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Segment features in each column are (GripAlyzeR):

Consistency Error (.ERR) File
The resulting .ERR file shows the following information:

Consistent data (.CON) File
The resulting .con file shows the extracted data (from .EXT file above), only for the trials that are approved as correct (green check beside trial, trials that have failed consistency checking have a red check mark).
The file has only the results of the last approved trial, after the data is processed. Data for all the trials is available only after the summarization is performed on the experiment.

© NeuroScript LLC. All Rights Reserved.

Summarizing Experiment Data

constant-velocity strokes yield a value of 10.96 (pi**3/2**1.5).
PROCEDURE:o Lowpass filter, estimate velocity [cm/s] and jerk [cm/s**3]o Segment into stroke from from near-zero velocity to the next near-zero velocityo Estimate stroke size [cm]o Estimate stroke duration [s]o Squared jerk[cm**2/s**6]o Integrate over time [cm**2/s**5]o Divide by distance**2o Multiply by duration**5o Square root (to reduce dynamic range and to make it proportional with jerk).o Divide by 2 (convention)
FORMULA: sqrt (0.5 * Sum (jerk(t)**2) * duration**5 / length**2).
RELATED MEASURES:o Stroke Durationo Number of acceleration peaks per strokeo Frequency of secondary submovement per strokeo Relative duration of secondary submovemento Relative size of secondary submovement
REFERENCE: Teulings, H.L., Contreras-Vidal, J.L., Stelmach, G.E., and Adler, C.H. (1997). Coordination of fingers, wrist, and arm in Parkinsonian handwriting. Experimental Neurology, 146, 159-170.

Score Relevant only for trials imported from WritAlyzeR, that have not been reprocessed. Shows the running scores obtained per trial during the handwriting practice.
Number of peak acceleration points Number of acceleration peaks both upgoing and downgoing in a stroke, which are above the acceleration level corresponding to "Min. velocity of 1st/last stroke (rel. to abs. peak)", set in experiment settings.
Average pen pressure Average of pen pressure (Z) values over a stroke

Features per stroke Listed Description
Trial Trial Number
Segment Stroke/Segment number within that trial
StartTime Start time of the relative to the start of the recording
Duration Duration per phase (in seconds)
UpperGrip/LowerGripForceSlope Slope of LowerGrip versus UpperGrip forces
UpperLoad/LowerGripForceSlope Slope of LowerGrip versus Load forces
UpperLoad/UpperGripForceSlope Slope of UpperGrip versus Load forces
UpperGrip/LowerGripForceCorrelation Correlation of LowerGrip versus UpperGrip forces
UpperLoad/LowerGripForceCorrelation Correlation of LowerGrip versus Load forces
UpperLoad/UpperGripForceCorrelation Correlation of UpperGrip versus Load forces
UpperGrip/LowerGripForceChangeSlope Correlation of the first time derivatives of LowerGrip versus UpperGrip forces
UpperLoad/LowerGripForceChangeSlope Correlation of the first time derivatives of LowerGrip versus Load forces
UpperLoad/UpperGripForceChangeSlope Correlation of the first time derivatives of UpperGrip versus Load forces
UpperGrip/LowerGripLinearityError Straightness Error of LowerGrip versus UpperGrip forces
UpperLoad/LowerGripForceLinearityError Straightness Error of LowerGrip versus Load forces
UpperLoad/UpperGripForceLinearityError Straightness Error of UpperGrip versus Load forces
Uppergrip/LowerGrip/LoadforceLinearityError Straightness Error in 3D space of LowerGrip, UpperGrip, and Load forces

Parameter Listed Description
Trial Trial number
Error Type Category of error encountered (e.g., target_error)
Description 'OK' if the trial is good

Otherwise, reason for which the trial was discarded.

Summarizing
NeuroScript MovAlyzeR Help Send comments on this topic.
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This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
After data collection and processing of trials, the feature extraction data and information of all groups, subjects is available. Per experiment, the trial data can be compiled in to one output text file (.inc file) by the summarization process.
* How to summarize data
* Viewing Summary of Error Data (.err)
* Viewing Extracted Data (.inc)
* Viewing Summary of Error data (.ers)

How to Summarize data
o Right click particular experiment > Summarize > Summarize.
o A list with all the subjects for that user is displayed. The user can exclude particular subjects from the summarization. 

o After selecting the subjects click 'OK', and another window showing the column headers (names of features extracted) will appear. 
You can choose to exclude unneeded variables in the output file and hence the final statistical analysis. 

o Summarize reruns the consistency testing and writes all the data into an large root path folder\exp\exp.inc file (exp is the experiment code) containing all derived data for valid trials. The data for invalid trials are written in to .err file in the same location.
o When Expriment Conditions or Experiment Settings are changed, the trials need to be reprocessed and resummarized to reflect the changes. The DataNavigator and the progress meter allow monitoring of summarization progress. 

Viewing Summary of Error Data (.err)
o The error output file concatenates all .err files per condition and provides a quick overview of the overall error sources that may lead to adjustment of the Condition_Properties and can be viewed, saved, printed by 
Right-click particular experiment > View Consistency Error data.
All variable data is preceded by group, subject, condition, trial, and stroke codes. 

Viewing Extracted Data (.inc)
The data file for statistical packages concatenates all consistent trial data as calculated by the feature extraction processing module and can be viewed, saved, printed by:
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Right-click particular experiment > Summarize > View Extracted data.
All variable data is preceded by group, subject, condition, trial, stroke codes and the #strokes.
o The .inc file contains the following data: 

~ Three digit IDs of groups, subjects, and conditions in the first three columns, respectively. 
~ Trial number and stroke number have an integer index starting with 1. 
~ Segment number (in the case of submovement analysis, there will be three segments per stroke). 
~ Total number of strokes.
~ Feature extraction data for that trial.

Viewing Summary of Error data (.ers)
This file contains a summary of consistent data per experiment. It contains details such as total number of trials, number of good trials, % error (ratio of bad to good trials) and a description of the most commonly occured error.
This file can be viewed by:
Right-click particular experiment > Summarize > View Consistency Error Summary data.

© NeuroScript LLC. All Rights Reserved.

Norm Database
OverviewSettingsBuilding the norm databases for an existing experiment/testViewing ResultsCalculationsImportant Notes

Overview
MovAlyzeR® enables you to build a norm database per subject and for all subjects [optional] within an experiment. Each time a subject runs an experiment/test, his/her results are compared to particular subject's personal norm and the norm databases over all subjects (ID is ---) and stored in the subject's z-score table with all subaverages.
The z-scores are averaged across strokes and across strokes and conditions per feature. The absolute z-scores are then averaged across all features, yielding eventually a single z-score for an entire subject's test. Those z-scores are shown in the Results window and compared against the critical z score.
For example, the Results window may show:
RESULTS OF TEST: Subject 008 of group G02 of experiment ALC:  Personal Z-score (0.466) and overall Z-score (0.634) - Averages of the absolute Z-scores.
NORM DB: Added subject 008 of group G02 to norm of subject 008.
NORM DB: Added subject 008 of group G02 to overall norm (---).
In addition the z-scores per feature are compiled in the Z-score History. Recent overall z-scores can be viewed in the Z-score Summary.

Settings
Turning Norm DB On/Off
The norm database can be set on/off via right-clicking your experiment >Properties >Running Experiment >Summarize/Analyze >Update norm DB?
As the Norm DB is done during Running Experiments and requires Summarize it is in its settings dialog. By default, updating of the norm databases is ON.

Norm DB
NeuroScript MovAlyzeR Help Send comments on this topic.
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Norm database specific settings
Control how the database is built is via right-clicking your experiment > Properties > Norm DB

Calculate of each subject's Z-score? Default is ON. This feature is used to determine how a subject's test compares to his/her averages. Further settings require that this is turned ON.
Include comparison to all subjects within experiment? An additional norm database is created combining all subjects into the average subject with ID is ---. Each subject's test results are then also compared to the overall averages.
Critical Z-Score. When comparing a subject's test results to the norm databases, the critical z-score is the threshold at which the subject's performance is considered "abnormal" in the view of the z-score summary.
Do not add subjects to DB if personal Z is above critical? If a subject tests compared to the same subject's previous tests has an overall Z-score above the critical Z-score these data will NOT be added to the norm databases.
Subjects can still be added manually via the Rightclick this subject ->Analysis ->Add to Norm DB. To undo an incorrectly added subject, rebuild the entire database via Rightclick your experiment ->Analysis ->Rebuild Norm DB.

Building the Norm Databases for an existing experiment/test
Building the norm databases and viewing results are accessed via the right-click menus of the subjects and experiments in the tree view.
Rightclick your Experiment Rightclick a Subject
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Build the norm databases by right-click your experiment ->Analyze ->Build Norm DB. You will be presented the Summarize dialogs, where you can select group/subjects and features. For example, if you know that the first 5 tests of each subject represents the norm you can build the norm databases from only those 5 tests for each subject. 
NOTE: Uncheck Do not add subject to DB if personal Z is above critical? to ensure all subjects will be included. 
For the remaining subject tests, you can add/compare them manually by Right-clicking the subject ->Analyze ->Add to Norm DB. If that subject's personal Z-score is less than the critical Z-score (when the Do not add option is OFF), their results will be added to the norm databases. 

Viewing Results
You can view the experiment's norm databases (averages), Z-score table per subject and the comparison history.

Viewing the Norm Databases
To view the experiment's norm databases, right0click the experiment and select Analyze -> View Norm DB. Each per-subject norm dtabase will be identified by the subject ID in the Av_Subject column. The global, overall subject averages (if the option is ON), will be represented by ---" in the Av_Subject column. The data in this table is the averages per stroke, per feature.

Viewing a Subjects's Z-Score table
To view a specific subject's Z-score table, right-click the subject and select "Analyze->View Z-Score Table". This table has 3 or 6 sections, depending on whether you have the global averages turned ON, and represents the average Z-scores for all trials of all groups for that subject. The first section is a rollup of all Z-scores of all trials and strokes by feature. The second section is a rollup of the Z-scores per condition/task. The last section is the average Z-scores per stroke, per condition. If overall averaging is ON, the next 3 sections represent the same as the first 3 sections, but represent the Z-scores from comparing to the overall averages from all subjects within the experiment. The overall Z-score for each is represented by "z_All". For more on how the calculations are performed, see below.
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Viewing the Z-Score Summary (History)
To view the comparison history for all or selected subjects within a given date range, right-click the experiment or subject and select "Analyze->View Z-Score Summary". In this dialog, you can specify ALL or a specific subject, the date range of tests to review and whether to "Compare against the global averages". Click the "Generate Report" button after changing the options.
The table contains the subject ("person"), group ("session"), date and time, duration, overall Z-score, status and confidence level of each test. The confidence level 1 – probability level of the z-score rounded down. The "status" is considered "Abnormal" if the overall personal Z-score is above the critical Z-score. See below for more on the calculations.

Calculations
The norm databases are comprised of:
- Average, standard deviation, and number of trials averaged per subject, stroke, condition and feature.- Average, standard deviation, and number of trials averaged across all subjects per stroke, condition and feature (option must be turned ON).
Z-scores are computed using Student's t test for 2 samples of unpaired data with unequal sizes but equal variances. The degrees of freedom of the t statistic is Number of trials used to build the database + Number of trials to be added – 2. Subsequently the normal approximation is based on average is 0 and standard deviation is sqrt(df/df-2). Therefore, more than 4 trials are needed to yield a z score. This can be achieved by having 3 trials per test. Hence the default number of trials in MovAlyzer is set to 3. 
Z-scores across strokes or conditions are averaged. A negative z-score means that a condition by stroke feature in the current subject is less than the current subject's historic average
Z-scores are the averages of the absolute z-score when collapsing across all features.
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Important Notes
- Summarization exclusions (group/subject and features) will affect the construction of the norm databases. If you change the selection of features in summarization after the norm database has been created, you will receive a warning that the norm databases will no longer be updated. You either need to restore the feature selection used to start the database (View database) or rebuild the norm database with the new selection of features.
- Certain features that are summarized might cause the overall Z-score to be exceedingly different from 0. By viewing the Z-score tables, you will be able to identify such features. Those features will be ill behaved in statistical analyses. If you identify features that you would like to deselect, rebuild the norm databases.

NSHelp: Run Experiment Trial Settings | Run Experiment Procedure Settings | Run Experiment Charting Settings | Run Experiment Summ/Analysis

© NeuroScript LLC. All Rights Reserved.

Analysis Charts
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.

* Introduction
* Customizing Axes Label
* Chart Customization
* Actions/Settings

¡ Point Inclusion/Exclusion/Dispersion
¡ Trial grouping
¡ Trial Flagging 
¡ Histogram Scaling
¡ Sorting/Selecting Groups and Conditions
¡ View Identities
¡ Exporting Charts
¡ Viewing Numerical Data
¡ Displaying Strokes

Introduction
Analysis charts is an extremely powerful data analysis tool.
It shows processed trials that have been summarized across trials, conditions, subjects, groups. 
Raw data, averages, and standard deviations can be plotted against any other variable. 
o Right-click a particular experiment > Analysis > Analysis Charts.
o Select scatter plot ( >All trials), with averages and SDs (>All Data), only averages (>Averages), averages of the averages per subject (>Average/Subject). 
o Other charts can be selected.
o Average per subject allows simple statistical comparisons (Actions >View Statistics)
o Select X-axis variable. Non-integer X values are rounded to the nearest integer. Set Action=Offset/Scaling to change the integer granularity. 
o Select Y-axis variable. 
o Select Grouping variable. Each rounded integer level yields a new curve.
o See various Actions to customize
o After applying adjustments view new chart by pressing Refresh.
o right click in chart for viewing, customization, and export options. 
EXAMPLE
~ Select X Axis= Condition
~ Select Y Axis=Duration (s). 
~ Customize axis names by right clicking on them.
~ Select Grouping = Submovement.
~ Select Chart=Individual Trials + Averages +/- Standard Deviations /sqrt(N)
~ Click Refresh

See Also 

Analysis Charts
NeuroScript MovAlyzeR Help Send comments on this topic.
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Customizing Axes Labels
o Right click on top menu bar of the chart on the X- or Y-axis parameter name>Click Customize:

o Each axis item can have one Custom Axes Label. 
o Click in the Custom Axes Label, Type a new label example, 'My condition'.

o click 'Change' and click 'OK'.
o Click 'REFRESH' on the main chart.

Chart Customization
Details on the Chart Properties help page. 

Actions/Settings
This drop-down menu provides the following settings for the chart. These settings are retained per experiment. 
Point Inclusion/Exclusion/Dispersion
o Actions/settings > points > GO
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o Inclusion Criteria: You can choose the points to be plotted for different combinations of group, subject, condition, trial, and stroke for the specific chart.
EXAMPLE: To plot the data for Group 2, Condition 1, Subject 3 and only trial 5, choose the appropriate values in the menus. If you want to see data for all trials, change the option for trial to All. 
NOTE: The order of the groups, conditions, subjects, trials are in the same order as they are included under the specific experiment; Double click and expand the experiment tree to the last to see the orders. 
o Point Dispersion: The points can be dispersed along the x-axis or y-axis by a certain factor with respect to condition, group, etc. 
~ In the given example: In order to clearly view all the data points for each stroke, we can disperse the points by submovements (in this case, dispersion is done by Grouping = stroke) for Select Actions=Points >Go >Check Disperse X-axis by Parameter=Submovement, Strength=0.05>Apply. Then click 'REFRESH'. The following plot is obtained. 

o Point exclusion: You can exclude some x-axis and y-axis values from the chart to have a better curve or to see the effect of removing a condition, group, trial etc. 
EXAMPLE: Select Actions=Points >Go > Check Exclude X-values > Set X-value Exclude value = 3. The data for subject 3 is not plotted.
Trial Grouping
o Used to display the data for particular group of items in a specific color and point type.
o The grouping is specified by the top pull down menu 'Grouping' = Submovement in the chart. This option is not available if you choose 'Grouping' = NONE.
o Choose Actions/Settings = Grouping > click 'Go'.
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o Change the above options for Item of Grouping = 2 (Here the grouping is submovement and there are 3 submovement strokes, hence you will have options 1,2 and 3).
o The colors may be changed as demonstrated in the figure above.
Trial Flagging
o Trials with a selectable index or data item between specific x and y values can be flagged by Actions/Settings=Flagging >Go.
o Check the option 'Use Flagging'.

EXAMPLE. If you want to mark the trials corresponding to conditions 1, 2,3, and 4, which are plotted on the x -axis, with solid dots of pink color, choose the above options.
~ It will yield the following graph:

NOTE: You can change the axis parameter to any value that appears on the plot, e.g. Trial, Duration, Stroke, Condition. Choosing the other options will not show any changes. The trial data points for conditions 1-4 are flagged in a specified color and shape. 
Histogram Scaling
o Histograms of dependent variables are possible using Actions=Sort groups/Conditions >Go. The offset and scaling for the X axis refer to the X axis. 
EXAMPLE: If the X=Duration and duration ranges from 0.2 to 1.5 and you want to cumulate values into bins 1 to 5, then you need to offset the Duration by 0.8 so that all values will exceed 1. Then you want to rescale the data range (=1.3) to 5 by rescaling factor 5/1.3= 3.9. Duration will be mapped onto the range of 1 to 5.99 and will be cumulated into 5 histogram bins.

Sorting/Selecting Groups, Subjects and Conditions
o Groups, Subjects and Conditions can be sorted or selected by Actions=Sort Groups/Conditions/Subjects >Go.
o This is the order of conditions that will be plotted on the x or y axis with numbers 1,2,.....
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View Identities
o The descriptions of Groups, Subjects, Conditions can be shown by Actions=View identities >Go. 

Exporting Charts
o A graph can be exported by Alt Print Screen and Control V. More extended exporting options are available via Right-clicking inside the graph >Export Dialog. 

Viewing Numerical Data
o Raw (=all features of all trials), Xmean (=all feature averages and SDs), Tabular (=feature averages and SDs all Group, Subject, Condition, Trial, Stroke indices), and exported data (=feature averages with X-axis index) can be viewed.
o EXAMPLE: Export a graph to other graphical software by Actions=View Exported Data >Go. This format can be used as ASCII importable into Microcal Origin.
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Displaying Strokes
o In the bottom right of the Analysis chart Check the option 'STROKES'. 
o Choose the stroke number for the x and y-axis making sure that the data on both axes will be available for that particular stroke. Otherwise, a blank chart will be displayed. 
o If a trial consists of a number of strokes and you want to display the data specific to a stroke, this option can be used. 
NOTE: This option can be made use of only while Grouping = Stroke or plotting the strokes on x or y (in this case, there is only one stroke as there is no grouping).
EXAMPLE: Choosing Strokes x-axis = 1 and y axis = 1 yields the following chart:

NSHelp: Charting Trials | Trials | Chart Properties and Export

© NeuroScript LLC. All Rights Reserved.

Export Summarized Data
This feature enables the user to transform data from the summarized .inc file into a format usable by other statistical analyses packages in case of Submovement Analysis. The summarized file has the submovement data in rows rather than columns, which is usually not directly usable by other statistical programs (i.e., without transformation).
This procedure provides compatibility by providing an output text file containing all the feature parameters in one of the two specifiable formats. 
This operation can be performed only after the Analysis Chart is plotted for the experiment (Experiment right click > Analysis > Analysis Chart). See this section for details. 
To Export data, Experiment > right click > Analysis > Export Summarized Data > choose option

See Also 

Export Summarized Data
NeuroScript MovAlyzeR Help Send comments on this topic.

Page 26 of 40Processing

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hhF5C4.htm



Summarized data (.inc file) 
Summarized data (.inc file) is processed to obtain the .Tmp file which is in the following format

(1), (2), (3)...etc indicate the columns of extracted features. 

Transformed data 
Option 1: Group Columns by Parameter

Suffixes 1, 2, 3 for each parameter indicate primary, secondary and total submovements
Option 2: Group Columns by Submovement

Output file (.ana):
After the operation is completed, the program indicates where the output file is stored (in the user root folder).

NSHelp: Import and Export | Summarizing | Processing Summarization | Run Experiment Summ/Analysis

© NeuroScript LLC. All Rights Reserved.

External Processing
Matlab® and other external scripts
MovAlyzeR supports integration with Matlab and other programming environments during processing. This section explains run-time integration (only during processing) of external applications with MovAlyzeR. For information about importing MovAlyzeR output files into other programs like Matlab see Using MovAlyzeR data in Matlab.
Processing of data in MovAlyzeR maybe broken down into the following steps (refer MovAlyzer process flow)
Recording > Time functions > Segmentation > Extraction > Consistency checking > Summarization > Analysis
When external processing of data is enabled, the process flow could be modified to
Time functions > External Script > Segmentation > External Script > Extraction > External Script > Consistency Checking
External Script may mean either a Matlab script or a Batch file that invokes other programs.

Setup external processing
Right click on Experiment name > Properties > Processing > External Apps

Group Subject Condition Trial Segment Submovement (1) StartTime (ST) (2) Duration DT (3) Jerk JK ........etc.
1 1 1 1 1 1 0.1111 1.0000 10000 ....
1 1 1 1 1 2 0.2222 2.0000 20000 ....
1 1 1 1 1 3 0.3333 3.0000 30000

Group SubjectConditionTrial SegmentST1 ST2 ST3 DT1 DT2 DT3 JK1 JK2 JK3 .......etc.
1 1 1 1 1 0.1111 0.2222 0.3333 1.0000 2.0000 3.0000 10000 20000 30000

Group SubjectConditionTrial SegmentST1 DT1 JK1 ..etc ST2 DT2 JK2 ...etc ST3 DT3 JK3 ...etc
1 1 1 1 1 0.1111 1.0000 10000 0.2222 2.0000 20000 0.3333 3.0000 30000

See Also 

External Processing Support
NeuroScript MovAlyzeR Help Send comments on this topic.
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No script
MovAlyzeR processes the data using the default internal algorithms.
Matlab® script
Select this option to modify processed data using Matlab. Input the matlab program you intend to use in the editor and save. Matlab must be installed on the computer in order to use this option. See example below.
Batch file
Create a batch file to execute another executable file or invoke a computing engine. The .bat file offers an easy way to launch external programs.
Example 1: Using Matlab
How to append data columns to MovAlyzeR's .EXT file
This example will show you how to append user-generated parameters to MovAlyzeR's .EXT file. The .EXT file has all the kinematic parameters extracted from the handwriting sample.
Step1: Create and test your matlab program
First we will create a program that reads the  .HWR and .EXT files created by MovAlyzeR. It calculates some simple features from the .HWR file and finally appends them to the .EXT file.
Create your matlab program and test it for logic and functionality. MovAlyzeR has limited debugging features. Hence this step is best done in an external environment like Matlab itself.
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MatExample.m Copy Code

function matexample(hwrfile, extfile)
% Program to calculate spiral features and append to MovAlyzeR .EXT file
% hwrfile - File with raw x, y and z data
% extfile - File with parameters extracted by MovAlyzeR

% Step1: Read .HWR data
xyzdata = dlmread(hwrfile);

% Step2: Use the data to make calculations
% Example calculation1: #samples
NumOfSamples = length(xyzdata);
% Example calculation2: Leftmost X coordinate
LeftXCoord = min(xyzdata(:,1));

% Step3: Read EXT file
fExt = fopen(extfile, 'r');
extheader = fgetl(fExt);
extdata = dlmread(extfile, ' ', 1, 0);
fclose(fExt);
% These are the number of parameters in a default MovAlyzeR .EXT file
numextheader = sum(isspace(extheader)) + 1;
% Parameters to append
header = 'NumOfSamples LeftXCoordinate';
numheader = sum(isspace(header)) + 1;
% Final header
outputheader = [extheader ' ' header];

% Step4: Open output file
tmpfile = strcat(extfile(1:end-4),'.TMP');
fTmp = fopen(tmpfile, 'w');
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Save this file as MatExample.m in the Scripts folder of your experiment. To do this:
In MovAlyzeR, go to Settings > Data Path and Settings > Data Path and copy the {data path}
The Data Path is the location of your experiment folder. The location of the scripts folder is {data path}\scripts
Step 2: Enter your program into MovAlyzer
Right click your Experiment Name > Properties > Processing > External Apps
A dialog may pop-up 'MovAlyzeR will now check to see if Matlab is installed'. Click OK to ensure that MovAlyzeR recognizes the Matlab installation.

Under the EXT: Post-Feature Extraction section select Matlab from the Application drop-down menu. Then click on the edit button to open the Script Editor.
Here we will enter our second Matlab script. This will parse the HWR and EXT filenames and then call MatExample.m

% Step5: Check each line of EXT file data and update accordingly
trialnumber = str2double( strtok( hwrfile( end-5 : end-4 ) ) );
LARGE = 999999;
if ~isempty(extdata) && fTmp ~= -1
% Output header
fprintf(fTmp, '%s\n', outputheader);
for itrial = 1:length(extdata(:,1))
% Case 1: Trial is not relevant
if extdata(itrial, 1) ~= trialnumber
extdata(itrial, numextheader+1:numextheader+numheader) = -LARGE;
end
% Case 2: Trial is relevant
if extdata(itrial, 1) == trialnumber
extdata(itrial, numextheader+1:numextheader+numheader) = [NumOfSamples LeftXCoord];
end
% Output trial data
fprintf(fTmp, '%f ', extdata(itrial, :));
fprintf(fTmp, '\n');
end
% Close output file
fclose(fTmp);
end

% Step6: Delete Extfile, rename TMP file > EXT file
movefile(tmpfile, extfile);
end
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The Browse button in the lower left corner of the Script Editor can be used to open up existing Matlab or BAT files. The existing script that is opened will be saved to the \Scripts folder in the MovAlyzeR user folder.
Notice how the HWR file has been referenced as %HWR%. This is a macro to reference MovAlyzeR files in Matlab scripts in the integration environment. MovAlyzeR will expand the reference and fill in the correct path with the filename so the user does not have to keep track of this.
The following references are legal:
%HWR%  Raw coordinates file
%TF%     Time function file with filtered data
%SEG%   Segmented into strokes
%EXT%   Extracted kinematic features
Save this script as MatDemo.m. Finally select MatDemo.m from the Script dropdown menu and click OK. Now this Matlab script will be run every time a trial is processed.

MatDemo.m Copy Code
clear all;
% Get filenames
hwrfile = '%HWR%';
extfile = '%EXT%';
% Set current working directory
scriptfolder = [hwrfile(1:end-30) 'scripts'];
cd(scriptfolder);
% Run MatExample.m
MatExample(hwrfile, extfile);
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Step 3: Reprocess your trials in MovAlyzeR
This experiment is now set to append the calculated parameters to the EXT file every time a trial is processed or reprocessed.

Similar scripts maybe used to modify the other processing files in MovAlyzeR. See also Using MovAlyzeR data in Matlab
WARNING Once a raw data file (.HWR with x, y, z coordinates) has been modified, the data cannot be retrieved. Please backup all your data before modifying the raw data files.
Example 2 Using BAT files and executable program in C/C++
Program to calculate the maximum width and height of each stroke and append to EXT file
Step 1: Create and test your C program
We will write a program in C to read processed data from the TF file, read the segmentation points from the SEG file, calculate the maximum height and width of each stroke and append the results to the EXT file.

Original EXT file EXT file with appended parameters

Example C program Copy Code
/**********************************************************//* Program to calculate additional kinematic parametersand append them to the EXT file of MovAlyzeR. This programis meant to be used as an external app. It interfaces withMovAlyzeR using liextension.batFeatures appended:StrokeWidth - Max horizontal displacement in strokeStrokeHeight - Max vertical displacement in stroke*//*********************************************************/#include <iostream>#include <string>#include <atlstr.h>#include <fstream>#include <cmath>using namespace std;int readhwr (const char* fIn, double* x, double* y, double* z);int readtf (const char* fIn, double* x, double* y);int readseg (const char* fIn, double* seg, int nseg);inline double SQR (double val){ return (val*val); }#define NSMAX 4096#define NSEGMAX 1000#define MAXVALUE -999999.#define MINVALUE 999999.#define ROUNDUP 0.999#define PRSMIN 0#define MINSEGTIME 0.04int main(int argc, char ** argv){// Show output if debugging is onBOOL DEBUGOUTPUT = ((int)strtod(argv[9], NULL) == 1) ? TRUE : FALSE;if(DEBUGOUTPUT){cout << "******************************************************" << endl;cout << "* Program to evaluate StrokeWidth, StrokeHeight. *" << endl;cout << "* Calculated parameters appended to EXT file. *" << endl;cout << "* (c) NeuroScript LLC *" << endl;cout << "******************************************************" << endl;char* list[10];list[0] = "Program name";list[1] = "File path";list[2] = "Experiment";list[3] = "Group";list[4] = "Subject";list[5] = "Condition";list[6] = "Trial";list[7] = "Hz, Sampling rate";list[8] = "lines/cm, Input device resolution";list[9] = "Debug ON";cout << "Number of input arguments=" << argc << endl;for( int i = 0; i < argc ; i++)
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cout << argv[i] << " " << list[i] << endl;}if (argc < 9){cout << "Not enough input parameters. Exiting..." << endl;cout << "Press ENTER to exit...";cin.get();exit(0);}/*****************************************//* Parse input arguments from batch file *//*****************************************/string root(argv[1]);string exp (argv[2]);string grp (argv[3]);string sub (argv[4]);string con (argv[5]);string trl (argv[6]);int trial = (int)strtod(argv[6],NULL);double sec = strtod(argv[7], NULL);// Convert sampling rate to secondssec = (sec != 0)? 1/sec : 0;double cm = strtod(argv[8], NULL);// Construct filenamesstring hwrfile = root + "\\" + exp + grp + sub + con + trl + ".HWR";string tffile = root + "\\" + exp + grp + sub + con + trl + ".TF";string segfile = root + "\\" + exp + grp + sub + con + trl + ".SEG";string extfile = root + "\\" + exp + grp + sub + con + ".EXT";string tmpfile = root + "\\" + exp + grp + sub + con + ".TMP";// Constantsdouble maxx = MAXVALUE;double minx = MINVALUE;double maxy = MAXVALUE;double miny = MINVALUE;// Other variablesint trialinfile;int i, j, spaces = 0;int spacesinheader;string line, temp;BOOL EXISTS;// Parameters that will be calculatedstring header("StrokeWidth StrokeHeight");spacesinheader = 0;for ( i = (int)header.size()-1 ; i > 0 ; i-- ){spacesinheader += (header.at(i) == ' ');}// Output filesifstream fExt(extfile.c_str());ofstream fTmp(tmpfile.c_str());// Allocate arrays for coordinate datadouble* x = new double [NSMAX];double* y = new double [NSMAX];memset ( x, 0, NSMAX * sizeof(double) );memset ( y, 0, NSMAX * sizeof(double) );int nsam = 0;// Find number of segments to allocate memory forifstream fSeg(segfile.c_str());int nseg = 0;if (fSeg.is_open()){// Segment headergetline(fSeg, line);nseg = (int)strtod(line.c_str(), NULL);}fSeg.close();nseg = min(nseg, NSEGMAX);// Segment arraydouble* seg = new double [nseg];memset (seg, 0, nseg * sizeof(double));int iseg, segbegin, segend;// Extracted parameters// These will be appended to the existing .EXT filedouble *strokewidth = new double [nseg];double *strokeheight = new double [nseg];memset (strokewidth, 0, nseg * sizeof(double));memset (strokeheight, 0, nseg * sizeof(double));/********************//* Read data points *//********************/nsam = readtf (tffile.c_str(), x, y);nseg = readseg (segfile.c_str(), seg, nseg );// Convert seg points in seconds to samplesfor ( iseg = 0 ; iseg < nseg ; iseg++){seg [iseg] /= sec;}/*************************//* Process every segment *//*************************/for ( iseg = 0; iseg < nseg - 1 ; iseg++ ){maxx = MAXVALUE;minx = MINVALUE;maxy = MAXVALUE;miny = MINVALUE;segbegin = (int)(seg[iseg] + ROUNDUP);segend = (int)(seg[iseg+1] + ROUNDUP);for ( j = segbegin ; j < segend ; j++ ){/* Stroke width */if ( x[j] > maxx )maxx = x[j];if ( x[j] < minx )minx = x[j];/* Stroke height */
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if ( y[j] > maxy )maxy = y[j];if ( y[j] < miny )miny = y[j];}strokewidth[iseg] = maxx - minx;strokeheight[iseg] = maxy - miny;}// Read data from EXT file line by line// Write to TEMP file after appending parameters calculated in this file// Copy the entire TEMP file back to EXT fileif ( fExt.is_open() && fTmp.is_open() && nseg > 0){// Read EXT headergetline( fExt, line);if (line.empty()){cout << "The EXT file is empty. Press Enter to Exit..." << endl;cin.get();goto Cleanup;}else if (line.compare(line.size()-header.size(), line.size()-1, header) == 0){fTmp << line << endl;EXISTS = TRUE;}else{fTmp << line << " " << header << endl;EXISTS = FALSE;}iseg = 0;// Output line by linewhile ( !getline(fExt, line).eof() ){// Read trial number at beginning of linetrialinfile = (int)strtod(line.c_str(), NULL);// Check if parameters already existspaces = 0;for ( i = (int)line.size()-1 ; i > 0 ; i-- ){spaces += (line.at(i) == ' ');}EXISTS = (spaces > 29) ? TRUE : FALSE;// Case 1: Trial is not relevant and has no previous params fieldif (trialinfile != trial && !EXISTS){fTmp << line;for (i = 0; i < spacesinheader+1 ; i++)fTmp << " " << MAXVALUE ;fTmp << endl;}// Case 2: Trial is not relevant and has previous params fieldif (trialinfile != trial && EXISTS){fTmp << line << endl;}// Case 3: Trial is relevant and has no previous params fieldif (trialinfile == trial && !EXISTS){if (nseg > 1){fTmp << line << " " << strokewidth[ iseg % (nseg - 1)] <<" " << strokeheight[ iseg % (nseg - 1)] << endl;}else{fTmp << line;for (i = 0; i < spacesinheader+1 ; i++)fTmp << " " << MAXVALUE ;fTmp << endl;}iseg++;}// Case 4: Trial is relevant and has previous params fieldif (trialinfile == trial && EXISTS){spaces = 0;// Match number of spaces in header to number of spaces in current line that was read, i has the required locationfor ( i = (int)line.size()-1 ; i > 0 ; i-- ){spaces += (line.at(i) == ' ');if (spaces == spacesinheader+1)break;}line = line.substr(0,i);if (nseg > 1){fTmp << line << " " << strokewidth[ iseg % (nseg - 1)] <<" " << strokeheight[ iseg % (nseg - 1)] << endl;}else{fTmp << line;for (i = 0; i < spacesinheader+1 ; i++)fTmp << " " << MAXVALUE ;fTmp << endl;}iseg++;}}fExt.close();fTmp.close();}/* The contents of EXT file were copied to TMP file after appending the parameters.Delete the EXT file and rename TMP file to EXT file*/
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C-function to read raw x, y and z points from MovAlyzeR generated HWR file

if (DEBUGOUTPUT)cout << "Trial " << trial << ": ";if ( remove( extfile.c_str() ) == 0 ){if ( rename( tmpfile.c_str(), extfile.c_str() ) == 0 ){if (DEBUGOUTPUT)cout << argv[0] << " script successful!" << endl;}else{cout << "Temporary file rename unsuccessful. Check if you have administrative privileges in the data folder:" << argv[1] << endl;cout << "Press ENTER to exit...";cin.get();}}else{cout << "EXT file deletion unsuccessful. Either EXT file does not exist or you do not have administrative privileges in the data folder:" << argv[1]<< endl;cout << "Press ENTER to exit...";cin.get();}if (DEBUGOUTPUT)cin.get();Cleanup:if (x) delete [] x;if (y) delete [] y;if (seg) delete [] seg;if (strokewidth) delete [] strokewidth;if (strokeheight) delete [] strokeheight;}
/***********************************/int readtf (const char* fIn, double* x, double* y)/***********************************//* Read time points in from SEG file */{ifstream fTF(fIn);int nsamples = 0, is = 0;string line;char * next;if ( fTF.is_open()){getline(fTF, line);getline(fTF, line);getline(fTF, line);getline(fTF, line);getline(fTF, line);getline(fTF, line);// X data headergetline(fTF, line);nsamples = (int)strtod(line.c_str(), NULL);nsamples = min(nsamples, NSMAX);// X datagetline(fTF, line);for (is = 0; is < nsamples; is++){x [is] = strtod(line.c_str(), &next);line = next;}// Y data headergetline(fTF, line);nsamples = (int)strtod(line.c_str(), NULL);nsamples = min(nsamples, NSMAX);// Y datagetline(fTF, line);for (is = 0; is < nsamples; is++){y [is] = strtod(line.c_str(), &next);line = next;}}fTF.close();return nsamples;}/***********************************/int readseg (const char* fIn, double* seg, int nsegalloc)/***********************************//* Read segmentation points in from SEG file*/{ifstream fSeg(fIn);int nsegpoints = 0, is = 0;string line;char * next;if (fSeg.is_open()){// Segment headergetline(fSeg, line);nsegpoints = (int)strtod(line.c_str(), NULL);nsegpoints = min(nsegpoints, nsegalloc);// Segment datagetline(fSeg, line);for (is = 0; is < nsegpoints; is++){seg[is] = strtod(line.c_str(), &next);line = next;}}fSeg.close();return nsegpoints;}
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C-function to read processed x, y and z points from MovAlyzeR generated TF file

ReadHWR Copy Code
int readhwr (const char* fIn, double* x, double* y, double* z)/* Read points in from HWR data filefIn: Path of HWR file to read data fromx: Array for x-coordinate datay: Array for y-coordinate dataz: Array for z-coordinate dataNSMAX: Maximum number of samples to read. Default value = 4096.*/{ FILE* fp;  fopen_s(&fp, fIn, "r");int nsamples = 0;if (fp!=NULL)  { while (fscanf_s(fp,"%lf %lf %lf",&x[nsamples],&y[nsamples],&z[nsamples]) != EOF && nsamples < NSMAX)     {         nsamples++;     }     fclose(fp);  }return nsamples;}

ReadTF Copy Code
int readtf (const char* fIn, double* x, double* y)
/* Read time points in from SEG file */
/*
fIn: Path of TF file to read processed data from
x: Array to save processed x coordinates
y: Array to save processed y coordinates
*/
{

 ifstream fTF(fIn);
 int nsamples = 0, is = 0;
 string line;
 char * next;
 if ( fTF.is_open())
 {

 getline(fTF, line);
 getline(fTF, line);
 getline(fTF, line);
 getline(fTF, line);
 getline(fTF, line);
 getline(fTF, line);

// X data header
getline(fTF, line);
nsamples = (int)strtod(line.c_str(), NULL);
nsamples = min(nsamples, NSMAX);
// X data
getline(fTF, line);
for (is = 0; is < nsamples; is++)
{
x [is] = strtod(line.c_str(), &next);
line = next;
}
// Y data header
getline(fTF, line);
nsamples = (int)strtod(line.c_str(), NULL);
nsamples = min(nsamples, NSMAX);
// Y data
getline(fTF, line);
for (is = 0; is < nsamples; is++)
{
y [is] = strtod(line.c_str(), &next);
line = next;
}
}
fTF.close();
return nsamples;
}
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C-function to read segmentation points from MovAlyzeR generated SEG file

Step 2: Compile program into an executable file and put in \Scripts folder
Copy the executable file into the Scripts folder of the MovAlyzeR User you intend to use.
MovAlyzeR user folder: Open MovAlyzeR > Settings > Data Path and Settings > Path and Settings > Data Path
Scripts folder: UserFolder\scripts
Step 3: Create BAT file to launch executable
A batch file (file extension: .BAT)is a collection of MS-DOS commands and is used to execute these commands one after the other. Any command that can be executed in the DOS prompt of a windows computer can be used in a BATCH file.
To enter the BAT file, do the following
1. Right-click on the Experiment name > Properties > Processing > External Apps
2. Under the EXT: Post Feature Extraction section, click on the Application drop down menu and select BATCH.
3. Click on the EDIT button to the right to create a new batch file.
4. Enter the following batch program and save it as liextension.bat.
5. Select liextension.bat from the Script drop down menu and click OK.

ReadSeg Copy Code
int readseg (const char* fIn, double* seg, int nsegalloc)
/* Read segmentation points in from SEG file */
/*
fIn: Path of SEG file to read segmentation points from
seg: Array to save segmentation data
nsegalloc: Maximum allowed size of segment array
{
    ifstream fSeg(fIn);

 int nsegpoints = 0, is = 0;
    string line;

 char * next;
 if (fSeg.is_open())

    {
 // Segment header

        getline(fSeg, line);
        nsegpoints = (int)strtod(line.c_str(), NULL);
        nsegpoints = min(nsegpoints, nsegalloc);

 // Segment data
        getline(fSeg, line);

 for (is = 0; is < nsegpoints; is++)
        {
            seg[is] = strtod(line.c_str(), &next);
            line = next;
        }
    }
    fSeg.close();

 return nsegpoints;
}

extension.bat Copy Code
@echo off
rem Batch procedure to calculaterem -> Horizontal Stroke Sizerem -> Vertical Stroke Sizerem in MovAlyzeR.rem Implemented using C in liextension.exerem (c) 2009 NeuroScript LLC
rem Parameters obtained from MovAlyzeRset rootpath=%1set experiment=%2set group=%3set subject=%4set condition=%5set trialnumber=%6set samplingrate=%7set deviceresolution=%8
Rem Set Debug messages ON (1) or OFF (0)set debug=1
rem Device name(drive letter) of the file pathset devicename=%rootpath:~1,2%
rem Change active directory to c drive, d drive etc
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BAT files may be used to launch any other executable file or programming environment. Calls to the .BAT files are also parameterized.
%1  root path
%2  experiment code
%3  group code
%4  subject code
%5  condition code
%6  trial number
%7  sampling rate
%8  device resolution
Step 4: Reprocess your trials
Reprocess the trials of the experiment and the additional features will be automatically appended to the .EXT file.

Other examples
The following C program opens an existing TF file, reads in the data line by line and deletes the first and last 10 points and then writes the data back to the TF file. The modified TF data can then be used by the segmentation and extraction modules. An appropriate BAT file maybe constructed as described above to use this program.

%devicename%
rem Extract path to /Scripts folder from rootpathset scriptdir=%rootpath:~1,-13%\\scriptscd "%scriptdir%"
rem Run External Appliextension.exe %rootpath% %experiment% %group% %subject% %condition% %trialnumber% %samplingrate% %deviceresolution% %debug%

Modify TF file Copy Code

/* Modify TF file data in MovAlyzeR.(c) NeuroScript LLC*/#include <iostream>#include <string>#include <atlstr.h>#include <fstream>#include <cmath>using namespace std;#define NSMAX 4096#define MISSING -9999int main(int argc, char ** argv){if (argc < 10){cout << "Not enough input parameters. Valid format to launch the program is " << endl;cout << "tfmod.exe {filepath} {experiment} {group} {subject} {condition} {trial} {sampling rate, Hz}";cout << " {device resolution, lines/cm} {debugmode, 0 or 1}." << endl;cout << "Press Enter to Exit..." << endl;exit(0);}char* list[10];bool debug;list[0] = "Program name";list[1] = "File path";list[2] = "Experiment";list[3] = "Group";list[4] = "Subject";list[5] = "Condition";list[6] = "Trial";list[7] = "Hz, Sampling rate";list[8] = "lines/cm, Input device resolution";list[9] = "Debug";debug = (int)strtod(argv[9], NULL) != 0;if (debug){cout << "*******************************" << endl;cout << "* Modify TF file of MovAlyzeR *" << endl;cout << "* (c) NeuroScript LLC *" << endl;cout << "*******************************" << endl;cout << "Number of input arguments=" << argc << endl;for( int i = 0; i < argc ; i++)cout << argv[i] << " " << list[i] << endl;}// Parse input arguments from batch filestring root(argv[1]);string exp (argv[2]);string grp (argv[3]);string sub (argv[4]);string con (argv[5]);string trl (argv[6]);int trial = (int)strtod(argv[6],NULL);double sec = strtod(argv[7], NULL);double cm = strtod(argv[8], NULL);
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string tffile = root + "\\" + exp + grp + sub + con + trl + ".TF" ;string tmpfile = root + "\\" + exp + grp + sub + con + trl + ".TMP";// Output filesifstream fTF(tffile.c_str());ofstream fTmp(tmpfile.c_str());/*****************************//* Read filtered data in and *//* write out to temp file *//*****************************/if ( fTF.is_open() && fTmp.is_open()){int is, isbegin, isend;int nsamples;string lineheader, linedata;char * headername;/* TF file parameters:DON'T UPDATE-- sec, prsmin, beta,x(cm), y(cm), zDON'T UPDATE-- Spectrum, V_Spectrum, A_Spectrum, Spectrum_Filtered, V_Spectrum_Filtered, A_Spectrum_Filteredvx(cm/s), vy(cm/s), vabs(cm/s), ax(cm/s**2), ay(cm/s**2), aabs(cm/s**2), jx(cm/s**3), jy(cm/s**3), jabs(cm/s**3)*/int nparam = 21; // Number of params in TF fileint nsamdel = 10; // Number of points to delete from processed x, y and z arraysint update[21] = {0, 0, 0,1, 1, 1,0, 0, 0, 0, 0, 0,1, 1, 1, 1, 1, 1, 1, 1, 1}; // Parameters to updatefor (int iparam = 0; iparam < nparam; iparam++){// Read the headergetline(fTF, lineheader);getline(fTF, linedata);if (!update[iparam]){// Write header and datafTmp << lineheader << endl;fTmp << linedata << endl;}else{// #data pointsnsamples = (int)strtod(lineheader.c_str(), &headername);for ( isbegin = 0, is = 0; isbegin < nsamdel && is < nsamples ; is++){isbegin += (linedata.at(is) == ' ');}isbegin = is;for ( isend = 0, is = linedata.size()-1; isend < nsamdel && is > 0 ; is--){isend += (linedata.at(is) == ' ');}isend = is;// Write header and datafTmp << nsamples-(2*nsamdel) << " " << headername << endl;fTmp << linedata.substr(isbegin, isend - isbegin + 1 ) << endl;}}}/**********//* Output *//**********/// Read data from EXT file line by line// Write to TEMP file after appending parameters calculated in this file// Copy the entire TEMP file back to EXT fileif ( fTF.is_open() && fTmp.is_open() ){fTF.close();fTmp.close();}if (debug)cout << "Trial " << trial << ": ";if ( remove( tffile.c_str() ) == 0 ){if ( rename( tmpfile.c_str(), tffile.c_str() ) == 0 ){if (debug)cout << argv[0] << " script successful!" << endl;}else{cout << "Temporary file rename unsuccessful. Check if you have administrative privileges on the data folder:" << argv[1] <<endl;cout << "Press ENTER to exit...";cin.get();}}else{cout << "TF file deletion unsuccessful. Either TF file does not exist or you do not have administrative privileges in the 
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Points to remember when using external applications for processing
1. The intermediate files are still processed by MovAlyzeR's internal algorithms before they are overwritten by the external program. Care must be taken to maintain the format and conventions of the original files for stable operation of MovAlyzeR.
2. Matlab or the Matlab runtime component are not included with MovAlyzeR. It is the responsibility of the user to install and configure all 3rd party software.
3. The integration environment offers limited tools to debug the scripts. It is best to have a working script outside the MovAlyzeR environment before any integration is attempted.
4. All Matlab and batch scripts used in the processing of a MovAlyzeR experiment are stored in the UserDirectory\Scripts folder and are included in an exported experiment file.
Matlab® is a registered trademark of The MathWorksTM
Disclaimer: All the C code is shown here only for demonstrative purposes and no other claims of suitability to any other purpose are made.

NSHelp: Condition Consistency Checking | Experiment Properties | Processing Time functions | Processing Segmentation Settings | Processing Extraction Settings | Word Extraction | Processing Summarization | Stroke Description

© NeuroScript LLC. All Rights Reserved.

data folder:" << argv[1] << endl;cout << "Press ENTER to exit...";cin.get();}return 0;}

See Also 
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Client/Server Technology
(Separate Purchase Required)
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
* Installation
* Operation

* Running the Server
* Shutting Down Server
* Managing Server
* Accessing Server
* Connecting to Server

* Uploading to Server
* Downloading from Server
* Legal

Installation (only by someone with administrator privileges)
When installing MovAlyzeR, ensure that you choose the option to include the client-server component. If you already have MovAlyzeR installed, rerun the installer and choose that option. The location of the server is in the "c-treeServer" folder within the MovAlyzeR folder. You will be provided with an activation key after you have purchased your licenses.
To input the key, click Start > Programs > NeuroScript > MovAlyzeR > "Activate c-tree Server".
^Top

Operation
Running the Server
The c-tree Server must be running for clients to connect to it. To start the server, click Start > Programs > NeuroScript > MovAlyzeR > "c-tree Server". By default, the name of the server is "NEUROSCRIPT" (all caps). To change this, you can edit the "ctsrvr.cfg" file in the "c-treeServer" folder. The first two lines in the configuration file are:
;FairCom server nameSERVER_NAME NEUROSCRIPT
If you desire, you can simply change the "NEUROSCRIPT" to whatever you prefer. The server name IS case sensitive. NOTE: Edit this file at your own risk. We cannot take responsibility for user error.
^Top
Shutting Down the Server
From the server, click the Control > Shutdown menu item. An administrator must enter the username and password of a user with appropriate privileges (see below). The default administrator username and password (after the first install) is "ADMIN" and "ADMIN".
^Top
Managing the Server

Client-Server
NeuroScript MovAlyzeR Help Send comments on this topic.
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You will need to setup users in order to use the server. Click Start > Programs > NeuroScript > MovAlyzeR > "c-tree Server Admin". The admin utility is a console application (i.e., no graphical user interface). It is menu driven and more-or-less self-explanatory. For the default setup, the following is the procedure to add a group and a user.
When you first open the admin utility:

l Enter the administrator username - Default: "ADMIN"
l Enter the administrator password (case sensitive) - Default: "ADMIN"
l Simply hit ENTER to skip the "Optional File Password"
l Enter the server name (case sensitive)- Default: "NEUROSCRIPT"

To add a group:
l Enter 2 for "Group Definitions"
l Enter 1 to "Add New Group"
l Enter a unique ID for the group
l Enter a description for the group
l Use the default options for the remaining items (refer to Faircom documentation for explanations)

To add a user:
l If you just did the above, enter "q" to return to the main menu
l Enter 1 for "User Operations"
l Enter 1 for "Add New User"
l Enter a unique ID for the user
l Enter a description for the user
l Use the default option for the next two items
l Enter a password for the user (case-sensitive)
l Re-enter the password for confirmation
l Enter the desired group ID for the user
l You can continue to add the user to additional groups or just hit "ENTER" to complete
l Enter the user's beginning access date ("ENTER" for immediate)
l Enter the user's last available access date ("ENTER" for no expiration)
l Enter the user's limit of failed login attempts ("ENTER" for default, "-1" to disable)

^Top
Accessing the Server
MovAlyzeR currently provides two cooperative features to utilize the client-server technology. Users can upload their experiments to the shared server, and users can download experiments from the server to their client. Available options are:
l Upload/download a category, element, stimulus, subject, group, condition or experiment
l Upload/download a stimulus or experiment, also uploading each of the sub-components (groups, conditions, etc)
l Upload/download all items of a folder (group folder, subject folder, etc.)
l Upload/download all items of the stimulus or experiment folder, including the sub-components of each stimulus or experiment
l Upload/download the master questionnaire

^Top
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Connecting
The first time (each execution) after a user attempts to use a client-server feature, MovAlyzeR will prompt the user to enter the server's name, the username, and a password. The server name and password are case-sensitive. The server name (default is "NEUROSCRIPT") will change depending on where it is installed. If it is on the same computer as the user, the user would simply enter "NEUROSCRIPT". If the server is on a network on a computer named "COMPUTER_4" (for example), the user would enter "NEUROSCRIPT@COMPUTER_4". Servers residing on a publicly visible internet location would replace the computer name with the IP or domain name of that machine. For example, "NEUROSCRIPT@111.11.222.22" or "NEUROSCRIPT@server.mydomain.com".

^Top

Uploading to the Server
To upload data, you must open the desired user with the data you want to upload.
Right-click on the item you want uploaded (under the corresponding folder, not under experiment) and click the "Upload..." menu item.
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You will be asked whether you want to overwrite any existing items. Clicking yes would overwrite items that are already on the server and clicking no would not overwrite the existing items, but other items are written. If it is an experiment or a stimulus, you will also be asked whether you want to upload the sub-components as well.
Experiment > upload.., would include all of its groups, subjects, conditions, and all of the stimuli, elements, and categories associated with each condition.
If you right-click on an item's parent folder, you have an option to choose "Upload All...". For example, if you right-click on the "Experiments" folder and click on "Upload All...", you can upload each and every experiment for that user. You will again be prompted to overwrite and include all sub-components (where appropriate).
^Top

Downloading from the Server
To download data, you must open the built-in "UUU" user. This is the user that represents all of the data on your server. The procedure to download an item (or items) is the same as uploading...with one additional step.
When you select "Download..." from an item's menu, you will be presented a dialog from which to choose the specific user to download to (with options to overwrite and include sub-components). NOTE: Users "UUU" and "UU1" (the server and example users) are not available 
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to select.

To upload/download the master questionnaire click the appropriate menu item under "Settings" in the main menu.
CAUTION: We are not responsible for users overwriting data inappropriately. We do not have a built-in user password-protection system (perhaps in a future release). Therefore, please use caution when you choose to overwrite. It is always best to ensure you backup your data regularly.
^Top

Legal
Portions copyright 1992-2004 FairCom Corporation. "FairCom" and "c-tree Plus" are trademarks of FairCom Corporation and are registered in the United States and other countries. All Rights Reserved.

© NeuroScript LLC. All Rights Reserved.
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Backup
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Complete Backup (Per user)
o A complete back up can be done by: Main toolbar, File > Complete Back up. 
o All the experiment files (conditions, stimuli..etc) and the trials for that user are written in the backup directory previously defined for the user. The old files are overwritten. New files are appended. For example, if new subjects and trials were added to an experiment since last backup, the corresponding data is appended during a new backup. 
o If you need to find the location of the backup directory that you assigned earlier while creating the user, go to file > users > select user > Properties symbol > Settings. 
Backup Database/Restore database (Per user)
A backup of the database can be done by File > Backup Database
o This option backsup all the experiment files without the trials in the backup directory.
o File > Restore database is used to retrieve the experiment files from an older version of the experiment. 
NOTE: It is recommended not to use the same physical disk as the backup root directory even if it has more partitions, but instead designate a physically different disk.

Backup History

The Backup History dialog shows you each instance that a backup was done and includes the following information:
l The user that initiated the backup
l The date of the backup
l The location of the backup
l The experiment that was backed up

Backups can consist of either or both recorded data files and the database.
To restore a previous backup, select it in the list and click the "Restore" button. If you want the database to also be restored, check the appropriate check box "Restore database".

Backup
NeuroScript MovAlyzeR Help Send comments on this topic.
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Click the "Clear History" button to clear out the backup history. WARNING: This is an undoable action.

Also, when you close the MovAlyzeR, the program will ask whether you want to backup the database files.

© NeuroScript LLC. All Rights Reserved.

<Previous
Example Experiments (from default user UU1)
This is a common topic for MovALyzeR, GripAlyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
Experiment E01 (Simulated Loops in Left and Right Handers)
Experiment EX1 (Hicks' Law)
Experiment EX2 (Stimulus Response Compatibility)
Experiment EX3 (Fitts' Law -- Speed-Accuracy Trade-off)
Experiment EX9 (Simulated Signals)
Experiment IMG (Mirror Image Tracing)
Experiment LAY (Menu Layout)
Experiment PH2 (Caligiuri Handwriting Test for EPS)
Experiment WRD (Word Extraction)
Experiment ALC (Alcohol Test)

Experiment E01 (Simulated Loops)
The experiment consists of making four loops of equal size for every trial.
For Subjects S01 and S02, the data has been generated using the data generate wizard, rather than recording real data. For Subject SSS, data was recorded.
Input device settings:
MovAlyzeR > Settings > Select input device > tablet.
In Input device settings: Resolution = 0.001, Minimum pen pressure = 1, Sampling rate = 0.01.
Procedure used to generate data for E01:
The following procedure was used to generate data for Experiment E01:

Example Experiments
NeuroScript MovAlyzeR Help Send comments on this topic.
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For Subject S01
1) Select File > Data Generate wizard.. > Specify data generation settings > click settings
2) Choose Predefined = custom, the following window appears:

3) Set the following specifications and click ok.
Noise Settings

Noise amplitude (cm) = 0.05
General Settings

Start Time = 0.1Number of strokes = 8.4trail time = 0.1
X Movement componentposition start = 0.3size = 1start phase = 60velocity = 2
Y Movement componentposition start = 0.3size = 1start phase = 0

Stroke Settings
Stroke duration = 0.22 s, stroke size = 2 cm (i.e., X component = 1.414 cm, Y component = 1.414 cm)

4) Click Next > choose experiment = E01 > condition = C01 group = G01 > subject = S01 > By clicking next, the first trial of the subject S01 for condition C01 is created.
5) Repeat steps 1-4 from the first screen, without changing any settings (clicking next instead 
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of finish retains all the previous settings) 8 times. Thus, 8 trials are generated with the above specifications.
6) Repeat steps 1-5 by changing the condition each time (condition = C02 and condition = C03) and the stroke settings:
Cond C02 : Stroke duration = 0.22 s, stroke size = 2.1 cm (i.e., X component = 1.449 cm, Y component = 1.449 cm)
Cond C03 : Stroke duration = 0.2 s, stroke size = 2 cm (i.e., X component = 1.414 cm, Y component = 1.414 cm)
NOTE: The data for the 8 trials per condition are slightly different from each other, even though the parameters are the same. This is because of the added noise.
For Subject S02
Repeat the same procedure as for Subject S01, changing only noise amplitude to 0.1, for all the steps.
For Subject SSS
Run experiment with the three conditions. Stimuli LOP and LIN which contain two lines between which the loops are used.

Experiment EX1 (Hick's Law -- Reaction Time Increases with #Choices)
Reaction Time (RT) is the interval between the presentation of an unanticipated stimulus and the beginning of the response.
~ Nature of the stimulus
~ Type of movement 
Number of Stimulus-Response Alternatives:
~ One of the most important factors influencing RT is the number of possible stimuli (choices)
~ Choice RT: subject identifies the stimulus and then chooses a response that corresponds to the stimulus
~ Simple RT: RT when there is only one stimulus and one response (shortest possible RT)
Hick’s Law: Longer reaction times result from greater number of stimulus-response (S-R) alternatives. Hick’s Law (Hick, 1952) states that RT increases by a nearly equal amount each time the number of alternatives is doubled (1 to 2 to 4 to 8, etc.). More formally, Hick’s Law is expressed as:

RT = a + b * log2(N)
N = Number of alternatives
a = Simple RT (when there is one response choice – no event uncertainty)
b = Increase in RT each time the number of alternatives is doubled

Experiment EX2 (Stimulus Response Compatibility)
There is a “natural” connection between the stimulus and the response
RT is faster with more compatible S-R pairs
Implementation In MovAlyzeR. The pen is moved to a home position. Two circles appear (width 1 cm) at an equal distance (8 cm) from the home position. Between the home position and the two target circles the precue "Compatible" or "Incompatible" appears  for 0.5 s. After a fixed period the home position turns red or green. Simultaneously, one of the circles turns 
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red and the the other one turns green. The subject has been instructed to move as quickly as possible to the target that has the same color if the precue was "Compatible" or to the target with a different color than the home position if the precue was "Incompatible".
The period between the time that the circle turns red or green and adn the movement start time is the reaction time. Reaction-time increase in the incompatible condition expresses the extra “cost” to process and program an incompatible target.

Experiment EX3 (Fitts' Law -- Speed-Accuracy Trade-off)
The time to reach a target depends on how the accuracy. Therefore, there is a “trade-off” between speed and accuracy when performing a goal-directed movement.
Fitts’ Law: Fitts’ Law describes the relationship between the duration of the movement and the accuracy:

MT = a + b * log2(2A/W)
MT = Movement time 

A = Amplitude of the movement
W = Width of the target
Index of Difficulty (ID), defined as ID = log2(2A/W). Therefore, Fitts’ Law says that movement time 
increases linearly with ID: MT = a + b * ID

Experiment EX9 (Simulated Signals)
The Data Generate Wizard in MovAlyzeR is used to create a wide array of signals with known underlying features. Please refer to EX9 experiment-property attachment to get information on how to generate these signals.

Experiment IMG (Mirror Image Tracing)
The mirror-image tracing study requires that the participant use the mouse to trace the star shown when running this experiment, first with one hand, and then with the other hand. Because mirror image tracing is primarily a visual-spatial task, and each half of the brain controls the contralateral side of the body, it is expected that right-handed participants will take longer to complete the task with their right hand (controlled by the left hemisphere) compared to their left hand ( controlled by the right hemisphere). Please note that this prediction may not necessarily hold for left-handed participants, because their brains are more bilateral.

Experiment LAY (Menu Layout)
You can establish the efficiency of aiming at one item in a 16-option menu. The menu has 2 different layouts: 16 items under each other or 4 x 4 items in a square. It is a 16 choice-reaction time experiment. You can also establish whether pen movements are more efficient than mouse movements. Different menu aiming efficiencies can be expected by altering the mouse setting in the Control Panel.

Experiment PH2 (Caligiuri's Handwriting Test for EPS)
Extrapyramidal side effects due to schizophrenia medication measurements were collected in 3 major US mental hospitals using this test battery consisting of simple (overlaying circles and cursive l sequences) and more complex movement patterns (cursive llee patterns and a sentence "Today is a nice day") at sizes 1, 2, and 4 cm, with dominant and non-dominant hands, at normal and maximal speeds. The test was intentionally simple. Subjects wrote with a non-inking pen on a template underlaying the tablet cover. The template showed guidelines indicating the target sizes. The writing patterns were shown by the experimenter using paper 

Page 5 of 18Backup

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh8C43.htm



cards. The subjects did not monitor their movements on the computer screen. The templates and examples are included in the experiment-property attachments.

Experiment WRD (Word Extraction)
Demonstrates the ability of MovAlyzeR to extract individual words from a long handwritten sample. There are two trials provided and a list of 500 conditions to run the experiment. Users may make their own lengthy recordings and tweak experiment parameters to get best results.

Experiment ALC (Alcohol Test)
Experiment to demonstrate the debilitating effects of alcohol on motor control. This experiment implements a number of tests that can be used to gauge the effect of alcohol on a given user.

<Previous
See Also

SetupStartCreate New UserDevice SetupExperiment SetupRun ExperimentChart and View TrialsAnalysisScanned Handwriting ImagesPrev: Bimanual Force CoordinationExample Experiments

© NeuroScript LLC. All Rights Reserved.

Frequently Asked Questions
1. What is MovAlyzeR?
2. What input devices can be used with MovAlyzeR?
3. Can I download the software and what are the requirements?
4. What are the basic steps to set up and run an experiment in MovAlyzeR ? 
5. What features of recording can I view/plot using the MovAlyzeR?
6. Is it possible to check the consistency of recordings I make? 
7. What are the optimum experiment settings that I should use? 
8. How do I check that my digitizer and display are mapped correctly? 
9. What does the message 'Error in initializing digitizer' is displayed, when I start MovAlyzeR, imply?
10. Can I obtain the statistical analysis chart for my data?
11. Is it possible to import/export data or experiment?
12. Can I extract individual words from a recording and how?
13. How do I make the targets/recording real size and print them? 

FAQ
NeuroScript MovAlyzeR Help Send comments on this topic.
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14. How are my data/stimuli/experiment going to differ if I use the mouse as my input device?
15. Can I reprogram the software to implement my own scripts or routines?
16. How do I report a problem to Neuroscript?
What is MovAlyzeR?
MovAlyzeR is a general purpose movement recording and analysis system for handwriting and drawing movements. MovAlyzeR enables professionals in the medical, gerontological, rehabilitation, ergonomical, psychological, psychiatrical, physiotherapy, forensic, and educational fields (among others) to obtain immediate, accurate recording and analysis of a person's handwriting, drawing, or other 2-dimensional movements. more..
Which type of input devices can be used with MovAlyzeR?
MovAlyzeR can record, process and analyze data using a mouse, tablet pen or a gripper. ScriptAlyzeR and MovAlyzeR can record mouse and tablet movements, whereas the GripAlyzeR records the gripper (or compatible external analog device) movements. 

Can I download the software and what are the requirements?
Yes. The MovAlyzeR installation file can be downloaded from the downloads page. Detailed requirements and instructions are also presented on this page. 

What are the basic steps to set up and run an experiment in MovAlyzeR ?
To set up and run a basic experiment, refer the tutorial with easy steps, examples and snapshots. Also available are precise steps on the online help introduction pages for each program, with cross-referenced links to the specific topics on each step. 

What features of recording can I view/plot using the MovAlyzeR?
Per trial, the processed data such as velocity, acceleration and jerk can be viewed in a text file and charted. MovAlyzeR parses movements in to segments/strokes. The segmentation points can be viewed in a file or shown on the charts (red circles). 
For each segment/stroke, features such as start time, duration, vertical length, velocity, acceleration, normalized jerk etc. are calculated. These data are available in a text file per condition and the charts can be viewed per trial. 
In addition, consistency error data and consistent data are presented in a text file. 
A summarized data and summarized error file are available per experiment, which give the data summary for analysis purposes. 

Is it possible to check the consistency of my recordings? 
Yes. Consistency checking can be applied to the trials and specifications can be set per condition. Based on the type and parameters specified, (e.g., length and direction of stroke), trials are accepted or rejected. The output consistency error file lists the reason a particular trial was rejected. The error summary file per experiment shows the corresponding statistics. 

What are the optimum experiment settings that I should use?
The Acquire button the Device Setup Wizard and the Experiment Properties > Input Device 
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window is the most accurate way to retrieve Sampling rate and resolution from the device 
driver.
The input device settings per experiment (e.g., sampling rate and resolution) should be specified as per the device used to collect data, and updated everytime the input device is changed, to yield correct results. Run experiment settings should also be specified according to the required timeouts. For a basic experiment, the other settings could use the default values. More..

How do I check that my digitizer and display are mapped correctly? 
The digitizer and display areas usually vary in size. The entire/portion of digitizer could be mapped proportionally to the entire display or recording window in MovAlyzeR. In the latter case, the size of the recording window is set to the size of the tablet. There are simple tests or precautions that can be done before the experiment is run. More..

What does the displayed message 'Error in initializing digitizer', when I start MovAlyzeR, imply?
This implies that either the digitizer driver is not installed on the computer or the driver needs updating. In order to use the digitizer tablet, the appropriate driver needs to be involved. (If you have a Wacom tablet, check http://www.wacom.com for the driver software). Please check your computer to see if the driver is installed and then retry opening the application. 
Can I obtain a statistical analysis chart for my data?
Yes. MovAlyzeR provides various options to chart the analyzed results of the trials. Although not extensive, this feature provides the user with a quick review of the results, which can be used to make corrective changes to the experiment or data collection. Upon satisfactory results, the data summary text file can be imported to more extensive statistical analysis programs, such as SPSS. More..

Is it possible to import/export data or experiments?
Yes. You can import MovAlyzeR, Accelerometer, Oasis, Eyelink and Gripper data in to MovAlyzeR for analysis. You can export MovAlyzeR trial data in the form of text files. An experiment can also be exported with or without associated data to be used by another user or on another computer. For more see File > Export in MovAlyzeR.
Can I extract individual words from a recording and how? 
Yes. You can extract a handwriting sentence (set of words or strokes) in a trial in to individual words by setting the appropriate word extraction properties in experiment settings per experiment. The individual words would be analyzed as seperate conditions and sub-trials will be generated accordingly. More.. 
How do I make the targets/recording real size and print them? 
The targets and recording can be made real size using the appropriate mapping settings. If such settings are chosen, a target element/recording would occupy the same size on the tablet as shown on the display. This would be highly efficient for trials with visual feedback. More..(including print real-size)
How are my data/stimuli/experiment going to differ if I use the mouse as my input device? 

Page 8 of 18Backup

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh8C43.htm



If you are using the mouse to collect data, specify that in the input device settings of the program (Settings > Select Input Device). Also, the appropriate sampling rate and resolution should be specified in all the corresponding Experiment Settings > Input Device Settings to avoid incorrect calculations. The sampling rate and resolution can be estimated while using MovAlyzeR. More..

Can I reprogram the software to implement my own scripts or routines?
Yes. Read External Processing Support in MovAlyzeR to learn how.

How do I report a problem to Neuroscript? 
The fastest response can be obtained by posting to the NeuroScript User Forums.
Else email your query, comment or suggestion to support@neuroscriptsoftware.com
Other ways to contact us http://www.neuroscript.net/contact.php

© NeuroScript LLC. All Rights Reserved.

Glossary
This is a common topic for MovALyzeR, GripAlyzeR and ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
This section lists all the commonly encountered keywords/phrases within the program. 

 Applies to MovAlyzeR, ScriptAlyzer and GripAlyzeR
 Applies only to MovAlyzeR and ScriptAlyzeR (except stimuli, targets, and submovements)
Applies only to GripAlyzeR

NOTE: These keywords/phrases when entered in to the help search box, returns all the relevant topics.
A B C D E F G   H   I J   K   L M N O P Q R S T U V W X   Y   Z

A
 ABSOLUTE JERK

See JERK first
Absolute Jerk value calculated at every sample from jerk values Jx and Jy as:
Jabs = {SQRT(Jx**2 + Jy**2)} * duration, units: cm3/s2

ABSOLUTE JERK Per Stroke
An extracted feature per stroke, which is calculated as the average of the squared values of absolute jerk (Jabs) at every sample point. 

ACTIVATION CODE 
Code generated by NeuroScript to be entered into your application. See also Authorization Request Code. 

Glossary
NeuroScript MovAlyzeR Help Send comments on this topic.

Page 9 of 18Backup

9/16/2016file:///C:/Users/hans3/AppData/Local/Temp/~hh8C43.htm



ACTIVATION REQUEST CODE 
See Authorization Request Code . 

 ANALYSIS CHART
A chart with several display and customization options to plot the statistical results per experiment. 

AUTHORIZATION REQUEST CODE 
We call this also Activation Request Code or ARC. It is a code generated by MovAlyzeR when running for the first time, or when purchasing or upgrading. This code needs to be sent to NeuroScript where an Activation Code will be generated and provided to you to be entered into your application.

B
BACKUP

An action that allows an extra copy of the experiment files and/or data to be stored on a local or network disk, so that experiments/data can be recovered in case of a problem. The program automatically prompts you to make a backup every time you exit the program. You can also customize you backup options. 

C
CLIENT

A computer on which MovAlyzeR/GripAlyzeR is installed, which interacts with the program on a central computer (server) that stores shared experiments and data.
 CONDITIONS

Different writing patterns (e.g., stroke to a 0.2-cm target at 45 degrees direction, write the word "elite") or may be the same writing pattern but executed under different instructions (e.g., as fast as possible, 2 cm large) or under a different exposure condition (e.g., distracting sounds) within the same experiment. Conditions may also differ by different stimuli or precues.
CONSISTENCY CHECKING

This feature per condition enables the program to check whether the trials meet a set of defined criteria to generate errors (and discard trials) or warnings. Hence, this allows certain trials to be separated as 'bad' trials and excludes them from summarization and statistical analysis. Trials can also be set to be checked for target reached errors. 
CONSISTENCY ERROR DATA

Error details including the nature and description for every trial that has been rejected (red check mark), based upon the consistency checking rules (or other automatically generated errors). This data is available in a text file per condition. If there is no error for a trial, the error file shows 'OK' for that trial.
CONSISTENT DATA

Processed data columns for every trial that has been accepted (green check mark). This data is written in a separate text file per condition. Only this data will be included in the summarization and final analysis per experiment. 
COORDINATES

The individual numbers produced by the movement recording device: x (horizontal position), y (vertical position), z (axial pen pressure) coordinates. More coordinates may be implemented in the future. Coordinates may have (integer or floating-point values) and are space separated 
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with 3 coordinates maximum per line.

D
DAQPAD

Data Acquisition device (National Instruments 6020E) which acts as the interface between the Gripper hardware and the GripAlyzeR program. The input device is chosen as DAQPad in GripAlyzeR when the data from Gripper hardware has to be collected. 
DATA GENERATION

Handwriting data patterns can be automatically generated by the program by using default or customized parameters. The data can be chosen to be included as a trial in a particular experiment, group, subject and condition. 
DATABASE

Hidden tables that store the different items, descriptions, properties and the relationships that define the structure of any experiment. These tables are located as files in the user folder (with extensions .dat and .idx) in the user root data path and transparent to the user (can be read only by the MovAlyzeR/GripAlyzeR program).
DELETE

Program operation which physically removes the selected item (group, condition...etc) from the database and will be no longer available.
 DIGITIZER

A digitizer consists of a pen and a flat tablet that digitizes the position of the pen tip on the surface, e.g., in terms of a horizontal (x) and vertical (y) coordinate, plus a penup/down or pen pressure coordinate (z). In some digitizers, pen orientation in x and y directions, axial rotation, and height can be measured, along with the movements of a second pen simultaneously (not implemented in MovAlyzeR or Scriptalyzer). Digitizer specifications and digitized data specifications are the number of levels per inch (e.g., 1270, 2540, 3048), and sampling rate (e.g., 100, 120, 200 Hz), and axial pen pressure (e.g., in 256 levels, not necessarily calibrated). The RMS accuracy of the x and y positions is larger than the resolution due to noise (e.g., 0.05 cm) and the constancy of the sampling rate.
DOWNLOAD (only for NETWORK VERSION)

Program operation performed from within the central user (UUU), which downloads a whole experiment or individual items in to a certain user. This can be performed only from list of items under the item folders in the left window tree. 

E
ELEMENTS

An object (square, rectangle, horizontal or vertical line) that can be used as a target. Attributes such as position, dimension, text, colors for successful/incorrect target, scheduling the appearance/disappearance on a time-line and animation, make the element very versatile. 
Only elements defined as targets can be sequenced and checked for target reached errors. Elements/targets have to be added to a stimulus (which in turn is added to an experiment condition), in order to make them functional and sequence them. 

EXPERIMENTS
Stand-alone tests that are done with the same device (Wacom UD series, mouse, imported data, Gripper data) requiring specific device settings.

EXPORT
The action through which a MovAlyzeR/GripAlyzeR experiment and/or data can be packaged in 
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to 1-3 files that can be used by another user or on another computer. 
EXTRACTED DATA

Parameters extracted per stroke/segment. These are listed in columns in a text file per condition.

F
FEEDBACK

Visual feedback presented on the display. Feedback can be customized with adjustable gain, rotation and other options per condition. 
FEEDBACK COLOR CODING 

Feedback of processed data charts of handwriting trials. Color coding schemes can be created and added per condition to color variations on charts, based on a certain processed data value. 
FILTERING

The steps in the processing of a movement pattern, where noise is reduced, based on the filter cut-off frequency specified per experiment. FFT and Butterworth low-pass filters are available in the program. 

G
GROUPS

Different populations of participants (e.g., 8-year olds, Grade 5, Young Adults, Patients) or different sessions that a person participated (e.g., before drug intake, the first training session) or different locations where data is collected (e.g., hospital, home, Phoenix).

I
IMPORT

The action through which a MovAlyzeR/GripAlyzeR experiment and/or associated data from another user or computer can be imported in to the current user. 
Data from other sources: The option 'data import wizard' allows data collected from other sources to be brought into a MovAlyzeR/GripAlyzeR experiment for processing and analysis. Example, processing and analysis of accelerometer data. 

 INCH
Measure of size (1 inch = 2.54 centimeters). Although in research the metric system is always used, many technical objects in research are in simple, rounded inch sizes. US paper sizes (e.g., 8.5x11, 8.5x14), digitizer sizes (e.g., 4x3, 8x6, 12x9), monitor-screen sizes (e.g., 15.2x11.4, 16x12), scanner sizes (matching paper sizes) are often in integer inches. Monitor screens are measured on the diagonal. The aspect ratio is often 4:3. Thus, diagonal:horizontal size:vertical size are related as 5:4:3. Monitor-screen diagonal sizes are mostly 15, 17, 19, 20, 21 inch. For LCD monitors the image size equals the screen size, but CRT monitors show images that are about 0.5 inch less than the tube specification. 

INPUT DEVICE 
A device connected to the computer, that can be sampled to obtain raw data in the program. MovAlyzeR uses a Wintab driver to collect data from the tablet. 
Mouse or Pen (tablet/digitizer) in MovAlyzeR and Gripper hardware in GripAlzyeR.

INSTRUCTION
Instructions can be used to provide the subject/experiment useful comments or steps to be 
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followed, before or during an experiment. Instruction can be provided at different levels: 
Experiment instructions per experiment, can be defined to be displayed before an experiment starts. Condition instructions settable per condition, can be chosen to display at the first trial or every trial of a condition. A short instruction can also be displayed in the toolbar during the trial recording. 

J
JERK 

Jerk is the third derivative of movement coordinates derived at different levels (units: cm/s**3). In MovAlyzeR, Jerk is calculated for x coordinates as Jx, and y coordinates as Jy. These are available as processed data and chart. 
See ABSOUTE JERK and NORMALIZED JERK.

L
LOGGING

A program operation which allows events occuring during any action performed in MovAlyzeR/GripAlyzeR to be logged into a Text file (LOG FILE). This file can be used for troubleshooting purposes and is usually required by NeuroScript for problem resolution. 

M
 MAGNETIC FORCE

Force value in Newtons units applied to the magnet in the Gripper hardware at the start of a trial. The value can be set per condition with the default value set to 8 N.

N
 NORMALIZE

Mathematical operation of a variable value so that its normalized value is rescaled into a known scale (e.g., a scale from 0 to 1) or a scale that does not depend upon the measurement scale (e.g., normalized jerk).
NORMALIZED JERK

See ABSOLUTE JERK.
Normalized integrated absolute jerk squared for the overall segment (normalization is not performed on submovements as normalization is only defined for complete strokes). 
FORMULA: SQRT (0.5 * SUM (Jabs(t)**2) * duration**5 / length**2). 

O
 OFFLINE

Offline signatures or offline handwriting are previously-written, optically scanned, static images, generated by a scanner. See Scanner.
ONE STROKE ANALYSIS (optional)

A process by which all the strokes are combined into one stroke during feature extraction that is commonly used in goal-directed movements. Data charts will display movement onset, offset, with segmentation points (and strokes). One Stroke Analysis combines the secondary submovement of the first stroke with consecutive strokes (even if a higher velocity peak occurs later in the movement).
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 ONLINE
Online signatures or online handwriting are presently-written, digitizer-recorded, time-changing, pen-movement signals which allow for the reconstruction of stroke sequence, pen speed, stroke duration, pen pressure, generated by a digitizer or tablet. See Digitizer.

P
PRIMARY SUBMOVEMENT

See also 'Secondary submovement'.
The initial ballistic segment of a movement (or stroke) that is considered to be under feedforward control. The primary submovement begins at movement onset with the end specified by the user, either aa the first zero-crossing of the velocity profile after peak velocity <or> at the first velocity minimia after peak velocity. All movements have a primary submovement. The total movement is comprised of the primary and secondary submovements.

PROCESS TRIALS
Process by which all the trials go through segmentation, feature extraction and consistency checking. By default, the trials are processed after every trial during recording. See REPROCESS TRIALS.

PROCESSED DATA
Resultant data after processing the raw data with filtering, rotation, etc. 
Data x-y-z position, velocity, acceleration, jerk, etc. at every sample point per trial may be viewed in a text file or a data chart.

Q
QUESTIONNAIRE

A list of questions assembled from the questionnaire template, per group under an experiment. The questionnaire can be presented to the participant before recording initiation, or at a later time. Results per subject can be viewed or used to create a report file.
QUESTIONNAIRE TEMPLATE

A master list/database of questions per user. The questions are intially created in the template and are available to be added to other questionnaires for any experiment for that user. 

R
 RADIAN (RAD)

Measure of angle: (PI radians = 180 degrees). Rules of thumb to convert to radians (rad) from degrees (deg).180 deg = PI rad (exact definition); 180 deg = 3.1416 rad (error 0.0005 deg) 180 deg = 3.00 +5% rad (error 0.5 deg) 90 deg = 1.5708 rad (error 0.0003 deg) 60 deg = 1.00 +5% rad (error 0.2 deg).45 deg = 0.75 +5% rad (error 0.2 deg).1 rad = 60 -5% deg (error 0.2 deg).
RAW DATA

X, Y and Z positional coordinates collected from the tablet/mouse (MovAlyzeR) or lower grip, upper grip and load force data from the Gripper hardware (GripAlyzeR)
Can be viewed in a text file or a chart per trial.
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RECORDING WINDOW
The portion of MovAlyzeR/GripAlyzeR window on the display used for mapping to the tablet area and where all the recordings will be displayed. The size of the recording window can be set to the size of the tablet <or> the entire display (area available after displaying toolbars, left tree menu, etc.).

REDO TRIAL
An option in which the user can choose to repeat a particular trial. Redo trial can be performed after the experiment is completed <or> an option can be set such that the program prompts during recording to redo a trial (1) after every trial <or> (2) manually redo if the trial is bad <or> (3) automatically redo if the trial is bad. 

RELATIONSHIP
The point of integration of different items within an experiment. The 'View Relationship' option can be used to view the relationship between subjects, groups, conditions, experiments, etc. 

 RELATIVE
Mathematical operation of a variable's value so that its relative value is a fraction or a percentage of the value it is compared to (e.g., relative time to peak velocity).

REPROCESS TRIALS
Process by which all the trials go through segmentation, feature extraction and consistency checking after recording is completed. Trials will need to be reprocessed anytime an experiment or condition setting is changed.

RESET INPUT DEVICE
A program action that resets all the resources used by the input device. It aids to clear up any problems encountered by the program while interacting with the input device. 

RESOLUTION (Device Resolution)
A value that specifies the distance in cm that corresponds with a data difference of 1. It can be set per experiment, depending on the input device used for that experiment. 

RESULTS WINDOW
The bottom window in the program that displays in real time all the events occuring during any action (e.g., the steps during recording). These can also be written to a LOG FILE for later viewing or for troubleshooting. 

ROOT DATA PATH
Path of the folder on the local or network disk where the data and the experiment files per user are stored (e.g., C:\MovAlyzeR data\USR). The default is the folder where MovAlyzeR is installed. Similarly, root path can also be specified to store a backup copy of all the files (e.g., on another disk, E:\MovAlyzeR data\USR\backup).
Please note that the user has to have read and write permissions for the folder/s selected. 

S
SAMPLES

The coordinates at each specified point in time recorded by the recording device, the importing device, or the data simulator. Ideally, samples are taken at a constant and known rate that is specified.
SAMPLING RATE

An input device parameter defined as the number of samples per second (Hz = 1/second). It can be set per experiment, depending on the input device used for that experiment. 
 SCANNER
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A scanner consists of a glass plate with a photosensitive bar that scans underneath the glass plate thus creating an image of the paper positioned on top of the glass plate. The image data consist of a sequence of pixels, each having color or gray level. The image data contains information about size, location, pen-stroke width, line quality, paper quality, ink color. The image data from huge files, e.g., in PCS format, which can be compressed (with little loss of information) into JPG or JPEG files (better for pictures) or TIF or TIFF files (better for line drawings). Scanner and image specifications include lines per inch (e.g., 300, 600, 1200), number of color levels (e.g., 256) or gray levels (e.g., 16 or 2).
SECONDARY SUBMOVEMENT(S)

See also 'Primary submovement'.
The corrective, or homing-in, segment of a movement (or stroke) that is considered to be under feedback control. The secondary submovement begins at the end of the primary submovement and ends at movement offset. Movements (or strokes) may or may not have secondary submovements. The total movement is comprised of the primary and secondary submovements.

SEGMENTS
See 'Strokes'.
Submovement analysis parses a stroke (or movement) into three segment measures: a primary submovement, a secondary submovement, and the total movement, per stroke. Hence, 1 stroke produces 3 segments. If submovement analysis is not performed, then segment and stroke are the same (1 stroke = 1 segment).

SERVER
A central network computer on which shared experiment or data can be stored, and accessed by all authenticated users (client computers). This computer runs a Ctree-server program to facilitate sharing and security. 

SOUND
A type of stimulus that can be set per condition, for any event occuring during recording to act as a signal to the user or participant (e.g., a beep at the start of recording or .wav file at the start of stimulus).

STATUS BAR (Progress Meter)
An indicator at the bottom tool bar (similar to the one on any web browser) that shows the progress of any action (e.g., recording). On the left portion of the toolbar, the % of progress is also shown. 

STIMULUS (Visual)
A group of target or non-target elements which are displayed on the screen during recording (imperative) or before recording (warning or precue), assigned per condition. The targets/elements are listed in the sequence they are to be reached. 
For example, in a condition where the trial involves moving from a home position to target position, there will be two targets (home and target, listed in the same order) under a stimulus. 

STROKE
Strokes are parsed movements that string together a movement pattern. Currently, a movement pattern can be segmented using 2segmentation methods: zero-crossings of the velocity profile after peak velocity, or the velocity minimia after peak velocity.

STROKE DESCRIPTION
A single or combination of symbols and letters used to define a pattern that has to be met by a movement in a trial in order to pass the consistency checking test. 

SUBJECTS
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Individual participants in an experiment (e.g., name and other characteristics are entered). The experiment date is generated automatically and is used to calculate the subject's age a the time of the experiment. An updateable questionnaire is produced for each subject. A subject may participate in multiple sessions, or experiments.
SUBMOVEMENTS

Separate subsegments of a stroke. Currently, a stroke is segmented into the primary and secondary submovements at the first negative-to-positive zero crossing, or minimia, of the velocity after the peak velocity.

T
 TABLET

See 'Digitizer'.
TARGET

An element can be defined as a target to display all the dynamic properties during recording. 
TARGET USE/SEQUENCE

A list that describes the template for the correct order of targets to be reached. Existing/new target elements can be added and arranged within this list. Sound or color changes included in the elements behave based on this list to signal the user or the subject in real-time (during recording) that the correct/incorrect targets have been reached. 
 TRACELENGTH

Trace length (tracelength) is the length of a segment from begin to end, following its trajectory. This feature is extracted from handwriting movements or from images. It is calculated by summing the distances between all consecutive samples or pixels. Alternative names: Path length, contour length, road length, trajectory length. Related features are: horizontal size, vertical size of a stroke or the absolute size (=vector addition or the size of the resultant vector).
TRIALS

Multiple replications of the same condition. In learning tests, Trial may be a dimension of analysis by itself. A gray check mark next to the trial indicates that the data have not yet been processed, a green check mark indicates a good trial and a red check mark indicates a bad trial (based on the specified criteria).
TRIGGER PULSE

A pulse that is sent through the DTR pin (pin 4) of the serial (COM) port. The pulse starts with a high-to-low transition and remains low for 50 ms. It can be set per condition to be fired at various events during recording. It is useful to synchronize MovAlyzeR/GripAlyzeR with other programs/hardware. 

U
USER

A person using MovAlyzeR/GripAlyzeR, who has an account with password (default password: userpass), and has full control including subject data. 
UPLOAD (only for NETWORK VERSION)

Program operation performed from within any user, which uploads a whole experiment or individual items in to a shared central user (UUU). This can be performed only from the list of items under the item folders in the left window tree. 
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V
VIEW DATA

A program action by which various experiment, processed and resultant data can be viewed in a tabular format as well as in a text file. The data can also be plotted using the 'CHART DATA' options. 

W
WORD EXTRACTION

The process by which the MovAlyzeR/ScriptAlyzeR extracts individual words from a sentence or group of strokes based on a set of pre-defined criteria. Usually used in handwriting experiments.
WIZARD

Easy step-by-step procedure to automatically perform tasks such as Setup Experiment, Run Experiment, and Generate customized data. 

© NeuroScript LLC. All Rights Reserved.

Whenever MovAlyzeR terminates abnormally or crashes, a reporting procedure is initiated to submit relevant information to the development team at NeuroScript. This process is essential in improving the software and no personally identifiable information is collected during this process.
MovAlyzeR detects an abnormal termination the first time it is run after the crash. The reporting system asks a series of questions inquiring about the series of events that led to the crash. An internally generated log file is also attached to the report. It is imperative for the user to answer all questions as accurately as possible to assist in identifying the source of the problem resulting in faster fixing of errors, if any.

© NeuroScript LLC. All Rights Reserved.

Reporting abnormal termination of MovAlyzeR
NeuroScript MovAlyzeR Help Send comments on this topic.
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Trouble Shooting
This is a common topic for MovALyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
To allow us to help efficiently in case of software problems, proceed as follows: 
(1) If you use a digitizer, troubleshoot the WinTab™ driver first. All major digitizer manufacturers have developed their Wintab™ compliant drivers.
(2) Verify that your system works properly. In case of doubt, close all applications, reboot your system and try again. 
(3) See our downloads web page for more recent downloads, known problems and solutions. 
(4) Identify the problem in MovAlyzeR. Report any problems to NeuroScript, stating what you were doing before the problem occurred, what information the screen shows and which particular system you are running. You can also e-mail the recent part of the log file via File > Logging > Send File.
* Installation
* WinTab
* ScriptAlyzeR/MovAlyzeR
* Known Problems and Remedies

Troubleshooting Installation
o If MovAlyzeR fails to open or displays error messages after installation, verify that you have uninstalled the previous version before installing a newer version. 
o If not, go to control panel > Add/Remove programs > Remove MovAlyzeR (older version). In the same window, verify that MovAlyzeR is not listed anymore as one of the installed programs. Run the .msi file (newer version) and follow the installer instructions.

Troubleshooting WinTab
When the digitizer does not seem to work or Wintab or the digitizer is mentioned in error reports, you should verify whether Wintab works properly.
o Click My Computer > Control Panel. 
o Find your tablet driver, open it and find the testing option.
o Verify that you can write in the test window. 
If this test is not successful it is often fastest to reinstall Wintab. Only one Wintab driver can be installed at a time.
Reinstall Wintab Driver
The standard solution for digitizer driver problems is to reinstall.
o Click My Computer > Control Panel > Add/Remove Programs. 
o Uninstall your tablet driver.
o Disconnect the digitizer. 
o Restart your system (which removes remaining files that were in use) with the digitizer still disconnected.
o Connect the digitizer after completing startup. 
o Run the digitizer driver install procedure, e.g.,

Trouble Shooting
NeuroScript MovAlyzeR Help Send comments on this topic.
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~ Download the latest version from your digitizer manufacturer's web site, into c:\{MANUFACTURERNAME}, where {MANUFACTURERNAME} is the digitizer manufacturer's name. The driver installation software may be run from the "current location" but saving first to disk is less error prone.
~ Execute the download in case it is a self-extracting program, or unzip it, e.g., using Winzip from http://www.winzip.com.
~ Open the setup program and follow the instructions. Another restart of the system may be needed at the end.

o Be alert that upgrading may result in non-working software. Be reluctant in upgrading without compelling reason.
If problems persist, check the following:
(1) Check the digitizer power is on and the data cable is connected to the correct port. 
(2) Check that the digitizer driver is in the control panel and can be activated: click My Computer > Control Panel > Your Tablet Driver, and check port identity and settings via Connection. 
(3) For MSWindowsNT/2000/XP or later:  o My Computer > Control Panel > Services (double click). o Stop TabletService. o Start TabletService. 
(4a) For MSWindowsNT/2000/XP or later: o Delete \winnt\system32\wacom.dat. 
(4b) For MSWindows95/97/ME or later: o Delete \windows\swacom.dat. 
(5) Shut down, power down the PC, wait 10 s, start the PC and try again. 
If the problem persists: 
o Try an older driver that has worked in the past.
o Inspect the manufacturer's web site for known bugs. Download the more recent WinTab drivers. 
o Contact customer service of your digitizer manufacturer. 
o Contact LCS/Telegraphics by e-mail: feedback@pointing.com, Tel +1-617-225-7970 EST or wintab@pointing.com, Tel +1-617-225-7969 EST or via http://www.pointing.com. 
o Contact NeuroScript if previous measures failed. 

Troubleshooting ScriptAlyzeR/MovAlyzeR
If a problem occurs while running MovAlyzeR, please e-mail NeuroScript the last 20 lines of the actions.log file: o Click File > Logging > Log Actions to File should be check marked. o Click File > Logging > View Log File. o Move to the end of the file and select approximately 20 lines by dragging the mouse over the text, Save (Control/S), Click your e-mail window, Paste (Control/V). o E-mail us also the literal text of the beginning of the system error message. o You may want to clear the log file clicking File > Logging > Clear Log File. 
o Less urgent problems, remarks, suggestions can be included in the actions.log file by Clicking File > Logging > Add Issue/Comment to Log, and e-mail (part of) the log file to NeuroScript (see Actions_Log). 
o If a severe software problem occurs, you need to check first whether the problem can be reproduced (and note the conditions when the problem recurs). Make sure to reboot the system and that no back ground programs interfere. 
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o Verify that the latest version of MovAlyzeR is being used, otherwise download and install the latest version.
o Shut down the PC, switch off the PC, wait 10 seconds, start the PC, start only the MovAlyzeR application and check whether the problem recurs. 

Known Problems and Remedies
Problem: The stimuli are not shown in the specified area on the display or the stimuli are pushed towards a corner.
Troubleshooting:
o Verify that for the stimulus elements, Element > Properties > Dimensions shows the right dimensions. The Center point x and y coordinates are plotted with the left bottom corner of the recording window as the origin.
o If you want the stimulus to be displayed real-size on the screen/tablet, verify that both the following switches are set.

1. Settings (main tool bar) > Select input device > Input device > Mapping > 'Recording window' and 'Proportional' are checked. The tablet and display sizes should be specified correctly.2. Experiment > Experiment settings > Run Experiment Trial Settings > 'Make recording window real size' is checked. 
If you set only 1. or 2., the stimuli might be greatly displaced.
o If you want to use most of the display as the recording window, set both of the following options:

1. Settings (main tool bar) > Select input device > Input device > Mapping > 'Entire display' and 'Proportional'. The tablet and display sizes should be specified correctly.2. Experiment > Experiment settings > Run Experiment Trial Settings > 'Maximize recording window'.
If you set only 1. or 2. then the stimuli might be greatly displaced.
o Before running the experiment with stimuli, you can test the functionality of individual stimulus by right clicking on the particular stimulus > Test in recording window.

© NeuroScript LLC. All Rights Reserved.

Trouble Shooting
This topic is ONLY for GripAlyzeR.
To allow us to efficiently help in case of software problems, please proceed as follows: 
(1) Verify that that your system works properly. In case of doubt, close all applications and reboot your system and try again. 
(2) See our downloads web page for more recent downloads, known problems and solutions. 
(3) Identify the problem in GripAlyZeR. Report any problems to NeuroScript, stating what you were doing before the problem occurred, what information the screen shows, and which particular system you are running. You can also e-mail the recent part of the log file via File >Logging > Send File

Trouble Shooting (Gripper)
NeuroScript MovAlyzeR Help Send comments on this topic.
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Trouble Shooting GripAlyzeR
If a problem occurs while running MovAlyzeR, please, e-mail us the last 20 lines of the Actions.log file: o Click File > Logging > Log Actions to File should be check marked. o Click File > Logging > View Log File o Move to the end of the file and select about 20 lines by dragging the mouse over the text, Save (Control/S), Click your e-mail window, Paste (Control/V) o E-mail us also the literal text of the beginning of the system error message. o You may want to clear the log file clicking File >Logging >Clear Log File 
o Less urgent problems, remarks, suggestions can be included in the actions.log file by Clicking File >Logging >Add Issue/Comment to Log, and e-mail (part of) the log file to NeuroScript (See Actions_Log) 
o If a severe software problem occurs, you should first check whether the problem can be reproduced (and note the conditions when the problem reoccurs). Make sure to reboot the system and that no background programs interfere. 
o Verify that the version used is less than 1 month old, otherwise a new version may be downloaded and tested. 
o Shut down the PC, switch off the PC, wait 10 seconds, start the PC, start only the MovAlyzeR application and check whether the problem reoccurs. 

© NeuroScript LLC. All Rights Reserved.

Contact NeuroScript
Mail:   1225 E Broadway Rd, Ste. 100         Tempe, AZ 85282, USATel:    +1-480-350-9200         +1-866-638-2800 (U.S. Toll Free) Fax:   +1-480-350-9199

E-mail: support@neuroscriptsoftware.comWebsite: http://www.neuroscript.net

© NeuroScript LLC. All Rights Reserved.
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Trouble Shooting
This is a common topic for MovALyzeR & ScriptAlyzeR. These programs will be referred to as MovAlyzeR on this page.
To allow us to help efficiently in case of software problems, proceed as follows: 
(1) If you use a digitizer, troubleshoot the WinTab™ driver first. All major digitizer manufacturers have developed their Wintab™ compliant drivers.
(2) Verify that your system works properly. In case of doubt, close all applications, reboot your system and try again. 
(3) See our downloads web page for more recent downloads, known problems and solutions. 
(4) Identify the problem in MovAlyzeR. Report any problems to NeuroScript, stating what you were doing before the problem occurred, what information the screen shows and which particular system you are running. You can also e-mail the recent part of the log file via File > Logging > Send File.
* Installation
* WinTab
* ScriptAlyzeR/MovAlyzeR
* Known Problems and Remedies

Troubleshooting Installation
o If MovAlyzeR fails to open or displays error messages after installation, verify that you have uninstalled the previous version before installing a newer version. 
o If not, go to control panel > Add/Remove programs > Remove MovAlyzeR (older version). In the same window, verify that MovAlyzeR is not listed anymore as one of the installed programs. Run the .msi file (newer version) and follow the installer instructions.

Troubleshooting WinTab
When the digitizer does not seem to work or Wintab or the digitizer is mentioned in error reports, you should verify whether Wintab works properly.
o Click My Computer > Control Panel. 
o Find your tablet driver, open it and find the testing option.
o Verify that you can write in the test window. 
If this test is not successful it is often fastest to reinstall Wintab. Only one Wintab driver can be installed at a time.
Reinstall Wintab Driver
The standard solution for digitizer driver problems is to reinstall.
o Click My Computer > Control Panel > Add/Remove Programs. 
o Uninstall your tablet driver.
o Disconnect the digitizer. 
o Restart your system (which removes remaining files that were in use) with the digitizer still disconnected.
o Connect the digitizer after completing startup. 
o Run the digitizer driver install procedure, e.g.,

Trouble Shooting
NeuroScript MovAlyzeR Help Send comments on this topic.
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~ Download the latest version from your digitizer manufacturer's web site, into c:\{MANUFACTURERNAME}, where {MANUFACTURERNAME} is the digitizer manufacturer's name. The driver installation software may be run from the "current location" but saving first to disk is less error prone.
~ Execute the download in case it is a self-extracting program, or unzip it, e.g., using Winzip from http://www.winzip.com.
~ Open the setup program and follow the instructions. Another restart of the system may be needed at the end.

o Be alert that upgrading may result in non-working software. Be reluctant in upgrading without compelling reason.
If problems persist, check the following:
(1) Check the digitizer power is on and the data cable is connected to the correct port. 
(2) Check that the digitizer driver is in the control panel and can be activated: click My Computer > Control Panel > Your Tablet Driver, and check port identity and settings via Connection. 
(3) For MSWindowsNT/2000/XP or later:  o My Computer > Control Panel > Services (double click). o Stop TabletService. o Start TabletService. 
(4a) For MSWindowsNT/2000/XP or later: o Delete \winnt\system32\wacom.dat. 
(4b) For MSWindows95/97/ME or later: o Delete \windows\swacom.dat. 
(5) Shut down, power down the PC, wait 10 s, start the PC and try again. 
If the problem persists: 
o Try an older driver that has worked in the past.
o Inspect the manufacturer's web site for known bugs. Download the more recent WinTab drivers. 
o Contact customer service of your digitizer manufacturer. 
o Contact LCS/Telegraphics by e-mail: feedback@pointing.com, Tel +1-617-225-7970 EST or wintab@pointing.com, Tel +1-617-225-7969 EST or via http://www.pointing.com. 
o Contact NeuroScript if previous measures failed. 

Troubleshooting ScriptAlyzeR/MovAlyzeR
If a problem occurs while running MovAlyzeR, please e-mail NeuroScript the last 20 lines of the actions.log file: o Click File > Logging > Log Actions to File should be check marked. o Click File > Logging > View Log File. o Move to the end of the file and select approximately 20 lines by dragging the mouse over the text, Save (Control/S), Click your e-mail window, Paste (Control/V). o E-mail us also the literal text of the beginning of the system error message. o You may want to clear the log file clicking File > Logging > Clear Log File. 
o Less urgent problems, remarks, suggestions can be included in the actions.log file by Clicking File > Logging > Add Issue/Comment to Log, and e-mail (part of) the log file to NeuroScript (see Actions_Log). 
o If a severe software problem occurs, you need to check first whether the problem can be reproduced (and note the conditions when the problem recurs). Make sure to reboot the system and that no back ground programs interfere. 
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o Verify that the latest version of MovAlyzeR is being used, otherwise download and install the latest version.
o Shut down the PC, switch off the PC, wait 10 seconds, start the PC, start only the MovAlyzeR application and check whether the problem recurs. 

Known Problems and Remedies
Problem: The stimuli are not shown in the specified area on the display or the stimuli are pushed towards a corner.
Troubleshooting:
o Verify that for the stimulus elements, Element > Properties > Dimensions shows the right dimensions. The Center point x and y coordinates are plotted with the left bottom corner of the recording window as the origin.
o If you want the stimulus to be displayed real-size on the screen/tablet, verify that both the following switches are set.

1. Settings (main tool bar) > Select input device > Input device > Mapping > 'Recording window' and 'Proportional' are checked. The tablet and display sizes should be specified correctly.2. Experiment > Experiment settings > Run Experiment Trial Settings > 'Make recording window real size' is checked. 
If you set only 1. or 2., the stimuli might be greatly displaced.
o If you want to use most of the display as the recording window, set both of the following options:

1. Settings (main tool bar) > Select input device > Input device > Mapping > 'Entire display' and 'Proportional'. The tablet and display sizes should be specified correctly.2. Experiment > Experiment settings > Run Experiment Trial Settings > 'Maximize recording window'.
If you set only 1. or 2. then the stimuli might be greatly displaced.
o Before running the experiment with stimuli, you can test the functionality of individual stimulus by right clicking on the particular stimulus > Test in recording window.

© NeuroScript LLC. All Rights Reserved.

Trouble Shooting
This topic is ONLY for GripAlyzeR.
To allow us to efficiently help in case of software problems, please proceed as follows: 
(1) Verify that that your system works properly. In case of doubt, close all applications and reboot your system and try again. 
(2) See our downloads web page for more recent downloads, known problems and solutions. 
(3) Identify the problem in GripAlyZeR. Report any problems to NeuroScript, stating what you were doing before the problem occurred, what information the screen shows, and which particular system you are running. You can also e-mail the recent part of the log file via File >Logging > Send File
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Trouble Shooting GripAlyzeR
If a problem occurs while running MovAlyzeR, please, e-mail us the last 20 lines of the Actions.log file: o Click File > Logging > Log Actions to File should be check marked. o Click File > Logging > View Log File o Move to the end of the file and select about 20 lines by dragging the mouse over the text, Save (Control/S), Click your e-mail window, Paste (Control/V) o E-mail us also the literal text of the beginning of the system error message. o You may want to clear the log file clicking File >Logging >Clear Log File 
o Less urgent problems, remarks, suggestions can be included in the actions.log file by Clicking File >Logging >Add Issue/Comment to Log, and e-mail (part of) the log file to NeuroScript (See Actions_Log) 
o If a severe software problem occurs, you should first check whether the problem can be reproduced (and note the conditions when the problem reoccurs). Make sure to reboot the system and that no background programs interfere. 
o Verify that the version used is less than 1 month old, otherwise a new version may be downloaded and tested. 
o Shut down the PC, switch off the PC, wait 10 seconds, start the PC, start only the MovAlyzeR application and check whether the problem reoccurs. 
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Contact NeuroScript
Mail:   1225 E Broadway Rd, Ste. 100         Tempe, AZ 85282, USATel:    +1-480-350-9200         +1-866-638-2800 (U.S. Toll Free) Fax:   +1-480-350-9199

E-mail: support@neuroscriptsoftware.comWebsite: http://www.neuroscript.net
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